KernelCare Blog

KernelCare supports many distributions, but does it work with your kernel?

KernelCare supports many distributions, but does it work with your kernel?

We often get a question whether a particular kernel is supported by KernelCare. We support a large number of distributions and kernel versions, such as CentOS/RHEL/CL 5,6 & 7, Debian, Ubuntu, Virtuozzo & Proxmox VE. List of all supported distributions, kernels, as well as patches for them is available at http://patches.kernelcare.com.

Yet, to simplify the process, we have released a simple script that you can run on your server to find out for sure.

https://github.com/iseletsk/kernelchecker/blob/master/py/kc-compat.py

It can be executed by running:

curl -s https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py|python

Or ...

wget -qq -O - https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py|python

The script will respond with:

  • COMPATIBLE -> kernel supported by KernelCare
  • UNSUPPORTED -> KernelCare doesn’t recognize the kernel
  • UNSUPPORTED; INSIDE CONTAINER -> running inside the container, unable to patch kernel

 

COM_EASYBLOG_TOPIC: KernelCare Blog , Tags: #CentOS, #Debian, #Ubuntu, #virtuozzo, #Proxmox,

2934 people viewed this

Comments (14)

 
by Guest - Michael Dance / 21.04.2016 20:57

Nice script Igor :).

Nice script Igor :).
by Guest - Mr. Nam / 23.04.2016 07:19

Hello,
I can't install kernelcare for my server is running Cloudlinx 7.2.
Please check again.
# wget -qq -O - https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py|python
(False, 'UNSUPPORTED')
uname -a
Linux xxxxxxxx.xxxxx.xxxxx 3.10.0-427.10.1.lve1.4.7.el7.x86_64 #1 SMP Sat Apr 2 12:09:46 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux

Hello, I can't install kernelcare for my server is running Cloudlinx 7.2. Please check again. # wget -qq -O - https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py|python (False, 'UNSUPPORTED') uname -a Linux xxxxxxxx.xxxxx.xxxxx 3.10.0-427.10.1.lve1.4.7.el7.x86_64 #1 SMP Sat Apr 2 12:09:46 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
by WisiKlo WisiKlo / 23.04.2016 17:50

Please, try now. This has been fixed.

Please, try now. This has been fixed.
by Guest - Victor Coss / 07.05.2016 22:20

[[email protected]:~]curl -s https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py|python
UNSUPPORTED
[[email protected]:~]uname -a
Linux excession.server.gtaxl.net 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u6 (2015-11-09) x86_64 GNU/Linux
[[email protected]:~]cat /etc/debian_version
8.4

WHAT? :( But I see it listed here, http://patches.kernelcare.com/e89cc28de257ef3f903fcb12e94e4e8391763f81/9/kpatch.html

[[email protected]:~]curl -s https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py|python UNSUPPORTED [[email protected]:~]uname -a Linux excession.server.gtaxl.net 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u6 (2015-11-09) x86_64 GNU/Linux [[email protected]:~]cat /etc/debian_version 8.4 WHAT? :( But I see it listed here, http://patches.kernelcare.com/e89cc28de257ef3f903fcb12e94e4e8391763f81/9/kpatch.html
by WisiKlo WisiKlo / 07.05.2016 22:35

The version you have is 3.16.0.x
The earliest we support is 3.16.7
sorry :(

The version you have is 3.16.0.x The earliest we support is 3.16.7 sorry :(
by WisiKlo WisiKlo / 07.05.2016 22:36

Actually - you are right, it should be supported, let me try/double check.

Actually - you are right, it should be supported, let me try/double check.
by WisiKlo WisiKlo / 07.05.2016 22:49

Please, try now, small bug in the script was causing it.

Please, try now, small bug in the script was causing it.
by Guest - Reiner030 / 12.05.2017 20:17

Nice that also Debian 8 is supported. :)
But not so nice, that the 4.9 Debian Jessie-backports kernel were missing :(

Perhaps that can be improved because 4.x kernels have much better SSD/filesystem
support/performance and you already offer such kernels for other vendors?

Nice that also Debian 8 is supported. :) But not so nice, that the 4.9 Debian Jessie-backports kernel were missing :( Perhaps that can be improved because 4.x kernels have much better SSD/filesystem support/performance and you already offer such kernels for other vendors?
by Kateryna Obiidykhata / 19.05.2017 12:05

Hi!
The support of such kernels will be available in one week.
Thanks!

Hi! The support of such kernels will be available in one week. Thanks!
by Guest - Reiner030 / 13.07.2017 13:36

Hi,

pretty that now also Debian 9 / 4.9.x kernels are supported but still Debian 8 Backports 4.9 ones are missing ;)
And since the networking/firewall handling was totally modified it would take longer time to adopt setup from Debian Jessie to Debian Stretch so this request still makes sense ...

Thx

Hi, pretty that now also Debian 9 / 4.9.x kernels are supported but still Debian 8 Backports 4.9 ones are missing ;) And since the networking/firewall handling was totally modified it would take longer time to adopt setup from Debian Jessie to Debian Stretch so this request still makes sense ... Thx
by Guest - NInad Shirgaonkar / 28.06.2017 06:28

Hi,

Latest VZ kernel 2.6.32-042stab123.6 is not supported by KernelCare. Please add it.

[[email protected] ~]# /usr/bin/kcarectl --update
Unknown Kernel (CentOS 2.6.32-042stab123.6)

Hi, Latest VZ kernel 2.6.32-042stab123.6 is not supported by KernelCare. Please add it. [[email protected] ~]# /usr/bin/kcarectl --update Unknown Kernel (CentOS 2.6.32-042stab123.6)
by Guest - Torsten Walther / 13.07.2017 10:31

Hello,

/usr/bin/kcarectl --update
Unknown Kernel (Virtuozzo Linux 3.10.0-514.16.1.vz7.30.10)

Pleas add it.



Hello, /usr/bin/kcarectl --update Unknown Kernel (Virtuozzo Linux 3.10.0-514.16.1.vz7.30.10) Pleas add it.
by Guest - Steve / 18.07.2017 00:46

Hi, I have 3.10.0-614.10.2.lve1.4.72 and have just purchased KC after a trial. The trial did not warn that the Kernel was not supported. Can you please advise

Hi, I have 3.10.0-614.10.2.lve1.4.72 and have just purchased KC after a trial. The trial did not warn that the Kernel was not supported. Can you please advise
by Guest - Karim Saied / 10.10.2017 09:09

I received the below error when i tried to install kernelcare

Error: kernelcare conflicts with uptrack-1.2.41-0.el6.noarch
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I received the below error when i tried to install kernelcare Error: kernelcare conflicts with uptrack-1.2.41-0.el6.noarch You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

Leave your comment

Guest, 18.10.2017

Captcha Image