Ошибка: не удается войти в рабочую область
Форум
  1. Forums
  2. General
  3. General Discussion
  1. chcp a
  2. Friday, 29 October 2010
  3.  Subscribe via email
On php script petition
Rate this post:
  1. 29.10.2010 04:10:14
  2. # 1
chcp a Accepted Answer
Posts: 20
Joined: 29.10.2010
0
Votes
Undo
Hi,

We are testing lve with mod_fcgid and we are receiving this error. Dont know at this moment why it happens.

Error: Can\'t enter to lve from slave context user_id

Thanks in advance
  1. 29.10.2010 07:10:53
  2. # 2
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
Usually this is due to conflict between mod_hostinglimits and mod_fcgid
Could you disable mod_hostinglimits and see if that resolves the issue.
If it does -- you need to go through AddHandlers in modhostinglimits.conf and remove those that are handled by mod_fcgid.

What control panel are you using?
  1. 29.10.2010 08:10:33
  2. # 3
chcp a Accepted Answer
Posts: 20
Joined: 29.10.2010
0
Votes
Undo
That was correct,

Once we commented the mod_hostinglimits handlers it worked fine. We are using cpanel with mod_fcgid .

Thanks a lot ;)
  1. 29.10.2010 08:10:28
  2. # 4
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
Are you using MPM Worker or MPM Prefork?
If pre-fork -- you still want mod_hostinglimits for CGI scripts.
Edit modhostinglimits.conf
And remove all handlers related to PHP, after that you should be able to re-enable it.

Also, how did you install mod_fcgid, via install-lve, or via latest cpanel-lve?
I want to try to replicate the issue in house. It should have worked out of the box.
  1. 02.11.2010 04:11:31
  2. # 5
chcp a Accepted Answer
Posts: 20
Joined: 29.10.2010
0
Votes
Undo
Hi,

The thing is that we did a conversion centos to clodlinux , mod_fcgid is installed with cpanel tools afaik. I think it should work fine with the out-of-the-box configuration since we have some custom modifications in the mod_fcgid configuration for the php handlers. The conflict between the modules is normal once you see modhostinglimits.conf content and custom modifications. But with the \'enable lve 0N\' for mod_fcgid it works ok once you edit the handlers. We are using prefork in apache.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
гость
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.