Отсутствует зависимость lve-0.7.1-2.el5.
Форум
  1. Forums
  2. General
  3. General Discussion
  1. kernow
  2. Thursday, 26 August 2010
  3.  Subscribe via email
Missing Dependency lve-0.7.1-2.el5
Rate this post:
  1. 26.08.2010 00:08:10
  2. # 1
kernow Accepted Answer
Posts: 72
Joined: 06.08.2010
0
Votes
Undo
lve-0.7.1-2.el5.cloudlinux.x86_64 from cloudlinux-x86_64-server-5 has depsolving problems
--> Missing Dependency: kmod-lve >= 0.7 is needed by package lve-0.7.1-2.el5.cloudlinux.x86_64 (cloudlinux-x86_64-server-5)
  1. 26.08.2010 07:08:13
  2. # 2
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
Most likely you have kernel listed as excluded package in yum.conf
  1. 26.08.2010 08:08:13
  2. # 3
kernow Accepted Answer
Posts: 72
Joined: 06.08.2010
0
Votes
Undo
No, its not listed there, we already checked.
exclude=apache* bind-chroot centos-yumconf courier* dovecot* exim* httpd* mod_ssl* mysql* nsd* perl* php* proftpd* pure-ftpd* ruby* spamassassin* squirrelmail* wget

What is kmod-lve ?
  1. 26.08.2010 09:08:25
  2. # 4
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
What is the output of
rpm -qa kernel

And does it offer you to install any kernel when you do
yum install kernel
?

Also, can you show what is in /etc/sysconfig/kernel
  1. 26.08.2010 09:08:15
  2. # 5
kernow Accepted Answer
Posts: 72
Joined: 06.08.2010
0
Votes
Undo
kernel-2.6.18-294.8.1.el5.lve0.6.23
Yum offers to install new kernel and says dependancies resolved:
Resolving Dependencies
--> Running transaction check
---> Package kernel.x86_64 0:2.6.18-294.8.1.el5.lve0.7.32 set to be installed
--> Processing Dependency: liblve >= 0.7 for package: kernel
--> Running transaction check
---> Package liblve.x86_64 0:0.7.1-2.el5.cloudlinux set to be updated
--> Processing Dependency: lve = 0.7.1-2.el5.cloudlinux for package: liblve
--> Running transaction check
--> Processing Dependency: lve = 0.6.1-3.el5.cloudlinux for package: liblve-devel
---> Package lve.x86_64 0:0.7.1-2.el5.cloudlinux set to be updated
--> Running transaction check
---> Package liblve-devel.x86_64 0:0.7.1-2.el5.cloudlinux set to be updated
--> Finished Dependency Resolution

cat /etc/sysconfig/kernel
# UPDATEDEFAULT specifies if new-kernel-pkg should make
# new kernels the default
UPDATEDEFAULT=yes

# DEFAULTKERNEL specifies the default kernel package type
DEFAULTKERNEL=kernel

So it loooks like yum will install a new kernel but cpanel /upcp says a Missing Dependency: kmod-lve >= 0.7 is needed by package lve-0.7.1-2.el5.cloudlinux.x86_64 (cloudlinux-x86_64-server-5)
--> Running transaction check
---> Package kernel.x86_64 0:2.6.18-164.el5 set to be erased
--> Finished Dependency Resolution
Dependencies Resolved
  1. 26.08.2010 10:08:03
  2. # 6
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
Thanks. We will check why is that. Maybe upcp specifically excludes kernel updates..
  1. 27.02.2011 09:02:22
  2. # 7
TPNnet Accepted Answer
Posts: 2
Joined: 27.02.2011
0
Votes
Undo
Hello.
Slightly different issue here.

We\'ve got a cloud VPS with vps.net and we have \"CloudLinux Server 5.5 x64 with cPanel and WHM\" there.

WHM installation&configuration worked fine.
Then in WHM Software -> Upd ate Server Software worked fine too.
However, Software -> Upd ate System Software results in this:
(other stuff here)
--> Running transaction check
---> Package lve.x86_64 0:0.8-16 set to be updated
--> Processing Dependency: kmod-lve >= 0.8 for package: lve
---> Package python-dmidecode.x86_64 0:3.10.13-1.el5_5.1 se t to be updated
--> Finished Dependency Resolution
lve-0.8-16.x86_64 from cloudlinux-x86_64-server-5 has depsolving problems
--> Missing Dependency: kmod-lve >= 0.8 is needed by package lve-0.8-16.x86_64 (cloudlinux-x86_64-server-5)
Error: Missing Dependency: kmod-lve >= 0.8 is needed by package lve-0.8-16.x86_64 (cloudlinux-x86_64-server-5)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

And package-cleanup --problems has given this:
Se tting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package exim requires libresolv.so.2(GLIBC_PRIVATE)(64bit)
Package exim requires perl(SafeFile)
Package grub requires system-logos
Package MySQL-client requires perl(DBI)
Package bandmin requires perl(bandmin.conf)
Package bandmin requires perl(bmversion.pl)
Package bandmin requires perl(services.conf)
Package MySQL-server requires perl(DBI)

However, running yum update and a restart after it seems to have fixed the problem.
  1. 27.02.2011 09:02:03
  2. # 8
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
Try running yum update kernel

The problem is that when cPanel runs update it never updates kernel, and new 0.8 kernel is needed to satisfy this dependency:

--> Processing Dependency: kmod-lve >= 0.8 for package: lve
  1. 27.02.2011 09:02:44
  2. # 9
TPNnet Accepted Answer
Posts: 2
Joined: 27.02.2011
0
Votes
Undo
Hmm...
We got this:
Package(s) kernel available, but not installed.

Our yum.conf:
[main]
exclude=apache* bind-chroot courier* dovecot* exim* httpd* mod_ssl* mysql* nsd* perl* php* proftpd* pure-ftpd* ruby* spamassassin* squirrelmail*
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1

# Note: yum-RHN-plugin doesn\'t honor this.
metadata_expire=1h

installonly_limit = 5

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d

Ideas? :D
  1. 27.02.2011 09:02:26
  2. # 10
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
try:

yum update kernel-xen liblve lve lve-utils
yum update cpanel-lve
yum update cpanel-lvemanager (or yum install if it wasn\'t installed)
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
гость
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.