Configure LSAPI
Forum
  1. Forums
  2. General
  3. General Discussion
  1. Antonio Vilela
  2. 29.12.2016
  3.  Subscribe via email
lsapi_backend_children
Rate this post:
  1. 29.12.2016 09:12:50
  2. # 1
Antonio Vilela Accepted Answer
Posts: 4
Joined: 23.06.2015
0
Votes
Undo
Hi,

How should LSAPI be configured? There is no helpfull information about mod_LSAPI fine tunning.

For instance, lsapi_backend_children, which is probably the most important setting, should be set to which value?

Thanks,
  1. 03.01.2017 13:01:11
  2. # 2
Antonio Vilela Accepted Answer
Posts: 4
Joined: 23.06.2015
0
Votes
Undo
Hi Bogdan,

Thanks for your answer.

We are experiencing the following error on long or complex php scripts:
503 Service Temporarily Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


In apache error log we found:
[Mon Jan 02 18:27:04.548986 2017] [lsapi:error] [pid 911621:tid 140130488612608] [client 213.63.137.202:54421] [host formacao.mcdonalds.pt] Error receiving response: ReceiveResponse: receive pkg hdr failed: ReceivePkgHdr: nothing to read from backend socket, referer: [color=#0000ff]XXXXX/admin/index.php?cache=0&lang=pt&agreelicense=1[/color]

[Mon Jan 02 18:36:00.395347 2017] [lsapi:error] [pid 918378:tid 140130555754240] [client 213.63.137.202:54551] [host formacao.mcdonalds.pt] Error receiving response: ReceiveResponse: receive pkg hdr failed: ReceivePkgHdr: nothing to read from backend socket, referer: [color=#0000ff]XXXXXadmin/index.php?cache=0&agreelicense=1&confirmrelease=1&lang=pt[/color]

[Mon Jan 02 18:43:11.768783 2017] [lsapi:error] [pid 924293:tid 140130747733760] [client 213.63.137.202:54655] [host formacao.mcdonalds.pt] Error receiving response: ReceiveResponse: receive pkg hdr failed: ReceivePkgHdr: nothing to read from backend socket, referer: [color=#0000ff]XXXXXXXX/admin/index.php?cache=0&agreelicense=1&confirmrelease=1&lang=PT[/color]

Do you have a clue if this is a mod_lsapi problem?

Thanks
  1. 03.01.2017 13:01:15
  2. # 3
Antonio Vilela Accepted Answer
Posts: 4
Joined: 23.06.2015
0
Votes
Undo
Hi Bogdan,

Other issue. OpCache resets when we stop using the site for a few seconds.

Is this related to the lsapi_terminate_backends_on_exit option? Should it be Off to keep OpCache alive?

Thanks
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.