Обновлено обновление YUM
Форум
  1. Forums
  2. General
  3. General Discussion
  1. Lama
  2. Monday, 31 October 2016
  3.  Subscribe via email
Hi all,
When I do a yum update I get the below output. If anyone can help me resolve this it would be much appreciated.

[[email protected] ~]# yum update
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from CLN.
Loading mirror speeds from cached hostfile
* cloudlinux-x86_64-server-7: xmlrpc.cln.cloudlinux.com
Traceback (most recent call last):
File \"/usr/bin/yum\", line 29, in <module>
yummain.user_main(sys.argv&#91;1:&#93;, exit_code=True)
File \"/usr/share/yum-cli/yummain.py\", line 365, in user_main
errcode = main(args)
File \"/usr/share/yum-cli/yummain.py\", line 174, in main
result, resultmsgs = base.doCommands()
File \"/usr/share/yum-cli/cli.py\", line 573, in doCommands
return self.yum_cli_commands&#91;self.basecmd&#93;.doCommand(self, self.basecmd, self.extcmds)
File \"/usr/share/yum-cli/yumcommands.py\", line 500, in doCommand
ret = base.updatePkgs(extcmds, update_to=(basecmd == \'update-to\'))
File \"/usr/share/yum-cli/cli.py\", line 1015, in updatePkgs
self.update()
File \"/usr/lib/python2.7/site-packages/yum/__init__.py\", line 5085, in update
updates = self.up.getUpdatesTuples()
File \"/usr/lib/python2.7/site-packages/yum/__init__.py\", line 1098, in <lambda>
up = property(fget=lambda self: self._getUpdates(),
File \"/usr/lib/python2.7/site-packages/yum/__init__.py\", line 844, in _getUpdates
self._up = rpmUtils.updates.Updates(self.rpmdb.simplePkgList(), self.pkgSack.simplePkgList())
File \"/usr/lib/python2.7/site-packages/yum/__init__.py\", line 1079, in <lambda>
pkgSack = property(fget=lambda self: self._getSacks(),
File \"/usr/lib/python2.7/site-packages/yum/__init__.py\", line 784, in _getSacks
self.repos.populateSack(which=repos)
File \"/usr/lib/python2.7/site-packages/yum/repos.py\", line 383, in populateSack
sack.populate(repo, mdtype, callback, cacheonly)
File \"/usr/lib/python2.7/site-packages/yum/yumRepo.py\", line 224, in populate
if self._check_db_version(repo, mydbtype):
File \"/usr/lib/python2.7/site-packages/yum/yumRepo.py\", line 316, in _check_db_version
return repo._check_db_version(mdtype)
File \"/usr/lib/python2.7/site-packages/yum/yumRepo.py\", line 1484, in _check_db_version
repoXML = self.repoXML
File \"/usr/lib/python2.7/site-packages/yum/yumRepo.py\", line 1670, in <lambda>
repoXML = property(fget=lambda self: self._getRepoXML(),
File \"/usr/share/yum-plugins/rhnplugin.py\", line 614, in _getRepoXML
return YumRepository._getRepoXML(self)
File \"/usr/lib/python2.7/site-packages/yum/yumRepo.py\", line 1666, in _getRepoXML
self._loadRepoXML(text=self.ui_id)
File \"/usr/lib/python2.7/site-packages/yum/yumRepo.py\", line 1657, in _loadRepoXML
return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
File \"/usr/lib/python2.7/site-packages/yum/yumRepo.py\", line 1631, in _groupLoadRepoXML
if self._commonLoadRepoXML(text):
File \"/usr/lib/python2.7/site-packages/yum/yumRepo.py\", line 1456, in _commonLoadRepoXML
result = self._getFileRepoXML(local, text)
File \"/usr/lib/python2.7/site-packages/yum/yumRepo.py\", line 1234, in _getFileRepoXML
size=102400) # setting max size as 100K
File \"/usr/share/yum-plugins/rhnplugin.py\", line 427, in _getFile
start, end, copy_local, checkfunc, text, reget, cache, size)
File \"/usr/share/yum-plugins/rhnplugin.py\", line 506, in _noExceptionWrappingGet
size = size
File \"/usr/lib/python2.7/site-packages/urlgrabber/grabber.py\", line 1172, in urlgrab
return self._retry(opts, retryfunc, url, filename)
File \"/usr/lib/python2.7/site-packages/urlgrabber/grabber.py\", line 1064, in _retry
r = apply(func, (opts,) + args, {})
File \"/usr/lib/python2.7/site-packages/urlgrabber/grabber.py\", line 1157, in retryfunc
fo = PyCurlFileObject(url, filename, opts)
File \"/usr/lib/python2.7/site-packages/urlgrabber/grabber.py\", line 1258, in __init__
self._do_open()
File \"/usr/lib/python2.7/site-packages/urlgrabber/grabber.py\", line 1589, in _do_open
self._set_opts()
File \"/usr/lib/python2.7/site-packages/urlgrabber/grabber.py\", line 1413, in _set_opts
self.curl_obj.setopt(pycurl.CAPATH, opts.ssl_ca_cert)
pycurl.error: (4, \'\')
&#91;[email protected] ~&#93;#
Rate this post:
  1. 31.10.2016 18:10:41
  2. # 1
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
Have you tried 
yum clean all
  1. 01.11.2016 07:11:22
  2. # 2
Lama Accepted Answer
Posts: 1
Joined: 31.10.2016
0
Votes
Undo
I tried this and still get the above error

yum clean all
rm -f /var/lib/rpm/__db*
rpm --rebuilddb
yum update
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
гость
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.
By submitting the response, you agree with Cloudlinux Privacy Policy