Скрипт обмена видео
Форум
  1. Forums
  2. General
  3. General Discussion
  1. Mark Sheppard
  2. Friday, 15 July 2016
  3.  Subscribe via email
Hi Everyone,
I just wanted to get some advice really on a particular issue i just came across, I have just installed a video script on my server but for it to work i have had to disable CageFS for that particular user. This is not something i would like to do so i was wondering if there was another way around it.

So here is a list of encoders and paths for the video sharing script it needs access to for the video sharing script

PHP CLIfound (/usr/local/bin/php)
MEncoderfound (/usr/bin/mencoder)
MPlayerfound (/usr/bin/mplayer)
FFMpegfound (/usr/local/bin/ffmpeg)
FLVTool2found (/usr/bin/flvtool2)
Mediainfofound (/usr/bin/mediainfo)
MP4Boxfound (/usr/local/bin/MP4Box)
NeroAacEncfound (/usr/local/bin/neroAacEnc)

JPEG Supportfound (/usr/lib64/libjpeg.so.62 (0x00007f4edb9e6000))
LAME Supportfound (/usr/lib64/libmp3lame.so.0 (0x00007f4ed653e000))
XVID Supportfound (/usr/lib64/libxvidcore.so.4 (0x00007f4ed78c8000))
THEORA Supportfound (/usr/lib64/libtheora.so.0 (0x00007f4ed9b23000)
X264 Supportfound (/usr/lib64/libx264.so.107 (0x00007f4ed67b5000))
FAAC Supportfound (/usr/lib64/libfaac.so.0 (0x00007f4ed6a59000))

These only seem to work when CageFS is disabled for that user, can these not be echo\'ed through the .htaccess file or is there another way around it with CageFS still being activated?

Thanks

Rockyuk
Rate this post:
  1. 15.07.2016 03:07:50
  2. # 1
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Hi,

If that is a comprehensive list of used files then I suppose you just have to add them to cagefs, so users can access them from cagefs inside. To do it please follow http://docs.cloudlinux.com/index.html?file_system_templates.html . But in short:
- create /etc/cagefs/conf.d/mycodecs.conf file
- add all your files you want to be available inside cagefs to it
- run \'cagefsctl --force-update\'
  1. 15.07.2016 04:07:19
  2. # 2
Mark Sheppard Accepted Answer
Posts: 9
Joined: 25.04.2016
0
Votes
Undo
Hi Bogdan,
I am using something called Clip-Share and what you suggested work but one codec Xvid is not showing now matter what i do? It is showing it is installed but just cannot get it to show up within the script. 

I am also getting the following error in php selector

warning:_php_startup:_unable_to_load_dynamic_library_'/opt/alt/php55/usr/lib64/php/modules/ffmpeg.so'_-_libswscale.so.3:_cannot_open_shared_object_file:_no_such_file_or_directory_in_unknown_on_line_0

Thanks

Rockyuk
  1. 15.07.2016 11:07:02
  2. # 3
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
We would like to check the issue in place, please create separate support tickets regarding both issues at https://helpdesk.cloudlinux.com/ . About xvid codec - please provide as much information as possible how to test it with your script.
  1. 15.07.2016 21:07:01
  2. # 4
Mark Sheppard Accepted Answer
Posts: 9
Joined: 25.04.2016
0
Votes
Undo
Hi Bogdan,
I have one more strange issue all my websites don\'t seem to be able to read my max upload size from my global php.ini for some reason it has reverted back to the default 2M. But all the websites seem to be reading the rest of the global php.ini settings just not the max upload size?
Thanks

Rockyuk
  1. 18.07.2016 10:07:46
  2. # 5
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
I believe your ticket has been resolved today. Anyway, things are returned to defaults if there are some wrong directives in php.ini file. But yes, upload_max_filesize is changable in php.ini file. As well as any other directive.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
гость
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.