Не удается войти в рабочую среду
Форум
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and Other Control Panels
  1. Gregor L
  2. Monday, 28 November 2011
  3.  Subscribe via email
I noticed fr om other posts, that this error relates to a confusions between mod_fcgi and mod_hostinglimits.[br][br]I would like PHP via FCGI and other scripts monitored by cloudlinux.[br][br]I\'m running apache 1.3 for this example.[br]the extra/httpd-hostinglimits.conf looks like this now:[br][br]
LoadModule hostinglimits_module /hsphere/shared/apache/libexec/mod_hostinglimits.so[br][br]<IfModule mod_hostinglim its.c>[br]   SkipErrors Off[br]#   AllowedHandlers cgi-script php5-script php4-script php-script application/x-httpd-php5 application/x-httpd-php x-httpd-php fcgid-script application/x-httpd-php4[br]AllowedHandlers cgi-script fcgid-script[br]</IfModule>
[br][br]httpd.conf contains this:[br][br]
[br]<IfDefine FASTCGI>[br]   <IfDefine !LIBLVE>[br]       LoadModule fastcgi_module libexec/mod_fastcgi.so[br]   </IfDefine>[br]   <IfDefine LIBLVE>[br]       LoadModule fastcgi_module libexec/mod_fastcgi_lve.so[br]   </IfDefine>[br]</IfDefine>[br][br][br]
[br][br]apache runs like this:[br]
/hsphere/shared/apache/bin/httpd -DLIBPHP5 -DSSL -DFASTCGI -DFRONTPAGE -DSECURITY -DLIBLVE -f /hsphere/local/config/httpd/httpd.conf
[br][br]Now, the error message (Can\'t enter to lve from slave context) no longer appears, but lveinfo -d does no longer show websites running PHP5 via fcgi.[br][br]I\'m guessing they are no longer protected from using to many resources now?
Rate this post:
  1. 30.11.2011 12:11:26
  2. # 1
Gregor L Accepted Answer
Posts: 5
Joined: 28.07.2011
0
Votes
Undo
After some more digging, this seems to do the trick. (not sure if there is something redundant in there through)


<IfModule mod_hostinglimits.c>
<IfModule mod_fcgid.c>
EnableLVE on
</IfModule>
SkipErrors Off
<IfModule mod_cgi.c>
AllowedHandlers php5-script php4-script php-script application/x-httpd-php5 application/x-httpd-php x-httpd-php fcgid-script application/x-httpd-php4
</IfModule>
<IfModule !mod_cgi.c>
AllowedHandlers cgi-script php5-script php4-script php-script application/x-httpd-php5 application/x-httpd-php x-httpd-php fcgid-script application/x-httpd-php4
</IfModule>

</IfModule>

  1. 01.12.2011 11:12:01
  2. # 2
Alexey Berezhok Accepted Answer
Posts: 35
Joined: 20.04.2010
0
Votes
Undo
Hello, Gregor!

Can you say - do you use mod_fcgid or mod_fastcgi? Why did you comment this string \"AllowedHandlers cgi-script php5-script php4-script php-script application/x-httpd-php5 application/x-httpd-php x-httpd-php fcgid-script application/x-httpd-php4\"? I checked integration H-Sphere 3.5 and CloudLinux - it works correct - without \"Can\'t enter to lve fr om slave context\".

This configuration file:

<IfModule mod_hostinglimits.c>
<IfModule mod_fcgid.c>
EnableLVE on
</IfModule>
SkipErrors Off
<IfModule mod_cgi.c>
AllowedHandlers php5-script php4-script php-script application/x-httpd-php5 application/x-httpd-php x-httpd-php fcgid-script application/x-httpd-php4
</IfModule>
<IfModule !mod_cgi.c>
AllowedHandlers cgi-script php5-script php4-script php-script application/x-httpd-php5 application/x-httpd-php x-httpd-php fcgid-script application/x-httpd-php4
</IfModule>

</IfModule>


is for mod_hostinglimits+apache2.2+mod_fcgid, but not for apache1.3+mod_hostinglim its+mod_fastcgi. If lvetop still blank, can you describe your problem more detail on helpdesk page (https://helpdesk.cloudlinux.com). I need investigate this problem more deep.

Regards,
Alexey
CloudLinux Developers Team
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
гость
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.