Проблема после добавления CloudLinux в CentOS
Форум
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and Plesk
  1. vnat
  2. Wednesday, 08 April 2015
  3.  Subscribe via email
Plesk CP not loading and yum update fails
Rate this post:
  1. 08.04.2015 15:04:30
  2. # 1
vnat Accepted Answer
Posts: 9
Joined: 31.03.2015
0
Votes
Undo
This is a new build, first I installed CentOS 6.6, then installed Plesk 12, then added CloudLinux (and CageFS, MySQL Governor, PHP Selector)

Current version:

# uname -r
2.6.32-531.29.2.lve1.3.11.1.el6.x86_64

# cat /etc/*release*
CloudLinux Server release 6.6 (Leonid Kizim)




After doing the CloudLinux/CageFS/MySQL Gov/PHP Sel installations, the Plesk CP won't load.
(error is  " ERROR: Zend_Db_Adapter_Exception: SQLSTATE[HY000] [2002] No such file or directory (Abstract.php:144) "


Further, I tried to run "yum update" to see if that might resolve the issue but that won't run either:


]# yum upd ate
Loaded plugins: fastestmirror, rhnplugin
Setting up Update Process
Loading mirror speeds from cached hostfile
 * cloudlinux-x86_64-server-6: xmlrpc.cln.cloudlinux.com
Resolving Dependencies
--> Running transaction check
..
..  (cut out for brevity)
..


--> Finished Dependency Resolution
Error: Package: psa-php5-configurator-1.6.3-cos6.build1200140526.11.x86_64 (@PSA_12_0_18-dist)
           Requires: php-ioncube-loader >= 4.6.0
           Removing: php5-ioncube-loader-4.6.0-14042516.x86_64 (@PSA_12_0_18-dist)
               php-ioncube-loader = 4.6.0-14042516
           Obsoleted By: php-ioncube-loader-4.0.12-1.el6.cloudlinux.x86_64 (cloudlinux-x86_64-server-6)
               php-ioncube-loader = 4.0.12-1.el6.cloudlinux
 You could try using --skip-broken to work around the problem
** Found 11 pre-existing rpmdb problem(s), 'yum check' output follows:
MySQL-python-1.2.3-0.3.c1.1.el6.x86_64 has missing requires of libmysqlclient_r.so.16()(64bit)
MySQL-python-1.2.3-0.3.c1.1.el6.x86_64 has missing requires of libmysqlclient_r.so.16(libmysqlclient_16)(64bit)
mysql-connector-odbc-5.1.5r1144-7.el6.x86_64 has missing requires of libmysqlclient_r.so.16()(64bit)
mysql-connector-odbc-5.1.5r1144-7.el6.x86_64 has missing requires of libmysqlclient_r.so.16(libmysqlclient_16)(64bit)
perl-DBD-MySQL-4.013-3.el6.x86_64 has missing requires of libmysqlclient.so.16()(64bit)
perl-DBD-MySQL-4.013-3.el6.x86_64 has missing requires of libmysqlclient.so.16(libmysqlclient_16)(64bit)
php-mysql-5.3.3-40.el6_6.x86_64 has missing requires of libmysqlclient.so.16()(64bit)
php-mysql-5.3.3-40.el6_6.x86_64 has missing requires of libmysqlclient.so.16(libmysqlclient_16)(64bit)
plesk-core-12.0.18-cos6.build1200140606.15.x86_64 has missing requires of mysql-server >= ('0', '5.0.60', None)
2:postfix-2.8.17-14042513.x86_64 has missing requires of libmysqlclient.so.16()(64bit)
pp12.0.18-bootstrapper-12.0.18-cos6.build1200150126.15.x86_64 has missing requires of mysql-server >= ('0', '5.0.60', None)




I'm not sure what went wrong and the best way to resolve this.

I did a similar se t up last week except I started out with CentOS 6.5 (instead of 6.6) and later updated it to 6.6 but I didn't run into any of these issues (Plesk initially had the same error but this resolved after a server reboot)


Thank you
  1. 08.04.2015 16:04:00
  2. # 2
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Here is interesting KB on parallels (odin) site: http://kb.odin.com/en/120312 , could you please check the same? It is about mysql socket file location in Plesk /usr/local/psa/admin/conf/php.ini file. Maybe it become different after mysql versions switch with governor?
  1. 09.04.2015 07:04:12
  2. # 3
vnat Accepted Answer
Posts: 9
Joined: 31.03.2015
0
Votes
Undo
Yes I saw that KB too but I don't know if it applies when CloudLinux / MySQL Governor is installed so I didn't want to try that yet.  Also the odd thing is that I got the same error in the last machine I built but it resolved after a server reboot.


Still this won't solve the yum update issue I'm having which is going to be the bigger problem.

Any idea on safely updating the system? (errors are in my first post)


Thanks
  1. 09.04.2015 15:04:46
  2. # 4
vnat Accepted Answer
Posts: 9
Joined: 31.03.2015
0
Votes
Undo
Just to update, it\'s MySQL Governor that is breaking Plesk and yum update

I don\'t know why, I\'d still like to know for future knowledge, but I coudn\'t wait so I created a new virtual machine and left MySQL Governor out this time.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
гость
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.