Cloudlinux and Plesk panel execution mode apache, fastcgi and cgi
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and Plesk
  1. Jose Joaquin
  2. 09.04.2013
  3.  Subscribe via email
I have installed a trial version for testing purpose, we'll going to migrate 5000 domains to 5 servers with cloudlinux so we are testing with a wordpress installation. I notice some issue or things that i dont understand:

- cl-selector: Only work if the domains is in fastcgi or cgi execution, i think because the apache mode execution is with apache user so i have to change the apache user properties with cl-selector. Is right?

- cagefs: If i execute the wordpress with the "localhost" as database url only work if i execute in apache mode, when i change to fastcgi or cgi mode i get an error if i execute in apache mode not. The error in fastcgi and cgi mode is "Cant connect to database", if i disable the cagefs to the user that run wordpress i can connect but when i enable again i get the error again. Why? 

I have to add two rpm to cagefsctl, "psa-mod-fcgid-configurator" and "psa-mod_fcgid". Without this rpm cant execute the domains in fastcgi or cgi mode with plesk panel. Can be relation the error to the database connection in fastcgi or cgi with this?

Someone else with this problems?

Best Regards.
Rate this post:
  1. 09.04.2013 08:04:04
  2. # 1
Igor Seletskiy Accepted Answer
Posts: 1194
Joined: 09.02.2010
1. mod_php is not supported for PHP selector -- nor it will be. In most cases you shouldn\'t be using mod_php for security reasons anyway.
2. mod_php doesn\'t work with CageFS. If you cannot get MySQL to work from inside CageFS -- contact support -- they will help you. It is not related to fcgid RPMs. It is related to location of mysql socket.
  • Page :
  • 1

There are no replies made for this post yet.
Be one of the first to reply to this post!
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.