Plesk & CloudLinux - Error 500 under load.
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and Plesk
  1. Jordan Dyckes
  2. 13.04.2016
  3.  Subscribe via email
My RAM and CPU is only at 50% when connections are rejected under load.
Rate this post:
  1. 13.04.2016 08:04:01
  2. # 1
Jordan Dyckes Accepted Answer
Posts: 5
Joined: 13.04.2016
Hey Guys,

I have a mystery problem with my server, after my server reaches a certain load approx 40/reqs a second it throws an error 500. My system reports that my resources aren\'t even 50% used when connections are failing.

I am running static assets through an NGINX Proxy with the following configuration:
proxy_connect_timeout       600;
proxy_send_timeout 600;
proxy_read_timeout 600;
send_timeout 600;
gzip_proxied any;
Applying the above config fixed error 500 has mainly fixed general problems like when a user interacts with a page. However, not under generalised load.

Does anyone have some ideas to diagnose and resolve this problem?

Kind regards,

  1. 13.04.2016 09:04:38
  2. # 2
Jordan Dyckes Accepted Answer
Posts: 5
Joined: 13.04.2016

Thankfully when you mentioned \"But they are not limited by CloudLinux services...\" I had never thought about this, and checked out LVE.
Turns out that my entry process limit is capped at 20 and at the same point as the faults occurred my entry processes hit 20 as well.

I have now increased the limit, and the problem has been resolved.

Thank you very much for pointing this out,

  • Page :
  • 1

There are no replies made for this post yet.
Be one of the first to reply to this post!
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.

EU e-Privacy Directive

This website uses cookies to ensure you get the best experience using our website and services. If you prefer we don’t use cookies, please disable them in your browser.

You have declined cookies. This decision can be reversed.

You have allowed cookies to be placed on your computer. This decision can be reversed.