CloudLinux Kernel 3.10.0lve1.4.2 ith Centos 7: Kernel Panic unable to mount root (VFS)
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and Plesk
  1. steinsgate
  2. 18.02.2016
  3.  Subscribe via email
Updating to the latest CloudLinux kernel with Centos 7 and ESXi 6 makes system unable to boot
Rate this post:
  1. 18.02.2016 06:02:45
  2. # 1
steinsgate Accepted Answer
Posts: 11
Joined: 11.02.2014
0
Votes
Undo
Hi there,

Updated glibc and other packages including the kernel  via yum update in Centos 7 with Plesk and CloudLinux, upon reboot the system will show a kernel panic since it is unable to mount root (apparently). Nothing has changed and I can boot the system using the previous kernel version (cloudlinux or base centos) from Grub.

However, the kernel update is broken which is very bad. Currently the kernel version 3.10.0-233.1.2.lve1.3.33.4.el7.x86_64 works, but not its update. I am not generating initrd manually or using any unusual kernel modules,etc. Just regular Centos 7 with CloudLinux (SELinux is disabled).

Any ideas ? what is the actual issue ? some missing module for VMWare in the latest update ? root uses XFS as filesystem and /boot uses ext4.

Someone else having this problem? any advice is welcome.
  1. 18.02.2016 06:02:45
  2. # 2
steinsgate Accepted Answer
Posts: 11
Joined: 11.02.2014
0
Votes
Undo
Running: Linux liffey 3.10.0-329.7.2.lve1.4.2.el7.x86_64 #1 SMP Wed Jan 20 10:51:51 EST 2016 x86_64 x86_64 x86_64 GNU/Linux

Just booted using another kernel and seems solved: did yum reinstall kernel, that for whatever reason pulled a new kernel again installed and it booted normally afterwards, except for the below errors:

[    9.011171] LVE: [863] lve_namespace_init: trying to create a namespace before setup
[    9.011209] LVE: [863] lve_first_init: res init -71
[    9.011253] LVE: [1097] _lve_enter: Can't alloc ve #48, rc -22
[    9.013664] systemd[1]: Got notification message for unit php-fpm.service
[    9.013671] systemd[1]: php-fpm.service: Got notification message from PID 1097 (READY=1, STATUS=Ready to handle connections, MAINPID=1097)
[    9.013675] systemd[1]: php-fpm.service: got MAINPID=1097
[    9.013679] systemd[1]: php-fpm.service: got READY=1
[    9.013714] systemd[1]: php-fpm.service changed start -> running
[    9.013719] systemd[1]: Job php-fpm.service/start finished, result=done
[    9.013729] systemd[1]: Started The PHP FastCGI Process Manager.

  1. 29.09.2018 23:09:00
  2. # 3
Eugene Accepted Answer
Posts: 0
Joined: 18.09.2020
0
Votes
Undo
This problem still exist in hyper-v vm with the latest kernel, any fix for that?
  1. 01.10.2018 13:10:58
  2. # 4
Igor Ghertesco Accepted Answer
Posts: 153
Joined: 07.08.2015
0
Votes
Undo
Hello,

Could you please submit a ticket to https://cloudlinux.zendesk.com/hc/en-us/requests/new, we will take a closer look.

Thank you.
  1. 18.09.2019 22:09:13
  2. # 5
John Accepted Answer
Posts: 0
Joined: 18.09.2020
0
Votes
Undo
we are seeing this issue as well

CL 7.7
runing on XCP-NG 7.6
  1. 19.09.2019 09:09:55
  2. # 6
Sergey Khristich Accepted Answer
Posts: 422
Joined: 20.05.2019
0
Votes
Undo
Hello John! To help you with this question we need a little bit more information, please create a ticket here https://cloudlinux.zendesk.com/hc/en-us/requests/new and technical experts will help you asap.
If you have any other questions, feel free to ask here.
Marketing Manager
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
John
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.