Проблема добавления новой директивы для настраиваемого php.ini в PHP Selector
Форум
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Scott Neader
  2. Sunday, 25 January 2015
  3.  Subscribe via email
I have several customers that would like to increase the max_input_vars value in their custom php.ini,  This directive became available starting in PHP version 5.3.9, and has a default value of 1000.

I'm following the documentation here:  http://docs.cloudlinux.com/index.html?custom_php_ini_options.html

I edited /etc/cl.selector/php.conf and copied one of the other directives, then edited the values.  So, I copied this one that comes with alt php by default:

Directive = magic_quotes_gpc
Default   = On
Type      = bool
Remark    = <5.4.0
Comment   = Sets the magic_quotes state fo...
And I made it look like this:
Directive = max_input_vars
Default   = 1000
Type      = value
Remark    = >5.3.8
Comment   = How many input variables may be accepted.
This did not work.  The max_input_vars did not show up as editable in PHP Selector.  After doing some troubleshooting, I realized that the problem was the REMARK line.  When I remove it, the directive shows up as editable!

What is Remark?  There is no documentation at all for it.  I assumed that it was to help control when this directive shows up.  i.e. it should ONLY show up in any PHP version GREATER than 5.3.8, because the directive didn't become available until 5.3.9.

For now, I have removed REMARK, however now customers with even PHP 5.2 are now seeing this directive, when they should not.

1) What is Remark?
2) How do we use it?
3) How can I make sure that any new directives I add to /etc/cl.selector/php.conf are only shown in versions of PHP that are valid for that directive?

Thanks!

- Scott
Rate this post:
  1. 26.01.2015 13:01:51
  2. # 1
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
It appears the only one acceptable \'mark\' for greater value \">=\" , your remark should be:

Remark >= 5.3.8

This will it will works properly. We have opened bugreport about this case so will be fixed in future releases.
  1. 26.01.2015 13:01:28
  2. # 2
Scott Neader Accepted Answer
Posts: 89
Joined: 12.06.2014
0
Votes
Undo
Hi Bogdan.  This is not working:

Remark >= 5.3.8
It is causing all sorts of problems in PHP Selector in cPanel.  For example, our Native PHP is 5.4. If a customer chooses PHP 5.5 instead, it still gives the message "Warning: Changing php modules and php options via PHP Selector for native php version is impossible"

I have simply removed Remark completely until the bug is resolved.  I wanted you to know that >= is not a working work-around.

- Scott
  1. 26.01.2015 14:01:43
  2. # 3
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Scott, you are right, I have just tested on internal server it cause the issue you describe, a \'warning about native php\', really not sure how that is possible. I am going to escalate it to our developers .
  1. 03.03.2016 01:03:03
  2. # 4
Scott Neader Accepted Answer
Posts: 89
Joined: 12.06.2014
0
Votes
Undo
Was this ever resolved?

- Scott
  1. 03.03.2016 03:03:56
  2. # 5
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
I have just tested the same and issue was fixed 'from other side', support for more comparison symbols were added so now '>' could be used.

However  '>=' and '=>' are still not supported.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
гость
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.