1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Tommy K
  2. 11.07.2013
  3.  Subscribe via email
alt-php, php selector, etc
Rate this post:
  1. 11.07.2013 06:07:12
  2. # 1
Tommy K Accepted Answer
Posts: 14
Joined: 03.07.2013
0
Votes
Undo
When I create new accounts I can\'t select php version (User not in cagefs).

Seem like etc not getting copied to the accounts.

Ideas?
  1. 11.07.2013 08:07:22
  2. # 2
Hostking Accepted Answer
Posts: 38
Joined: 07.11.2012
0
Votes
Undo
I had a similar issue but noticed that when I add clients to cagefs it worked. When they were not in cagefs the php selector was \"disabled\"

Not sure if it was a configuration issue my side or not. But left it to have everyone always in cagefs. No issues since then.
  1. 11.07.2013 12:07:30
  2. # 3
Tommy K Accepted Answer
Posts: 14
Joined: 03.07.2013
0
Votes
Undo
My server is set to cage users by default, and it seemes like it does as well. The only thing I can see is wrong is that the etc does not get copied to the new accounts.
  1. 24.07.2013 09:07:26
  2. # 4
Tom Whiting Accepted Answer
Posts: 7
Joined: 15.03.2012
0
Votes
Undo
Have you run

cagefsctl --update 
since you added the selector RPMS?
This should update everything in cagefsctl
  1. 24.07.2013 15:07:01
  2. # 5
Tommy K Accepted Answer
Posts: 14
Joined: 03.07.2013
0
Votes
Undo
Yes, I did. I think there was something wrong with some update or something, cause without any changes from me it started working.
  1. 24.07.2013 15:07:43
  2. # 6
Tom Whiting Accepted Answer
Posts: 7
Joined: 15.03.2012
0
Votes
Undo
I noticed something odd like this myself. Recompiled apache (easyapache), as it was a bit old anyways, and it worked. Odd that yours just didn\'t want to work, or maybe it needed a --force-update instead of just an update.

Good to hear you got it working though ;)
  1. 13.12.2013 16:12:04
  2. # 7
Douglass C Accepted Answer
Posts: 1
Joined: 13.12.2013
0
Votes
Undo
Hi,

/usr/bin/cl-selector --summary php --user USER

ERROR:User is not in cagefs

Try to  add the user to cagefs

/usr/sbin/cagefsctl --enable USER

That works for me
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.