Плагин cPanel
Форум
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Igor Seletskiy
  2. Tuesday, 14 September 2010
  3.  Subscribe via email
Beta of cPanel plugin was just released:
http://www.cloudlinux.com/docs/whmplugin.php
Rate this post:
  1. 16.09.2010 05:09:34
  2. # 1
Marie Accepted Answer
Posts: 7
Joined: 11.08.2010
0
Votes
Undo
Looks great ! Will this plugin be part of the cloudlinux package or will we pay an extra for it ?
  1. 19.09.2010 22:09:13
  2. # 2
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
This plugin is included in CLN subscription, so there is no extra fees for it.
It is not in production repository, and you should be able to install it.

We are going to release beta version of another cPanel plugin on Monday (this one for end users)
http://www.cloudlinux.com/docs/cpanel-enduser-plugin.php

I would like to get some feedback on how we present CPU usage.
The problem is that I don\'t want to show user that he is using 5% CPU out of 25% CPU that is his limit. It will be a problem when customer is on 8 core or 16 core systems -- where they are limited by 5% to 10% of CPU resources.

So, right now I set 100% to be the total amount of CPU customer can use (his limit), and calculate usage accordingly.
It doesn\'t feel perfect.

One other option that I don\'t like too much: I can set 100% at 1 CORE, and display usage/limit relative to that.
If someone has other suggestions -- please.

We are going to expand this two plugins a bit more in the coming weeks, once we attach our stats to rrdtool, and collect historical information. Once that is done -- it should become more useful to everyone. Yet, even now, I hope this is a step forward.
  1. 11.10.2010 06:10:40
  2. # 3
kernow Accepted Answer
Posts: 72
Joined: 06.08.2010
0
Votes
Undo
The WHM plugin looks useful, but we doubt we will ever install the end user cpanel plugin as we believe most clients will not use it or understand it.
  1. 10.11.2010 17:11:09
  2. # 4
Kahuna Accepted Answer
Posts: 5
Joined: 26.10.2010
0
Votes
Undo
I installed the end user plugin via the instructions here: http://www.cloudlinux.com/docs/cpanel-enduser-plugin.php

However, the extra stats aren\'t showing in my user cpanel accounts. We\'re using a slightly restyled version of the \"Black Ice\" cpanel style for user accounts. Could that be why?
  1. 10.11.2010 17:11:00
  2. # 5
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
Yes, this is most likely the reason. See
/usr/share/lve/cpanelplugin/ for patch files that we use to patch original cPanel skin.
Most likely you will need to patch yours manually.
  1. 30.12.2010 11:12:02
  2. # 6
Roman Romanov Accepted Answer
Posts: 4
Joined: 30.12.2010
0
Votes
Undo
Hello, Igor
Could you please help me..
we have installed trial version of CL at one of our servers, and want to use LVE module for our users..we installed it and it shows in users stats in x3 theme but in the max allowed concurrent connection is showing 0 in x3 and empty in x2 theme..

for x3
Concurrent Connections 0 / 0

for x2
Concurrent Connections 0 /

could you please help me?
we have 30 in the lve settings in whm for max allowed concurent connections
we have following package
Package lve-cpanel-plugin-0.1-4.el5.cloudlinux.noarch already installed and latest version
Thanks
  1. 30.12.2010 11:12:20
  2. # 7
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
Could you check that:

You are running LVE kernel (uname -r should show kernel name with lve in the name)
lvetop shows some output.

lve-stats package is installed and running.
To do that:
rpm -qa lve-stats
ps auxw|grep lvestats

If package is installed, but not running, start it up by
/etc/init.d/lvestats start

It should take a minute for data to appear.

If it is running -- I will need access to the server (not sure if I can figure it out remotely) to understand what is going on.
  1. 30.12.2010 11:12:24
  2. # 8
Roman Romanov Accepted Answer
Posts: 4
Joined: 30.12.2010
0
Votes
Undo
uname -r
2.6.18-264.11.1.el5.17.cloudlinux
rpm -qa lve-stats
lve-stats-0.4-1.el5.cloudlinux

ps auxw|grep lvestats
root 14735 0.0 0.0 61204 744 pts/0 S+ 11:53 0:00 grep lvestats


/etc/init.d/lvestats start
Starting lvestats: X [ OK ]
[email protected] [/usr/local/cpanel/base/frontend/rvblue/rvbranding]# Traceback (most recent call last):
File \"/usr/sbin/lvestats-server\", line 283, in ?
main()
File \"/usr/sbin/lvestats-server\", line 274, in main
lveRefreshThread = LVERefresh()
File \"/usr/sbin/lvestats-server\", line 174, in __init__
self.old = parseLVEList()
File \"/usr/sbin/lvestats-server\", line 126, in parseLVEList
return parseLVEUsage(stats)
File \"/usr/sbin/lvestats-server\", line 104, in parseLVEUsage
lines = open(\'/proc/lve/usage\', \'r\').readlines()
IOError: [Errno 2] No such file or directory: \'/proc/lve/usage\'

looks like no lve core.. am i right?

thanks for promt reply :)
  1. 30.12.2010 12:12:49
  2. # 9
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
Yes, strange kernel, I don\'t understand where it came from.
Could you give output of
rpm -qa |grep kernel

Also, is it inside of VZ container? Our kernel always has lve in its name (at least for the past 6 month). Maybe it is very old kernel?
Our kernel should also be version: 2.6.18-294... not 264.., so what every you are running as kernel looks very old.
  1. 30.12.2010 12:12:48
  2. # 10
Roman Romanov Accepted Answer
Posts: 4
Joined: 30.12.2010
0
Votes
Undo
rpm -qa |grep kernel
kernel-debug-2.6.18-294.8.1.el5.lve0.7.33.1
kernel-headers-2.6.18-294.26.1.el5.lve0.7.45
kernel-2.6.18-264.11.1.el5.17.cloudlinux
no it is not in VZ..
for me it looks like not the right kernel is loaded and that;s the problem..
  1. 30.12.2010 12:12:57
  2. # 11
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
very old kernel package (back from Apr 2010)
do: yum install kernel
You should get kernel-2.6.18-294.26.1.el5.lve0.7.45

If you don\'t get this kernel, make sure you are registered with cln:
# rhn_check
should return without any error message, or anything at all

And check that yum.conf doesn\'t have kernel excluded.
  1. 30.12.2010 12:12:57
  2. # 12
Roman Romanov Accepted Answer
Posts: 4
Joined: 30.12.2010
0
Votes
Undo
simple reboot did the trick :)
uname -r
2.6.18-294.26.1.el5.lve0.7.45

thanks a lot for your help and assistance ;)
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
гость
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.