getting warning message
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. steven elvisda
  2. 11.12.2012
  3.  Subscribe via email
Hello I got [warn] message when I usually type below command.
[email protected] [~]# httpd -G | grep mod_fcgid >/dev/hull && echo OK
[Wed Dec 12 10:55:07 2012] [warn] module hostinglimits_module is already loaded, skipping
[Wed Dec 12 10:55:07 2012] [warn] NameVirtualHost 127.0.0.1:80 has no VirtualHosts


could you give me an idea?
Rate this post:
  1. 12.12.2012 05:12:12
  2. # 1
George Accepted Answer
Posts: 7
Joined: 06.12.2012
0
Votes
Undo
Hi,

The first error:

[Wed Dec 12 10:55:07 2012] [warn] module hostinglimits_module is already loaded, skipping 

is generated due to the fact that hostinglimits is loaded twice -- most probably once in the httpd.conf:

LoadModule hostinglimits_module modules/mod_hostinglimits.so

and the second time in the hosting limit configuration file which is also loaded in the httpd.conf:

Include "/usr/local/apache/conf/modhostinglimits.conf"

[~]# cat "/usr/local/apache/conf/modhostinglimits.conf"
LoadModule hostinglimits_module /etc/httpd/modules/mod_hostinglimits.so

You can safely ignore this warning, no harm any way. If you insist on resolving this you can simply remove on the the lines that load the module.

As for ---  NameVirtualHost 127.0.0.1:80 has no VirtualHosts  --- I believe this is a warning due to no virtual host in the httpd.conf for 127.0.0.1:80. You can simply add the following line:

NameVirtualHost 127.0.0.1:80

and reload the apache. Anyway both warnings should not affect your web service.
  1. 12.12.2012 05:12:49
  2. # 2
steven elvisda Accepted Answer
Posts: 23
Joined: 02.12.2012
0
Votes
Undo
thanks you so much for your kind your idea make bright

I was added

    ServerName server01.xxx.com
    DocumentRoot /usr/local/apache/htdocs
    ServerAdmin [email protected]
    UserDir disable




the problem had been solve. 

thanks you so much.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.