Ошибка lvestats
Форум
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. rahnev
  2. Tuesday, 13 December 2016
  3.  Subscribe via email
During last update I think, the following error is generated in /var/log/lve-stats.log:[br]
 2016-12-13 01:44:50,818: (main_loop.plugin_executor.process) [ERROR] Other exception during execution of plugin <class \'lvestats.plugins.generic.dbsaver_x60.DBSaverX60\'>[br]Traceback (most recent call last):[br]  File \"/opt/alt/python27/lib/python2.7/site-packages/lvestats/eventloop/plugin_executors.py\", line 196, in _in_separate_process[br]    plugin_instance.execute(lve_data)[br]  File \"/opt/alt/python27/lib/python2.7/site-packages/lvestats/plugins/generic/dbsaver_x60.py\", line 117, in execute[br]    self.aggregate_new(dt_x1_max, dt_x1_min, dt_x60_max)[br]  File \"/opt/alt/python27/lib/python2.7/site-packages/lvestats/plugins/generic/dbsaver_x60.py\", line 137, in aggregate_new[br]    self.aggregate_db_data_by_hours(dt_x60_max, dt_x1_max)[br]  File \"/opt/alt/python27/lib/python2.7/site-packages/lvestats/plugins/generic/dbsaver_x60.py\", line 76, in aggregate_db_data_by_hours[br]    one_insert_values[\'cpu\'] *= 100[br]TypeError: unsupported operand type(s) for *=: \'NoneType\' and \'int\'[br]2016-12-13 01:44:51,843: (main.loop) [ERROR] Error during execution of /opt/alt/python27/lib/python2.7/site-packages/lvestats/plugins/generic/dbsaver_x60.py:DBSaverX60[br]Traceback (most recent call last):[br]  File \"/opt/alt/python27/lib/python2.7/site-packages/lvestats/eventloop/main_loop.py\", line 98, in run[br]    self.executor.execute(plugin, now, timeout)[br]  File \"/opt/alt/python27/lib/python2.7/site-packages/lvestats/eventloop/plugin_executors.py\", line 372, in execute[br]    raise PluginExecutionException(ex)[br]PluginExecutionException: unsupported operand type(s) for *=: \'NoneType\' and \'int\'[br]2016-12-13 01:44:51,879: (init_db_engine) [INFO] Connecting to database: sqlite
[br]Similar errors are generated in /var/log/messages:[br]
Dec 13 01:47:27 lve-stats: (main.loop) [ERROR] Error during execution of /opt/alt/python27/lib/python2.7/site-packages/lvestats/plugins/generic/dbsaver_x60.py:DBSaverX60#012Traceback [br] (most recent call last):#012  File \"/opt/alt/python27/lib/python2.7/site-packages/lvestats/eventloop/main_loop.py\", line 98, in run#012    self.executor.execute(plugin, now, timeout)#012  [br] File \"/opt/alt/python27/lib/python2.7/site-packages/lvestats/eventloop/plugin_executors.py\", line 372, in execute#012    raise PluginExecutionException(ex) [br]#012PluginExecutionException: unsupported operand type(s) for *=: \'NoneType\' and \'int\' [br][br]Dec 13 01:47:31 lve-stats: (main_loop.plugin_executor.process) [ERROR] Other exception during execution of plugin <class \'lvestats.plugins.generic.dbsaver_x60.DBSaverX60\'> [br]#012Traceback (most recent call last):#012  File \"/opt/alt/python27/lib/python2.7/site-packages/lvestats/eventloop/plugin_executors.py\", line 196, in _in_separate_process#012     [br]plugin_instance.execute(lve_data)#012  File \"/opt/alt/python27/lib/python2.7/site-packages/lvestats/plugins/generic/dbsaver_x60.py\", line 117, in execute#012     [br]self.aggregate_new(dt_x1_max, dt_x1_min, dt_x60_max)#012  File \"/opt/alt/python27/lib/python2.7/site-packages/lvestats/plugins/generic/dbsaver_x60.py\", line 137,  [br]in aggregate_new#012    self.aggregate_db_data_by_hours(dt_x60_max, dt_x1_max)#012  File \"/opt/alt/python27/lib/python2.7/site-packages/lvestats/plugins/generic/dbsaver_x60.py\",  [br]line 76, in aggregate_db_data_by_hours#012    one_insert_values[\'cpu\'] *= 100#012TypeError: unsupported operand type(s) for *=: \'NoneType\' and \'int\'[br] 
I tried restarting lvestats but nothing changed. Version of lve-stats is[br][br]lve-stats.noarch                              2.4-6.el6                @cloudlinux-x86_64-server-6[br][br]Before the update version was 0.10-51.el6:[br][br][2016-12-09 03:04:32 -0500] [135739] ---> Package lve-stats.noarch 0:0.10-51.el6 will be updated[br][2016-12-09 03:04:32 -0500] [135739] ---> Package lve-stats.noarch 0:2.4-6.el6 will be an update[br][br]Is there someone else with similar errors or know resolution of the problem?
Rate this post:
  1. 13.12.2016 08:12:16
  2. # 1
rahnev Accepted Answer
Posts: 11
Joined: 06.07.2016
0
Votes
Undo
I think I fixed the problem by downgrade the module to version 0.10 and then upgrade it again. Now the errors don\'t appear in logs.
  1. 13.12.2016 13:12:14
  2. # 2
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
The error should be fixed for good in beta package released today. Most probably you updated to it already.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
гость
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.