1. Форумы
  2. CloudLinux и панели управления
  3. CloudLinux и cPanel
  1. fen7azy
  2. Среда, 09 ноября 2016
  3. Подписка по электронной почте
Правильная установка
Оценить этот пост:
  1. 09.11.2016 20:11:43
  2. # 1
fen7azy Принято ответа
Сообщений: 6
Присоединился: 09.11.2016
0
Голосов
расстегивать
Привет, У меня возникли проблемы с установкой всего упомянутого выше программного обеспечения. Я переустановил выделенный сервер 2 раз, потому что я не могу корректно работать вместе.
Может ли кто-нибудь сообщить мне правильный порядок установки следующего: Cloudlinux 7 (это будет первый: D), последняя версия cPanel (его версия 60 на момент написания), Настройка EasyApache4 для работы с Apache mod_lsapi, предоставленным CloudLinux, MySQL Covernor, CageFS, LVE, CL7 PHP Seletor, suexec.

Я могу повториться, но я не могу правильно установить все упомянутое выше программное обеспечение, потому что я думаю, что порядок не может быть случайным.

Вот шаги, которые я сделал:

1. Установка CloudLinux7
2. Установите cPanel поверх свежего CloudLinux 7
3. Установка LVE
4. Установка CageFS
5. Установить MySQL Governor
6., Установить PHP (yum groupinstall alt-php)
7. Установить Apache mod_lsapi (не удалось)
8. Установить alt-suexec (не удалось)

На шаге 7 я получаю следующую ошибку:

ням установить liblsapi liblsapi-devel - ОК
yum install ea-apache24-mod_lsapi - Ошибка с ошибкой:

Пакета ea-apache24-mod_lsapi недоступна.

На шаге 8:

yum install alt-suexec --enablerepo = cloudlinux-updates-testing - не удалось с ошибкой:


Загрузка зеркальных скоростей из кэшированного файла хоста
* EA4: 91.197.228.252
* cloudlinux-x86_64-сервер-7: de-proxy.cl-mirror.net
Разрешение зависимостей
-> Проверка транзакции
---> Пакет alt-suexec.x86_64 0: 2.4.6-31.el7_1.4.cloudlinux будет установлен
-> Зависимость обработки: httpd для пакета: alt-suexec-2.4.6-31.el7_1.4.cloudlinux.x86_64
-> Законченное разрешение зависимостей
Ошибка: пакет: alt-suexec-2.4.6-31.el7_1.4.cloudlinux.x86_64 (cloudlinux-updates-testing)
Требуется: httpd
Вы можете попробовать использовать -skip-break для решения проблемы
Вы можете попробовать запустить: rpm -Va --nofiles --nodigest


даже с -skip-broken Я не могу установить alt-suexec.

Не могли бы вы помочь мне? Заранее спасибо.
  1. 10.11.2016 04:11:48
  2. # 2
Богдан Принято ответа
Сообщений: 709
Присоединился: 26.06.2013
0
Голосов
расстегивать
Здравствуйте,

1) Я только что играл с тестовым сервером CL7, и я не могу воспроизвести проблему. Я смог установить ea-apache24-mod_lsapi с той же командой. Вы действительно используете EasyApache 4 на этом сервере? Предоставьте мне следующие данные:
/ usr / local / cpanel / bin / rebuild_phpconf - текущий  реполист 


2) Вам не нужен alt-suexec с сервером cPanel, он используется для разных целей. Вот что говорит документация:
Если вы используете стандартный httpd из нашего репозитория, но ваши сайты пользователей не соответствуют стандартным местоположениям Apache / var / www, то вы должны использовать alt-suexec
  1. 10.11.2016 10:11:50
  2. # 3
fen7azy Принято ответа
Сообщений: 6
Присоединился: 09.11.2016
0
Голосов
расстегивать
Богдан, спасибо за ваш ответ.

Я уверен, что я использую EasyApache4, поскольку это единственный вариант, который поставляется с версией WHM / cPanel 60.

1) [[Электронная почта защищена] ~] # / usr / local / cpanel / bin / rebuild_phpconf --current
DEFAULT PHP: ea-php56
ea-php55 COW: suphp
ea-php56 COW: suphp
ea-php70 COW: suphp

2) Спасибо. Я пропустил это. :)
  1. 15.11.2016 07:11:25
  2. # 4
Богдан Принято ответа
Сообщений: 709
Присоединился: 26.06.2013
0
Голосов
расстегивать
Хорошо, у меня нет идей, почему ea-apache24-mod_lsapi недоступен с yum. Пожалуйста, создайте билет поддержки, чтобы мы могли проверить проблему на месте.
  1. 16.11.2016 20:11:22
  2. # 5
fen7azy Принято ответа
Сообщений: 6
Присоединился: 09.11.2016
0
Голосов
расстегивать
Я подал билет.

Однако мне удалось это сделать, используя конвертер EA3 для Ea4, однако, с последней версией CloudLinux и cPanel 11.60, я не могу вносить какие-либо изменения в EA4, как я описал в билете. Поскольку я не получаю ответа на день 1, я также опубликую здесь эту проблему:

Мне удалось исправить проблему, используя следующий скрипт:

cd ~; wget [url]https://repo.cloudlinux.com/cloudlinux/sources/cloudlinux_ea3_to_ea4; [/ url] sh cloudlinux_ea3_to_ea4 --convert

Однако, поскольку последняя версия cPanel 11.60 поставляется с EA4 ТОЛЬКО, я не 100% уверен, что этот скрипт необходим.

После выполнения сценария выше, mod_lsapi был успешно установлен. Теперь я сталкиваюсь с другой проблемой с EasyApache4.
Теперь, когда я вхожу в WHM -> EasyApache 4, я не могу вносить какие-либо изменения в профили Apache, потому что когда я нажимаю «Настроить» в любом из профилей, я получаю следующее сообщение:

Пакетов нет.

Также я не могу изменить профиль EasyApache4 по умолчанию, потому что, когда я нажимаю кнопку «Предоставление» любого из профилей, я получаю:

Ошибка обновления:

Ошибка: ea-apache24-mod_cgi конфликтует с 1: ea-apache24-mod_cgid-2.4.23-3.el7.cloudlinux.x86_64
Ошибка: ea-apache24-mod_mpm_prefork конфликтует с 1: ea-apache24-mod_cgid-2.4.23-3.el7.cloudlinux.x86_64
Ошибка: ea-apache24-mod_mpm_worker конфликтует с 1: ea-apache24-mod_mpm_prefork-2.4.23-3.el7.cloudlinux.x86_64
Ошибка: ea-apache24-mod_cgi конфликтует с 1: ea-apache24-mod_mpm_worker-2.4.23-3.el7.cloudlinux.x86_64
Ошибка: ea-apache24-mod_cgid конфликтует с 1: ea-apache24-mod_mpm_prefork-2.4.23-3.el7.cloudlinux.x86_64
Ошибка: ea-apache24-mod_cgid конфликтует с 1: ea-apache24-mod_cgi-2.4.23-3.el7.cloudlinux.x86_64
Ошибка: ea-apache24-mod_mpm_worker конфликтует с 1: ea-apache24-mod_cgi-2.4.23-3.el7.cloudlinux.x86_64
Ошибка: ea-apache24-mod_mpm_prefork конфликтует с 1: ea-apache24-mod_mpm_worker-2.4.23-3.el7.cloudlinux.x86_64 на /usr/local/cpanel/Cpanel/PackMan.pm строке 602.
  1. 17.11.2016 11:11:23
  2. # 6
Богдан Принято ответа
Сообщений: 709
Присоединился: 26.06.2013
0
Голосов
расстегивать
Чтобы обновить эту тему, мы сотрудничаем с разработчиками cpanel в этом случае. Пока что не уверен, что произошло.
  1. 20.11.2016 15:11:38
  2. # 7
fen7azy Принято ответа
Сообщений: 6
Присоединился: 09.11.2016
0
Голосов
расстегивать
Спасибо за ваш ответ. Пожалуйста, держите нас в курсе дела.
  1. 23.11.2016 02:11:17
  2. # 8
Богдан Принято ответа
Сообщений: 709
Присоединился: 26.06.2013
0
Голосов
расстегивать
Мне просто сообщили, что cPanel собирается исправить это со своей стороны, внутренний номер корпуса - CPANEL-9862. Скорее всего, это будет исправлено в следующей версии WHM v60. Здесь можно увидеть историю изменений (проблема еще не исправлена): https://documentation.cpanel.net/display/CL/60+Change+Log
  1. 24.11.2016 01:11:05
  2. # 9
fen7azy Принято ответа
Сообщений: 6
Присоединился: 09.11.2016
0
Голосов
расстегивать
Спасибо, Богдан.
  • Страница:
  • 1


Там нет ответов, сделанные на этот пост пока нет.
Будьте одним из первых, чтобы ответить на этот пост!
гость
Отправить Ваш ответ
Загрузить файлы или изображения для обсуждения этого вопроса, нажав на кнопку загрузки ниже. опоры GIF, JPG, PNG, ZIP, RAR, PDF
• Вставить • Удалить Загрузка файлов (Максимальный размер файла: 2 MB)
Защитный код
Чтобы защитить сайт от ботов и несанкционированных сценариев, мы требуем, чтобы вы ввели коды капчи ниже, прежде чем отправить свой вопрос.