CloudLinux7 + cPanel 60 + CageFS + EasyApache4 + Mod_LSAPI + MySQL Governor + LVE + CL7 Селектор PHP + suexec
Форум
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. fen7azy
  2. Wednesday, 09 November 2016
  3.  Subscribe via email
Proper installation oder
Rate this post:
  1. 09.11.2016 20:11:43
  2. # 1
fen7azy Accepted Answer
Posts: 6
Joined: 09.11.2016
0
Votes
Undo
Hello, I am having issues installing all the mentioned software above. I've reinstalled my dedicated server 2 times already, because I cannot make all soft working correctly together.
Could someone let me know the correct order to install the following: Cloudlinux 7 (this will be the first :D ), cPanel latest version (its version 60 at the moment of writing), Configure EasyApache4 to work with Apache mod_lsapi provided by CloudLinux, MySQL Covernor, CageFS, LVE, CL7 PHP Seletor, suexec .

I might be repeat myself, but I am unable to properly install all the mentioned software above, because I think the order cannot be random.

Here are the steps that I've taken:

1. Install CloudLinux7
2. Install cPanel on top of fresh CloudLinux 7 
3. Install LVE
4. Install CageFS
5. Install MySQL Governor
6., Install PHP (yum groupinstall alt-php)
7. Install Apache mod_lsapi (failed)
8. Install alt-suexec (failed)

At step 7 I am receiving the following error:

yum install liblsapi liblsapi-devel - OK
yum install ea-apache24-mod_lsapi - Failed with error:

No package ea-apache24-mod_lsapi available.

At step 8:

yum install alt-suexec --enablerepo=cloudlinux-updates-testing - failed with error:


Loading mirror speeds from cached hostfile
 * EA4: 91.197.228.252
 * cloudlinux-x86_64-server-7: de-proxy.cl-mirror.net
Resolving Dependencies
--> Running transaction check
---> Package alt-suexec.x86_64 0:2.4.6-31.el7_1.4.cloudlinux will be installed
--> Processing Dependency: httpd for package: alt-suexec-2.4.6-31.el7_1.4.cloudlinux.x86_64
--> Finished Dependency Resolution
Error: Package: alt-suexec-2.4.6-31.el7_1.4.cloudlinux.x86_64 (cloudlinux-updates-testing)
           Requires: httpd
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


even with --skip-broken I am unable to install alt-suexec.

Could you help me? Thank you in advance.
  1. 10.11.2016 04:11:48
  2. # 2
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Hello,

1) I have just played with test CL7 server and I am not able to reproduce the issue. I was able to install ea-apache24-mod_lsapiwith same command. Do you really use EasyApache 4 on that server? Provide me with the output of the following:
/usr/local/cpanel/bin/rebuild_phpconf --current
yum repolist


2) You do not need alt-suexec with cPanel server, it is used for different purposes. Here is what documentation says:
If you use standard httpd from our repository, but your users\' sites do not match standard Apache location of /var/www, then you should use alt-suexec
  1. 10.11.2016 10:11:50
  2. # 3
fen7azy Accepted Answer
Posts: 6
Joined: 09.11.2016
0
Votes
Undo
Bogdan, thank you for your reply. 

I am sure that I am using EasyApache4 since it is the only option that came with WHM/cPanel version 60.

1) [[email protected] ~]# /usr/local/cpanel/bin/rebuild_phpconf --current
DEFAULT PHP: ea-php56
ea-php55 SAPI: suphp
ea-php56 SAPI: suphp
ea-php70 SAPI: suphp

2) Thank you. I've missed that. :)
  1. 15.11.2016 07:11:25
  2. # 4
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Ok, I have no ideas why ea-apache24-mod_lsapi not available with yum. Please create support ticket so we can check the issue in place.
  1. 16.11.2016 20:11:22
  2. # 5
fen7azy Accepted Answer
Posts: 6
Joined: 09.11.2016
0
Votes
Undo
I\'ve submitted ticket.

However, I was able to mange this, using the EA3 to Ea4 converter, however, with the latest version of CloudLinux and cPanel 11.60 I am not able to make any changes to EA4, as I\'ve described in the ticket. As I am not getting reply for 1 day, I will post the issue here as well:

I\'ve managed to fix the issue by using the following script:

cd ~; wget [url]https://repo.cloudlinux.com/cloudlinux/sources/cloudlinux_ea3_to_ea4;[/url] sh cloudlinux_ea3_to_ea4 --convert

However, since the latest version of cPanel 11.60 is coming with EA4 ONLY, I am not 100% sure this script was needed.

After running the script above, mod_lsapi was successfully installed. Now am I facing another issue with EasyApache4.
Now when I enter WHM -> EasyApache 4 I am not able to make any changes to Apache profiles, because when I click on Customize on any of the profiles I am getting the following message:

There are no packages to display.

Also I am not able to change the default EasyApache4 Profile, because when I click on the Provision button of any of the profiles I am getting:

Update Error:

Error: ea-apache24-mod_cgi conflicts with 1:ea-apache24-mod_cgid-2.4.23-3.el7.cloudlinux.x86_64
Error: ea-apache24-mod_mpm_prefork conflicts with 1:ea-apache24-mod_cgid-2.4.23-3.el7.cloudlinux.x86_64
Error: ea-apache24-mod_mpm_worker conflicts with 1:ea-apache24-mod_mpm_prefork-2.4.23-3.el7.cloudlinux.x86_64
Error: ea-apache24-mod_cgi conflicts with 1:ea-apache24-mod_mpm_worker-2.4.23-3.el7.cloudlinux.x86_64
Error: ea-apache24-mod_cgid conflicts with 1:ea-apache24-mod_mpm_prefork-2.4.23-3.el7.cloudlinux.x86_64
Error: ea-apache24-mod_cgid conflicts with 1:ea-apache24-mod_cgi-2.4.23-3.el7.cloudlinux.x86_64
Error: ea-apache24-mod_mpm_worker conflicts with 1:ea-apache24-mod_cgi-2.4.23-3.el7.cloudlinux.x86_64
Error: ea-apache24-mod_mpm_prefork conflicts with 1:ea-apache24-mod_mpm_worker-2.4.23-3.el7.cloudlinux.x86_64 at /usr/local/cpanel/Cpanel/PackMan.pm line 602.
  1. 17.11.2016 11:11:23
  2. # 6
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Just to update this thread, we are co-operating with cpanel developers about this case. So far not sure what happened.
  1. 20.11.2016 15:11:38
  2. # 7
fen7azy Accepted Answer
Posts: 6
Joined: 09.11.2016
0
Votes
Undo
Thank you for the reply. Please keep us updated about this case.
  1. 23.11.2016 02:11:17
  2. # 8
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
I was just informed that cPanel are going to fix it from their side, internal case number is CPANEL-9862. Most probably it will be fixed in next WHM v60 release. Changelog could be seen here (issue is not fixed yet): https://documentation.cpanel.net/display/CL/60+Change+Log
  1. 24.11.2016 01:11:05
  2. # 9
fen7azy Accepted Answer
Posts: 6
Joined: 09.11.2016
0
Votes
Undo
Thank you, Bogdan.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
гость
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.