/opt/alt/phpXX/etc/php.ini changed (bug?)
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Morten
  2. 12.10.2016
  3.  Subscribe via email
Does updates automatically change php.ini files?
Rate this post:
  1. 12.10.2016 06:10:01
  2. # 1
Morten Accepted Answer
Posts: 115
Joined: 16.04.2014
0
Votes
Undo
Hello,

As the description on this thread I have noticed on old servers that our settings are reversed.
We usally change some settings in these files:
/opt/alt/php53/etc/php.ini
/opt/alt/php54/etc/php.ini
/opt/alt/php55/etc/php.ini
/opt/alt/php56/etc/php.ini
/opt/alt/php70/etc/php.ini

Normally I only change these settings:
memory_limit = 384M;
post_max_size = 32M;
upload_max_filesize = 32M;
expose_php = Off
allow_url_fopen = On
date.timezone = \"Europe/Berlin\"

When checking some servers today I see that these are back to defaults.
Is this correct? Are you changing these files to defaults when doing yum update?

I saw the file is changed this night:
-rw-r--r-- 1 root linksafe 45K Oct 12 03:37 /opt/alt/php53/etc/php.ini

Could you please shed some light on this and give me a solution where the files are not changed or fix it if it\'s a bug?
  1. 12.10.2016 08:10:06
  2. # 2
Morten Accepted Answer
Posts: 115
Joined: 16.04.2014
0
Votes
Undo
Thanks for you reply.

So basically if I add these values in the global_php.ini file they will update in all the /opt/alt/phpXX/etc/php.ini files and will not be overwritten?

Like this:
; This file provides global settings for php.ini of all alt-php packages
; The structure of this file:
; option = value
; To confirm changes please run:
; /usr/sbin/cagefsctl --setup-cl-selector
[Global PHP Settings]
memory_limit = 384M; 
post_max_size = 32M; 
upload_max_filesize = 32M; 
expose_php = Off 
allow_url_fopen = On 
date.timezone = "Europe/Berlin" 

And then run cagefsctl --setup-cl-selector ?
  1. 18.10.2016 17:10:47
  2. # 3
Morten Accepted Answer
Posts: 115
Joined: 16.04.2014
0
Votes
Undo
I have tested this and got most of them working, but the only line I cannot get updated is the date.timezone.
Here is the content of my file:
; This file provides global settings for php.ini of all alt-php packages
; The structure of this file:
; option = value
; To confirm changes please run:
; /usr/sbin/cagefsctl --setup-cl-selector
[Global PHP Settings]
memory_limit = 384M
post_max_size = 32M
upload_max_filesize = 32M
expose_php = Off
allow_url_fopen = On
date.timezone = "Europe/Oslo"
max_input_vars = 6000

After running cagefsctl --setup-cl-selector date.timezone still shows as:
date.timezone = "UTC"
On all /opt/alt/phpXX/etc/php.ini files. Could you give me some tips or is it a bug?
  1. 19.10.2016 00:10:40
  2. # 4
Scott Neader Accepted Answer
Posts: 87
Joined: 12.06.2014
0
Votes
Undo
EDIT:  Disregard my suggestion -- I see you already have looked at this.
  1. 19.10.2016 02:10:26
  2. # 5
Morten Accepted Answer
Posts: 115
Joined: 16.04.2014
0
Votes
Undo
Thanks for trying to help out Scott :-)
Yes, I have tested on some servers now, but date.timezone is not updating as it should :(
  1. 19.10.2016 04:10:29
  2. # 6
Morten Accepted Answer
Posts: 115
Joined: 16.04.2014
0
Votes
Undo
Ok, thanks for checking this and hope you find a solution quick :-)
There are alot of error_log\'s filling up quite quickly because of UTC date.timezone!

Could you give me an update when this have been fixed?
  1. 10.11.2016 03:11:22
  2. # 7
Morten Accepted Answer
Posts: 115
Joined: 16.04.2014
0
Votes
Undo
Any eta on a fix Bogdan?
  1. 14.11.2016 03:11:12
  2. # 8
Morten Accepted Answer
Posts: 115
Joined: 16.04.2014
0
Votes
Undo
Found another bug now.
All lines I added to global_php.ini file have now been erased on all servers automatically!
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.