Problem with crons and command line php
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Jon Felosi
  2. 23.03.2011
  3.  Subscribe via email
On all of our users who are running crons that execute php, probably other binaries are getting out of memory errors, even after raising memory quite a bit it still happens.
Our whmcs crons and everything quit working so here I am.

what can be done here?
Rate this post:
  1. 23.03.2011 14:03:31
  2. # 1
Igor Seletskiy Accepted Answer
Posts: 1201
Joined: 09.02.2010
0
Votes
Undo
You can disable LVE in cronjobs for now, until the issue is fixed.
http://www.cloudlinux.com/docs/vixie_cron.php
Though I don\'t know what is causing it.

Could you post content of /proc/lve/list
  1. 25.03.2011 16:03:27
  2. # 2
Jon Felosi Accepted Answer
Posts: 2
Joined: 01.11.2010
0
Votes
Undo
4:LVE EP lCPU lIO CPU MEM IO lMEM lEP nCPU fMEM fEP
0 0 30 30 0 0 0 128000 150 1 00
504 0 30 30 735078806 0 0 128000 150 20 0
507 0 30 30 32358377892583 0 0 128000 150 20 0
508 0 30 30 77721939252 0 0 128000 150 20 0
516 1 75 30 59108511306480 779 0 262144 500 20 0
518 0 30 30 221701251327 0 0 128000 150 20 0
523 0 30 30 938648992396 0 0 128000 150 20 0
524 0 30 30 102017225904 0 0 128000 150 20 0
528 0 30 30 1041500751 0 0 128000 150 20 0
544 0 30 30 310313400779 0 0 128000 150 20 0
545 0 30 30 523228147464 0 0 128000 150 20 0
546 0 30 30 113730638888923 0 0 128000 150 21338 0
547 0 30 30 233018661269183 0 0 128000 150 2158453 0
548 0 30 30 1212380 0 0 128000 150 1 00
550 0 30 30 2151915832506 0 0 128000 150 20 0
551 0 30 30 562398437174 0 0 128000 150 20 0
552 0 30 30 112233368 0 0 128000 150 20 0
559 0 30 30 3257003807109 0 0 128000 150 20 0
565 0 30 30 137676367530 0 0 128000 150 20 0
569 0 30 30 38812174603 0 0 128000 150 20 0
573 0 40 30 4313931364800 0 0 193536 200 20 0
576 0 30 30 1253582669759 0 0 128000 150 10 0
577 0 30 30 9226781988989 0 0 128000 150 20 0
578 0 30 30 83389593365538 0 0 128000 150 2301 0
579 0 30 30 12205975696191 0 0 128000 150 20 0
580 0 30 30 320197827313 0 0 128000 150 20 0
585 0 30 30 4481654010 0 0 128000 150 10 0
586 0 25 30 22322063406108 0 0 64000 100 11205 0
587 0 30 30 104943466890 0 0 128000 150 20 0
591 0 30 30 24464 0 0 128000 300 2 00
592 0 30 30 9027968203 0 0 128000 150 20 0
593 0 30 30 86314289374 0 0 128000 150 20 0
600 0 30 30 15338626023 0 0 128000 150 20 0
602 0 30 30 777927074448 0 0 128000 150 10 0
603 0 30 30 129649225225 0 0 128000 150 10 0
605 0 30 30 41579837133 0 0 128000 150 10 0
32006 0 30 30 18675400781 0 0 128000 150 20 0
  1. 25.03.2011 20:03:41
  2. # 3
Igor Seletskiy Accepted Answer
Posts: 1201
Joined: 09.02.2010
0
Votes
Undo
I see users with 1GB hitting the limit from time to time, yet user with 512MB limit hitting it quite a lot of time.

Is it possible that they actually reach the limit. Single PHP process can easily take up 100-200MB, so if multiple processes are spawned it can use that much memory.

Few things you can do:
1. Try setting memory limit to 0 (means no limit)
2. Increasing memory limts, and seeing if they are still hit
3. Check lvetop while running cron jobs (or same command as cronjobs, under user, within lve, via lve_wrapper, or our pam lve module)
4. Using top to check.

Or if you would like -- contact our support or me direct at [email protected] -- and I would be happy to check you system, and see exactly what is going on.
  1. 31.03.2011 11:03:48
  2. # 4
Jon Felosi Accepted Answer
Posts: 2
Joined: 01.11.2010
0
Votes
Undo
email sent, thanks Igor
  1. 03.06.2011 06:06:37
  2. # 5
Rudi Accepted Answer
Posts: 5
Joined: 03.06.2011
0
Votes
Undo
Igor, has this problem been resolved? i.e. have you made it so that cronjobs are ignored? Or what else would you suggest?
  1. 03.06.2011 07:06:36
  2. # 6
Igor Seletskiy Accepted Answer
Posts: 1201
Joined: 09.02.2010
0
Votes
Undo
It was resolved. Make sure you have set virtual memory limit high enough.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.