Требования к mod_lsapi и php
Форум
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Scott Mutter
  2. Friday, 11 March 2016
  3.  Subscribe via email
why does mod_lsapi requires alt-php51?
Rate this post:
  1. 11.03.2016 11:03:36
  2. # 1
Scott Mutter Accepted Answer
Posts: 56
Joined: 23.04.2014
0
Votes
Undo
Why does installing mod_lsapi require alt-php51 to be installed?  Why does mod_lsapi require any alt-php to be installed?

What if I just want PHP 5.5 and PHP 5.6 to be installed?  Why do I have to install all the old versions of PHP?
  1. 11.03.2016 12:03:41
  2. # 2
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Hello,

Well, so far there is no way to install mod_lsapi without older alt-php packages. But you are right about dependencies to older packages, we will consider this situation with out developers.
  1. 11.03.2016 13:03:25
  2. # 3
Scott Mutter Accepted Answer
Posts: 56
Joined: 23.04.2014
0
Votes
Undo
Is there a reason why it would require any PHP version?  I mean, I understand that mod_lsapi is used for PHP and would therefore be fairly useless without some version of PHP installed.  But removing the requirement would mean that alt-php55 or alt-php56 or whatever alt-php version could be installed.

I just don't see the reason why installing mod_lsapi would have to depend on any alt-php being installed.
  1. 11.03.2016 14:03:53
  2. # 4
Baby Accepted Answer
Posts: 23
Joined: 04.10.2012
0
Votes
Undo
Are you concerned about the functionality or disk space usage?

Even though the various alt-php packages are installed, you can prevent any specific PHP version from actually functioning by clicking on it in the Selector tab in the CloudLinux LVE Manager in WHM.

I\'m assuming that\'s the reason you\'re concerned about this issue, and you weren\'t aware of the ability to disable the functionality of unwanted versions.

If, on the other hand, you already know how to disable unwanted PHP versions, and are simply concerned about the disk space usage, which is only about 50-100 MB per version, then you have far too little disk space on your server, and therefore bigger problems to worry about.
  1. 11.03.2016 14:03:26
  2. # 5
Scott Mutter Accepted Answer
Posts: 56
Joined: 23.04.2014
0
Votes
Undo
I have them disabled.  That's an option.  And it's not really disk space related.  I just don't see the point of installing all of the PHP versions if all I'm going to allow is PHP 5.5 and PHP 5.6.  It takes longer to install because it's installing I don't know how many different versions of PHP.  Those PHP versions have to be updated when a new version hits the repository.  It just seems like an overall waste.

I'm just not sure I see why installing mod_lsapi should depend on having any alt-php package installed.  It seems that would solve a lot of problems.  Then instead of having to do a yum groupinstall alt-php you could do a yum install alt-php56 alt-php55 to install only the PHP versions you want.

I'm not meaning for this to sound critical, but just offering a question that might spark some critical thinking.
  1. 12.03.2016 08:03:04
  2. # 6
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Scott, you are right with your thoughts, older packages are not needed by mod_lsapi. They should be optional. Overall removing them will not be fast procedure however our developers created a bugreport about it. Most probably mod_lsapi will depend on latest (php56) only .

Thanks.
  1. 12.03.2016 14:03:00
  2. # 7
Scott Mutter Accepted Answer
Posts: 56
Joined: 23.04.2014
0
Votes
Undo
Why is any PHP package needed for mod_lsapi?  Why does it have to depend on any PHP package?  What if someone just wants to install PHP 5.5 or just PHP 7.0, why should they be forced to install PHP 5.6 also?  Maybe there's a reason why mod_lsapi has to depend on some version of PHP to be installed.  I'll admit it would seem kind of stupid to install mod_lsapi without any PHP, but if people don't want to follow installation instructions, then they get what they deserve.  As long as you make it clear in the install procedure documents to install at least 1 version of PHP to use mod_lsapi, I don't see why mod_lsapi has to require any version of PHP to be installed (although I'm not privy to all the information you are).

What enlightened me to this problem was that I only wanted PHP 5.5 and PHP 5.6 installed on a server.  So instead of doing a yum groupinstall alt-php install as per the documentation, I just did a yum install alt-php56 alt-php55.  Then when installing mod_lsapi from the cloudlinux-updates-testing, I didn't pay that much attention, but this ended up installing alt-php51 (and some others) from cloudlinux-updates-testing because alt-php51 was required by mod_lsapi.  Had I installed alt-php51 (or groupinstall alt-php) from cloudlinux-x86_64-server-6, I would not have had pending updates for PHP 5.1 coming from cloudlinux-updates-testing.  I did get all of this fixed after noticing my error, but that made me question all of this.

On a somewhat related note, and chance of moving mod_lsapi out of cloudlinux-updates-testing and into cloudlinux-x86_64-server-6?  Seems most CloudLinux users are using mod_lsapi.  It would seem to me to be safe to move out of testing.  But again, I'm not a decision maker.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
гость
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.