mod_lsapi медленная нагрузка
Форум
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Scott Mutter
  2. Thursday, 21 January 2016
  3.  Subscribe via email
Slow initial loading of PHP scripts
Rate this post:
  1. 21.01.2016 12:01:38
  2. # 1
Scott Mutter Accepted Answer
Posts: 56
Joined: 23.04.2014
0
Votes
Undo
I'm noticing that accounts that use mod_lsapi to load PHP scripts experiencing a horribly slow load time when they are first being accessed.  It takes about 30 seconds for the script to load (a simple phpinfo() page).  But then if you refresh the page, it loads fine.  Am I doing something wrong?
  1. 21.01.2016 12:01:25
  2. # 2
Scott Neader Accepted Answer
Posts: 89
Joined: 12.06.2014
0
Votes
Undo
Yep, something is wrong.  Our sites load very fast, even WordPress sites, which usually take a long time due to how many calls it takes to build the page. Shoot me a PM and I'll send you some sites so you can compare.  I can tell you more about the configuration of those sites (php version, modules, site caching, etc.)

- Scott
  1. 21.01.2016 13:01:57
  2. # 3
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
I am sure issue is not in mod_lsapi, what if you disable lsapi for this domain and open phpinfo page? Does this happens to all accounts on a server? Also, please check io/iops limits for roblematic LVE.
  1. 21.01.2016 17:01:34
  2. # 4
Scott Mutter Accepted Answer
Posts: 56
Joined: 23.04.2014
0
Votes
Undo
I only have 1 account using CageFS right now, and using mod_lsapi, I\'m just testing this out. The site loads fine when it is run through suphp.

I have to let it sit idle for about an hour or two before testing it and it takes 30 seconds for it to begin to process.

The IO for the account is set at 512KB/s. I do see it hitting that limit.

The IOPS is set at 256, but I don\'t see it getting any where close to that, max IOPS during that time was only 12. Are there suppose to be any options enabled in /usr/local/apache/conf/conf.d/lsapi.conf? All of the configuration options are commented out in that file.
  1. 21.01.2016 17:01:09
  2. # 5
Scott Neader Accepted Answer
Posts: 89
Joined: 12.06.2014
0
Votes
Undo
Disable io limits to see if that is causing it (temporarily set it to 0 for that account or package). 512 may be severely choking disk access for your test account.

- Scott
  1. 21.01.2016 21:01:44
  2. # 6
Scott Mutter Accepted Answer
Posts: 56
Joined: 23.04.2014
0
Votes
Undo
I raised the disk io to 1024KB/s and it still took 15 seconds to start loading.
  1. 22.01.2016 06:01:22
  2. # 7
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Please try to change it to 0 (unlimited ) for io and ios just to test how it goes.
  1. 23.01.2016 12:01:54
  2. # 8
Scott Mutter Accepted Answer
Posts: 56
Joined: 23.04.2014
0
Votes
Undo
I think this had more to do with this just being enabled for the 1 account.  Once I enabled php-selector and mod_lsapi for all accounts, this cleared up.  Everything is loading fine now.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
гость
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.