1. Форумы
  2. CloudLinux и панели управления
  3. CloudLinux и cPanel
  1. Свен
  2. Понедельник, 08 октября 2018
  3. Подписка по электронной почте
На данный момент установлено: 10.2.18-MariaDB (By cPanel)

Пожалуйста, проверьте это


[[email protected] ~]# yum remove db-governor db-governor-mysql
Loaded plugins: fastestmirror, rhnplugin, universal-hooks
This system is receiving updates from CLN.
No Match for argument: db-governor
No Match for argument: db-governor-mysql
No Packages marked for removal
[[email protected] ~]# yum install governor-mysql
Loaded plugins: fastestmirror, rhnplugin, universal-hooks
This system is receiving updates from CLN.
Loading mirror speeds from cached hostfile
epel/x86_64/metalink | 31 kB 00:00:00
* cpanel-addons-production-feed: 85.13.201.2
* cloudlinux-x86_64-server-7: cl-mirror.vimexx.nl
* epel: mirror.imt-systems.com
Resolving Dependencies
--> Running transaction check
---> Package governor-mysql.x86_64 0:1.2-36.el7.cloudlinux will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================================================================================================================================================================================================================================================
Package Arch Version Repository Size
===============================================================================================================================================================================================================================================================================================================
Installing:
governor-mysql x86_64 1.2-36.el7.cloudlinux cloudlinux-x86_64-server-7 260 k

Transaction Summary
===============================================================================================================================================================================================================================================================================================================
Install 1 Package

Total download size: 260 k
Installed size: 1.0 M
Is this ok [y/d/N]: y
Downloading packages:
governor-mysql-1.2-36.el7.cloudlinux.x86_64.rpm | 260 kB 00:00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installing : governor-mysql-1.2-36.el7.cloudlinux.x86_64 1/1
fs.suid_dumpable = 1
Set FS suid_dumpable for governor to work correctly
Add to /etc/sysctl.conf suid_dumpable instruction for governor to work correctly
Run script: /usr/share/lve/dbgovernor/mysqlgovernor.py --install
!!!Before making any changing with database make sure that you have reserve copy of users data!!!
Instruction: how to create whole database backup - http://docs.cloudlinux.com/index.html?backing_up_mysql.html
Verifying : governor-mysql-1.2-36.el7.cloudlinux.x86_64 1/1

Installed:
governor-mysql.x86_64 0:1.2-36.el7.cloudlinux

Complete!
[[email protected] ~]# /usr/share/lve/dbgovernor/mysqlgovernor.py --mysql-version=mariadb102
Now set MySQL to type 'mariadb102'
[[email protected] ~]# /usr/share/lve/dbgovernor/mysqlgovernor.py --install
!!!Before making any changing with database make sure that you have reserve copy of users data!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!Ctrl+C for cancellation of installation!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Instruction: how to create whole database backup - http://docs.cloudlinux.com/index.html?backing_up_mysql.html
---
metadata:
command: configureservice
reason: Disabled monitoring for mysql.
result: 1
version: 1
Start download current installed packages
URL http://httpupdate.cpanel.net/RPM/unknown/centos/7/x86_64/MariaDB-server-10.2.18-1.el7.centos.x86_64.rpm
Downloaded file /usr/share/lve/dbgovernor/tmp/governor-tmp/old/MariaDB-server-10.2.18-1.el7.centos.x86_64.rpm from http://httpupdate.cpanel.net/RPM/unknown/centos/7/x86_64/MariaDB-server-10.2.18-1.el7.centos.x86_64.rpm with status 200
URL http://httpupdate.cpanel.net/RPM/unknown/centos/7/x86_64/MariaDB-compat-10.2.18-1.el7.centos.x86_64.rpm
Downloaded file /usr/share/lve/dbgovernor/tmp/governor-tmp/old/MariaDB-compat-10.2.18-1.el7.centos.x86_64.rpm from http://httpupdate.cpanel.net/RPM/unknown/centos/7/x86_64/MariaDB-compat-10.2.18-1.el7.centos.x86_64.rpm with status 200
URL http://httpupdate.cpanel.net/RPM/unknown/centos/7/x86_64/MariaDB-devel-10.2.18-1.el7.centos.x86_64.rpm
Downloaded file /usr/share/lve/dbgovernor/tmp/governor-tmp/old/MariaDB-devel-10.2.18-1.el7.centos.x86_64.rpm from http://httpupdate.cpanel.net/RPM/unknown/centos/7/x86_64/MariaDB-devel-10.2.18-1.el7.centos.x86_64.rpm with status 200
URL http://httpupdate.cpanel.net/RPM/unknown/centos/7/x86_64/MariaDB-shared-10.2.18-1.el7.centos.x86_64.rpm
Downloaded file /usr/share/lve/dbgovernor/tmp/governor-tmp/old/MariaDB-shared-10.2.18-1.el7.centos.x86_64.rpm from http://httpupdate.cpanel.net/RPM/unknown/centos/7/x86_64/MariaDB-shared-10.2.18-1.el7.centos.x86_64.rpm with status 200
URL http://httpupdate.cpanel.net/RPM/unknown/centos/7/x86_64/MariaDB-common-10.2.18-1.el7.centos.x86_64.rpm
Downloaded file /usr/share/lve/dbgovernor/tmp/governor-tmp/old/MariaDB-common-10.2.18-1.el7.centos.x86_64.rpm from http://httpupdate.cpanel.net/RPM/unknown/centos/7/x86_64/MariaDB-common-10.2.18-1.el7.centos.x86_64.rpm with status 200
URL http://httpupdate.cpanel.net/RPM/unknown/centos/7/x86_64/MariaDB-client-10.2.18-1.el7.centos.x86_64.rpm
Downloaded file /usr/share/lve/dbgovernor/tmp/governor-tmp/old/MariaDB-client-10.2.18-1.el7.centos.x86_64.rpm from http://httpupdate.cpanel.net/RPM/unknown/centos/7/x86_64/MariaDB-client-10.2.18-1.el7.centos.x86_64.rpm with status 200
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/old/MariaDB-devel-10.2.18-1.el7.centos.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/old/MariaDB-shared-10.2.18-1.el7.centos.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/old/MariaDB-common-10.2.18-1.el7.centos.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/old/MariaDB-compat-10.2.18-1.el7.centos.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/old/MariaDB-client-10.2.18-1.el7.centos.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/old/MariaDB-server-10.2.18-1.el7.centos.x86_64.rpm was loaded
Start download packages for new installation
Loaded plugins: fastestmirror, rhnplugin, universal-hooks
Cleaning repos: cpanel-addons-production-feed MariaDB102 cl-ea4 cl-mysql-meta cloudlinux-imunify360 cloudlinux-x86_64-server-7 cpanel-plugins epel imunify360 imunify360-alt-php imunify360-ea-php-hardened kernelcare letsencrypt-cpanel lynis zabbix zabbix-non-supported
Cleaning up everything
Maybe you want: rm -rf /var/cache/yum, to also free up space taken by orphaned data from disabled or removed repos
Cleaning up list of fastest mirrors
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB-meta-client-10.2.18-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB-meta-devel-10.2.18-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB-meta-10.2.18-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB-meta-client-10.2.18-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB-meta-devel-10.2.18-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/mysqlclient16-5.1.73-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/mysqlclient15-5.0.91-2.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/mysqlclient18-compat-10.1.28-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/libaio-0.3.109-13.el7.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB-meta-client-10.2.18-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB102-bench-10.2.17-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB102-libs-10.2.17-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB102-server-10.2.17-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB102-10.2.17-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB102-server-10.2.17-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB102-bench-10.2.17-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB102-devel-10.2.17-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB102-libs-10.2.17-1.el7.cloudlinux.x86_64.rpm was loaded
Package /usr/share/lve/dbgovernor/tmp/governor-tmp/new/cl-MariaDB102-devel-10.2.17-1.el7.cloudlinux.x86_64.rpm was loaded
New packages will be installed:
cl-MariaDB-meta-10.2.18-1.el7.cloudlinux.x86_64.rpm
cl-MariaDB-meta-client-10.2.18-1.el7.cloudlinux.x86_64.rpm
cl-MariaDB-meta-devel-10.2.18-1.el7.cloudlinux.x86_64.rpm
cl-MariaDB102-10.2.17-1.el7.cloudlinux.x86_64.rpm
cl-MariaDB102-bench-10.2.17-1.el7.cloudlinux.x86_64.rpm
cl-MariaDB102-devel-10.2.17-1.el7.cloudlinux.x86_64.rpm
cl-MariaDB102-libs-10.2.17-1.el7.cloudlinux.x86_64.rpm
cl-MariaDB102-server-10.2.17-1.el7.cloudlinux.x86_64.rpm
libaio-0.3.109-13.el7.x86_64.rpm
mysqlclient15-5.0.91-2.el7.cloudlinux.x86_64.rpm
mysqlclient16-5.1.73-1.el7.cloudlinux.x86_64.rpm
mysqlclient18-compat-10.1.28-1.el7.cloudlinux.x86_64.rpm
You are attempting to install a LOWER mariadb version (10.2.17) than currently installed one (10.2.18).
This could lead to unpredictable consequences, like fully non working service.
Think twice before proceeding.
Continue? [y/n] n
Оценить этот пост:
  1. 09.10.2018 14:10:18
  2. # 1
Свен Принято ответа
Сообщений: 5
Присоединился: 13.11.2017
0
Голосов
расстегивать
Ничего?
  1. 10.10.2018 12:10:55
  2. # 2
Александр Парубочий Принято ответа
Сообщений: 187
Присоединился: 31.01.2017
0
Голосов
расстегивать
Привет Свен,

В соответствии с https://www.cloudlinux.com/cloudlinux-os-blog/entry/beta-mariadb-for-mysql-governor-updated-1-16
третья команда CLI должна быть:
# /usr/share/lve/dbgovernor/mysqlgovernor.py --install-beta
  1. 10.10.2018 19:10:19
  2. # 3
Свен Принято ответа
Сообщений: 5
Присоединился: 13.11.2017
0
Голосов
расстегивать
cPanel только что установил MariaDB 10.2.
Так я действительно должен это сделать ?: /usr/share/lve/dbgovernor/mysqlgovernor.py --install-beta

Когда я это сделаю: yum установить Governor-MySQL
Губернатор активирован и работает.
  1. 12.10.2018 15:10:03
  2. # 4
Александр Парубочий Принято ответа
Сообщений: 187
Присоединился: 31.01.2017
0
Голосов
расстегивать
MySQL Governor требует версию MariaDB, установленную из репозиториев CloudLinux для ее работы.
  1. 12.10.2018 21:10:44
  2. # 5
Свен Принято ответа
Сообщений: 5
Присоединился: 13.11.2017
0
Голосов
расстегивать
Хорошо, извините за вопрос, но для меня было непонятно, зачем мне снова устанавливать ту же версию MariaDB.
  • Страница:
  • 1


Там нет ответов, сделанные на этот пост пока нет.
Будьте одним из первых, чтобы ответить на этот пост!
гость
Отправить Ваш ответ
Загрузить файлы или изображения для обсуждения этого вопроса, нажав на кнопку загрузки ниже. опоры GIF, JPG, PNG, ZIP, RAR, PDF
• Вставить • Удалить Загрузка файлов (Максимальный размер файла: 2 MB)
Защитный код
Чтобы защитить сайт от ботов и несанкционированных сценариев, мы требуем, чтобы вы ввели коды капчи ниже, прежде чем отправить свой вопрос.