Блог CloudLinux - бета-версия: обновление EasyApache 4

Beta: EasyApache 4 обновлен

easyapache

Обновленные пакеты EasyApache 4 доступны для загрузки из нашего тестового репозитория.

Список изменений:

ea-cpanel-tools-1.0-25.cloudlinux

  • обновлено до версии 1.0-25

ea-nodejs10-10.17.0-1.cloudlinux

  • обновлен до версии 10.17.0

ea-php-cli-1.0.0-9.cloudlinux

  • обновлено до версии 1.0.0-9

ea-php71-7.1.33-1.cloudlinux

ea-php71-php-7.1.33-1.cloudlinux

  • обновлен до версии 7.1.33

ea-php72-7.2.24-1.cloudlinux

ea-php72-php-7.2.24-1.cloudlinux

  • обновлен до версии 7.2.24

ea-php73-7.3.11-1.cloudlinux

ea-php73-php-7.3.11-1.cloudlinux

  • обновлен до версии 7.3.11

Вы можете найти полный список изменений здесь.

Обновления PHP включают исправление для CVE-2019-11043, более подробно в ссылках ниже: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11043.

Журнал изменений для усиленного PHP

ea-php52-php-5.2.17-27.cloudlinux.20

  • исправлено #76342: file_get_contents ждет дважды указанное время ожидания
  • исправлено #76859 stream_get_line пропускает данные при использовании с фильтром генерации данных

ea-php53-php-5.3.29-29.cloudlinux.14

ea-php54-php-5.4.45-64.cloudlinux.3

ea-php55-php-5.5.38-47.cloudlinux.3

  • исправлено #76342: file_get_contents ждет дважды указанное время ожидания
  • исправлено #76859 stream_get_line пропускает данные при использовании с фильтром генерации данных
  • исправлено #78579: mb_decode_numericentity: несоответствие числа аргументов
  • исправлена ​​ошибка #78599 (переполнение env_path_info может привести к RCE) (CVE-2019-11043)

ea-php56-php-5.6.40-9.cloudlinux.3

  • исправлено #76342: file_get_contents ждет дважды указанное время ожидания
  • исправлено #76859 stream_get_line пропускает данные при использовании с фильтром генерации данных
  • исправлено #78413: php-fpm request_terminate_timeout не вступает в силу после fastcgi_finish_request
  • исправлено #78579: mb_decode_numericentity: несоответствие числа аргументов
  • исправлена ​​ошибка #78599 (переполнение env_path_info может привести к RCE) (CVE-2019-11043)

ea-php70-php-7.0.33-10.cloudlinux.3

  • исправлено #76342: file_get_contents ждет дважды указанное время ожидания
  • исправлено #76859 stream_get_line пропускает данные при использовании с фильтром генерации данных
  • исправлено #78413: php-fpm request_terminate_timeout не вступает в силу после fastcgi_finish_request
  • исправлено #78535: значение auto_detect_line_endings не анализируется как bool
  • исправлено #78579: mb_decode_numericentity: несоответствие числа аргументов
  • исправлена ​​ошибка #78599 (переполнение env_path_info может привести к RCE) (CVE-2019-11043)
  • исправлена ​​ошибка #78612
  • исправлено #78620: ошибка нехватки памяти
  • исправлено #78641: addGlob может изменять заданное значение remove_path

Обновления PHP включают исправление для CVE-2019-11043, более подробно в ссылках ниже: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11043.

Обновить команду

yum update ea-* --enablerepo=cl-ea4-testing
Beta: обновлен Alt-PHP
Beta: обновлен MySQL Governor

Комментарии

Нет комментариев на форуме. Будьте первым, чтобы оставить свой комментарий
Уже зарегистрирован? ВОЙТИ
гость
Понедельник, 27 января 2020

Защитный код изображение

Отправляя свой комментарий, вы соглашаетесь с Cloudlinux Политика Kонфиденциальности