Блог ОС CloudLinux - Селектор Node.js для DirectAdmin уже в разработке!
Блог CloudLinux OS

Node.js Селектор для DirectAdmin теперь готов к работе!

Node.js Селектор для DirectAdmin теперь готов к работе!

Мы рады сообщить, что поддержка DirectAdmin была добавлена ​​с последней версией выпуска LVE Manager-4.0-19.7. Это позволяет клиентам, использующим DirectAdmin, воспользоваться всеми функциями Node.js Selector, включая максимальную гибкость и удобный пользовательский интерфейс, который поможет новым пользователям быстрее познакомиться с селектором Node.js.

С помощью CloudLinux Node.js Selector ваши клиенты теперь могут размещать свои приложения для JavaScript с помощью Node.js 6.x, 8.x, 9.x или 10.x.

Node.js представлен с дружественным интерфейсом, который объединяет все функции в одном месте и делает его очень удобным для управления.

Чтобы узнать, как управлять селектором Node.js, прочитайте эта документация.

Если вы хотите узнать больше о Node.js Selector и как его вывернуть, вы можете посмотреть это Запись вебинара Академии CloudLinux.

Мы были бы чрезвычайно благодарны за предоставленную обратную связь! Если у вас есть какие-либо вопросы или комментарии, пожалуйста, не стесняйтесь и напишите нам по адресу Этот адрес электронной почты защищен от спам-ботов. Ботов, для его просмотра включен JavaScript..

Команда для обновления:

yum update alt-python27-cllib lvemanager lve-utils cagefs

Список изменений:

альт-python27-cllib-1.4-10.1

  • LVES-907: фиксированное отображение «N / A» вместо домена на Plesk;
  • LU-775: stderr теперь игнорируется при вызове whmapi1 & uapi;
  • LU-762: исправлено cPanel postmodifyacct: нет такого файла или каталога: '/ var / lve / tmp / USERNAME';
  • PTCLLIB-119: исключение для чтения человеком показано, когда конфигурация MySQL Governor неверна;
  • PTCLLIB-117: переработан плагин DirectAdmin cpapi в соответствии с улучшениями DirectAdmin;
  • LU-725: префикс Unicode возвращается с ключом «app_uri» для Node.js Selector;
  • LU-735: добавлена ​​возможность использования дополнительных доменов в DirectAdmin для создания приложений Node.js;
  • LU-737: remount_proc.py теперь не игнорирует fs.proc_super_gid в файлах /etc/sysctl.d/*;
  • LU-732: фиксированные поддомены в привязке для изменения основного домена.

LVE-Utils-3.0-14.3

  • LU-813: переработано неверное сообщение об ошибке при попытке удалить приложение с уже удаленными папками;
  • LU-773: сделал некоторый рефакторинг механизма кэширования в lvectllib.py;
  • LU-537: добавлено задание cron для обнаружения панели управления и автоматическая реконфигурация нашего программного обеспечения;
  • LU-632: теперь администратор не может устанавливать ограничения PMEM и VMEM для пользователя в реселлере с ограничениями;
  • LU-756: фиксированная карта синхронизации для пользователей с одинаковым UID;
  • LU-754: теперь проверяется, что пользователь действительно существует в системе, прежде чем получать другую информацию;
  • LVEMAN-1269: улучшен механизм создания значка Node.js в пользовательском интерфейсе конечного пользователя;
  • LU-752: исправлена ​​проблема, когда ни одному из пакетов не назначено пользователю в LVE Manager, когда у подписки есть дополнительные планы, выбранные в Plesk;
  • LU-725: префикс Unicode возвращается с ключом «app_uri» для Node.js Selector;
  • LU-661: реализована блокировка версий Node.js для CLI администратора;
  • LU-731: фиксированное обнаружение H-сферы;
  • LU-662: реализована блокировка для приложений Node.js;
  • LU-737: remount_proc.py теперь не игнорирует fs.proc_super_gid в файлах /etc/sysctl.d/*;
  • LU-693: команда «selectorctl --interpreter nodejs» теперь печатает «вместо этого используйте утилиту cloudlinux-selector»;
  • LVEMAN-1260: «--new-app-uri» теперь является необязательным при перемещении приложения только в новый домен;
  • LU-740: фиксированная трассировка при вызове «cloudlinux-selector», когда LVE Manager не был установлен.

cagefs-6.1-23

  • CAG-821: добавлено process_ssl_pending_queue в /etc/cagefs/proxy.commands;
  • LU-797: cldiag теперь работает, когда CageFS отключен;
  • CAG-818: cagefsctl --setup-cl-selector теперь отправляет SIGHUP в PHP-процессы пользователей с включенным CageFS;
  • LU-726: добавлен git в CageFS для установки git-пакетов с использованием npm;
  • CAG-808: исключенные virtfs монтируются из CageFS.

lvemanager-4.0-19.7

  • WEB-1069: фиксированная ширина кнопки на странице «Лицензия» для панелей DirectAdmin и Plesk;
  • WEB-1068: исправить ошибку о завершении сеанса в LVE Manager в Plesk \ DirectAdmin;
  • WEB-1065: добавлены переводы в соответствии с LU-813;
  • WEB-1063: фиксированная вкладка. Редактирование приложения Node.js для темы «тема» cPanel;
  • WEB-1064: фиксированный перевод для ярлыка приложения Node.js;
  • WEB-1031: удалено включение флагов Imunify360 в сборку;
  • WEB-1060: исправлена ​​проблема, когда страница истории не может быть открыта в интерфейсе Hoster \ Reseller менеджера LVE в локали RUS cPanel;
  • WEB-1058: изменения для пределов реселлера теперь отображаются правильно в плагине LVE Manager;
  • WEB-986: исправлена ​​проблема при сохранении лимитов, порождая два одинаковых запроса после включения / отключения пределов;
  • WEB-1045: исправлена ​​проблема с «переключателем CageFS» в рамке «пределы редактирования» для локали «ru»;
  • WEB-1040: фиксированная трассировка для редактирования пакета;
  • WEB-994: добавлено правильное имя сообщения в поле версии Node.js, если версия Node.js для приложения была отключена;
  • WEB-1042: включить локализацию России в LVE Manager;
  • WEB-840: проверенный русский перевод;
  • WEB-1024: аргумент --env-vars теперь работает так же на DirectAdmin и cPanel;
  • WEB-1025: исправлена ​​проблема с отображением «История» в LVE Manager реселлера;
  • WEB-1023: фиксированные выпадающие списки в LVE Manager;
  • WEB-1016: фиксированное отображение SPEED MYSQL. Теперь он отображается с знаком%;
  • WEB-1010: исправлен неправильный угловой режим в сборке;
  • WEB-1014: фиксированное введение новых строк в вкладку «Пользователи» после сортировки;
  • WEB-1012: исправлена ​​ошибка плагина DirectAdmin LVE Manager;
  • WEB-731: объект Row теперь используется в вкладках «Пользователи» и «Пакеты» вместо rowNum;
  • WEB-1013: обновлены отсутствующие заголовки для расширенного представления сведений о записи пользователя;
  • LU-693: команда «selectorctl --interpreter nodejs» теперь не печатает «вместо этого используйте утилиту cloudlinux-selector»;
  • LVEMAN-1283: удалены ненужные крючки для расширения cPanel LVE;
  • LU-759: при вводе виртуальной среды Node.js каталог теперь автоматически изменяется на корневой каталог приложений;
  • LU-702: улучшена проверка «переменных среды» для Node.js Selector;
  • WEB-1009: фиксированное определение типа здания для производства;
  • WEB-1004: фиксированная индикация приложения «старт / стоп» в общем списке при запуске / остановке приложения на странице редактирования;
  • WEB-975: изменение сортировки таблиц с использованием исходных данных;
  • WEB-898: исправлена ​​некорректная просьба о чтении-чтении-снимке;
  • WEB-979: пересмотренное switch.pm Использование модуля Perl в cPanel;
  • WEB-823: поле поиска теперь используется в тестах интеграции на вкладке Package;
  • WEB-980: кнопка «создать приложение» теперь отключена, когда все версии Node.js отключены;
  • LU-763: объединить все ответы от утилиты cloudlinux-selector;
  • WEB-588: реализована перенос слов для сообщений об ошибках на вкладке «Пользователи»;
  • LVEMAN-1269: улучшен механизм создания значка Node.js в пользовательском интерфейсе конечного пользователя;
  • LVEMAN-1275: исправлена ​​cl-квота, если она работает в LVE Manager на DirectAdmin;
  • WEB-997: размеры для ограничения EntryProcs теперь не используются;
  • LVEMAN-1272: уже созданные приложения Node.js теперь не скрыты для пользователя после добавления его в CageFS;
  • WEB-991: фиксированные визуальные проблемы при всплывающих окнах и подсказки для вкладки Node.js в DirectAdmin;
  • WEB-993: исправлена ​​проблема с CSS для раскрывающегося списка «версия Node.js» в пользовательской части Node.js Selector;
  • LU-746: добавлена ​​возможность изменять домены для приложения, даже если это псевдоним предыдущего домена;
  • Добавлена ​​фиксированная версия LVEMAN-1277 для приложения Python под пользователем;
  • WEB-957: обновленная версия с угловым до 5;
  • WEB-964: исправлены ошибки в консоли браузера в Plesk 17.8 для LVE Manager;
  • WEB-840: проверенный русский перевод;
  • WEB-887: исследована возможность локализации плагина LVE Extension для cPanel;
  • WEB-992: функция фиксированного поиска на вкладке «Параметры» для возможности использования любых определенных символов в поисковой фразе;
  • LU-741: фиксированное старт / остановка приложения Node.js в доменах CPanel;
  • WEB-970: реорганизованные тесты для использования атрибутов не углового;
  • WEB-414: большие таблицы не отображаются в веб-интерфейсе статистики пользователя;
  • WEB-971: фиксированный внешний вид и выравнивание кнопки;
  • WEB-963: увеличение размера поля «URL-адрес приложения Node.js»;
  • WEB-780: добавлена ​​проверка того, что для запросов разрешены только методы POST и GET;
  • WEB-324: реализовано отключение PHP Selector для Plesk;
  • WEB-961: разрешен символ точки в каталогах приложений;
  • WEB-629: исправлена ​​ошибка, когда сообщение об ошибке UI не отображается, если установлено недопустимое значение ЦП в качестве ограничения пользователя;
  • WEB-969: ключ активации и пароли теперь не используются непосредственно в источнике кода;
  • WEB-776: закрытое переключение пределов реселлера (WEB-762) с помощью тестов интеграции после реализации объекта страницы;
  • WEB-628: Селектор PHP: перемещены флажки для модулей PHP справа налево;
  • WEB-988: плагин ограниченного реселлера для администратора DirectAdmin, представленный реселлером;
  • WEB-928: созданный пользовательский интерфейс пользователя Node.js Selector для DirectAdmin;
  • WEB-974: улучшенное задание пилота-менеджера LVE Manager, позволяющее использовать дополнительные параметры;
  • WEB-585: разработанные интеграционные тесты для страницы лицензии;
  • LVEMAN-1256: запрещено указывать файл package.json в файле запуска приложения для Node.js Selector;
  • LU-732: фиксированные поддомены в привязке для изменения основного домена;
  • LU-718: приложение теперь перемещается в новый домен, когда домен переименовывается в DirectAdmin;
  • LU-661: переключение версии интерпретатора приложения теперь блокирует интерпретатор;
  • LU-726: добавлен git в CageFS для установки git-пакетов с использованием npm;
  • LVEMAN-1241: исправлена ​​проблема, когда cl-quota -YC cron job сбрасывает льготный период льготного предела;
  • WEB-937: исправлена ​​проблема с аккордеоном на вкладке «Параметры»;
  • WEB-849: реализована функция поиска на вкладке «Параметры»;
  • WEB-791: добавлена ​​возможность управлять ограничениями пользователей с «Текущее использование» в плагине реселлера;
  • WEB-965: исправлена ​​проблема при попытке создать новое приложение Node.js;
  • WEB-944: теперь невозможно запустить установку пакетов npm, нажав кнопку «Запустить NPM Install»;
  • WEB-945: улучшено поведение кнопки «Run NPM Install» для пользовательского интерфейса пользователя Node.js Selector;
  • LU-693: команда «selectorctl --interpreter nodejs» теперь печатает «вместо этого используйте утилиту cloudlinux-selector»;
  • WEB-949: фиксированное отображение сообщения об ошибке на вкладке Selector, когда CageFS еще не установлен;
  • WEB-956: адаптированная тестовая система для новой системы сборки (исправление);
  • WEB-932: исправлено размещение сообщения об отключении для Node.js;
  • WEB-958: разрешен конфликт во время выполнения тестов Admin в параллельном потоке;
  • WEB-968: улучшенные тесты Node.js для обнаружения полной версии Node.js;
  • LVEMAN-1260: «--new-app-uri» теперь является необязательным при перемещении приложения только в новый домен;
  • WEB-930: страница «плагин недоступен» теперь отображается пользователям, когда Node.js Selector отключен;
  • WEB-943: распространяется на вкладку «Параметры» вкладки «Интеграционные тесты»;
  • WEB-872: исправлена ​​проблема, когда поля ввода для MySQL Governor не скрываются / появляются при включении / выключении «Отслеживание пользователя с помощью MYSQL Governor»;
  • WEB-890: реализованы автотесты для вкладки «Текущее использование» реселлера;
  • WEB-911: измененный запрос на включение / выключение версии Node.js;
  • WEB-915: скорректированный текст в LVEManager для конфигурации DB Governor;
  • WEB-920: удалены старые файлы плагинов LVE Manager после обновления до версии SPA в DirectAdmin;
  • WEB-923: улучшен индикатор выполнения при запуске кеша для Node.js на вкладке «Параметры» в LVE Manager;
  • WEB-929: удалена зависимость прототипа в Plesk для LVE Manager;
  • WEB-933: улучшено поведение раскрывающегося списка «Выбрать версию» на вкладке Node.js - интерфейс администратора;
  • WEB-939: фиксированные функциональные кнопки в формах для редактирования приложений Node.js;
  • WEB-936: улучшено редактирование приложения на стороне пользователя Node.js Selector;
  • WEB-934: улучшен переход от списка версий к списку приложений в админ-части Node.js Selector;
  • WEB-928: создать пользовательский интерфейс пользователя Node.js Selector для DirectAdmin.
Beta: обновление MariaDB для MySQL Governor
Imunify360 3.4.1 Beta уже здесь!

Комментарии

Нет комментариев на форуме. Будьте первым, чтобы оставить свой комментарий
Уже зарегистрирован? ВОЙТИ
гость
Вторник, 19 ноября 2019

Защитный код изображение