CloudLinux - Блог CloudLinux - обновлено mod_lsapi
Блог CloudLinux OS

Обновление для mod_lsapi

Обновление для mod_lsapi

Новые обновленные пакеты mod_lsapi для CloudLinux 6 и 7, а также для Apache 2.4 (CloudLinux 6 и 7) и EasyApache 4 (CloudLinux 6 и 7) теперь доступны для загрузки из нашего производственного репозитория.

Внимание, Мы выпустили стабильный пакет CRIU только для CloudLinux 7.
На данный момент CRIU не поддерживается гибридным ядром CloudLinux 6. Мы собираемся проверить его совместимость в задаче MODLS-509.

Список изменений:

mod_lsapi 1.1-25

it-apache24-mod_lsapi 1.1-25

httpd24-mod_lsapi 1.1-25

  • зависимость от alt-libxml2 удалена из ea-apache24-mod_lsapi;
  • Параметр lsapi_backend_semtimedwait включен по умолчанию;
  • MODLS-494: установлен флаг ~ / mod_lsapi_reset_me для удаления всех изображений CRIU для всех доменов пользователя;
  • MODLS-483: исправлено преждевременное уничтожение мьютексов на мероприятии MPM;
  • MODLS-478: префикс lsapi-ошибок с отметками времени;
  • MODLS-475: очистка изображений criu при ошибке дампа;
  • MODLS-472: отключить размер основного файла при BACKEND_COREDUMP;
  • MODLS-470: сбросить все изображения criu при обновлении criu-lve и alt-phpXY;
  • MODLS-466: улучшена служба lsapi-cache;
  • AAP-189: ea-apache24-mod_suphp-0.7.2-21 установка пакета flush обработчики PHP для suphp;

верный 3.7-3

  • MODLS-488: отключена отправка SIGKILL при сбрасывании pid, уже используемом другим процессом;
  • MODLS-489: выполнен CRIU с новой частью ядра 2 (патч OpenVZ);
  • MODLS-489: выполнено CRIU с новым ядром;
  • обновлен до версии CRIU 3.7;
  • MODLS-469: исправлена ​​ошибка сброса CRIU SYSVIPC shmem;
  • MODLS-471: временные файлы теперь корректно очищаются после восстановления;
  • MODLS-409: фиксированный пирог CRIU, висящий на свалке;
  • MODLS-356: добавлена ​​поддержка PrivateTmp в CRIU.

Обновление:

cPanel & RPM Based

$ yum clean all
$ yum update liblsapi liblsapi-devel
$ yum update mod_lsapi
$ service httpd restart

DirectAdmin

$ yum clean all
$ yum update liblsapi liblsapi-devel
$ cd /usr/local/directadmin/custombuild
$ ./build update
$ ./build mod_lsapi

Для установки следуйте инструкциям по ссылке.

EasyApache 4

Обновление:

$ yum clean all
$ yum update liblsapi liblsapi-devel ea-apache24-mod_lsapi
$ service httpd restart

Установка:

$ yum clean all
$ yum update liblsapi liblsapi-devel

Читайте http://docs.cloudlinux.com/index.html?cpanel_easyapache_4.html

Перейдите в MultiPHP Manager и включите mod_lsapi для доменов через обработчик lsapi.

Узнайте больше о MultiPHP Manager и mod_lsapi на ссылке.

http24 для CloudLinux 6 и CloudLinux 7

Для запуска установки / обновления:

$ yum update liblsapi liblsapi-devel
$ yum install httpd24-mod_lsapi

Для установки criu-lve выполните следующую команду:

# yum очистить все
# yum install criu-lve

Запуск службы criu:

# systemctl enable create
# systemctl начать плакать

Чтобы обновить criu-lve, выполните следующую команду:

# yum очистить все
# yum update criu-lve

Перезапуск службы criu:

# systemctl restart created
# systemctl daemon-reload
Beta: обновление MariaDB для MySQL Governor
Бета-версия: LVE Manager и CageFS обновлены

Комментарии 5

[Электронная почта защищена] [~] # yum install criu-lve
Загруженные плагины: fastestmirror, rhnplugin, универсальные крючки
Настройка процесса установки
Загрузка зеркальных скоростей из кэшированного файла хоста
* EA4: 185.69.232.245
* cpanel-addons-production-feed: 185.69.232.245
* cloudlinux-x86_64-сервер-6-гибрид: de-proxy.cl-mirror.net
* rpmforge: ftp.nluug.nl
Пакет criu-lve недоступен.
Ошибка: ничего не делать

[Электронная почта защищена] [~] # yum install criu-lve Загруженные плагины: fastestmirror, rhnplugin, универсальные крючки Настройка процесса установки Загрузка зеркальных скоростей из кэшированного файла хоста * EA4: 185.69.232.245 * cpanel-addons-production-feed: 185.69.232.245 * cloudlinux-x86_64-server- 6-hybrid: de-proxy.cl-mirror.net * rpmforge: ftp.nluug.nl Нет доступных пакетов criu-lve. Ошибка: ничего не делать
Гость - Джо в воскресенье, 25 March 2018 16: 59

Я ищу обновление, которое исправит эту проблему. https://wordpress.org/support/topic/big-phpxxxxxx-files-in-home-user-cagefs-tmp/page/4/

Они сказали, что им сказали:

Похоже, что проблема должна быть исправлена ​​в предстоящем выпуске группы alt-php, где LiteSpeed ​​SAPI будет обновляться до версии 7.0. Идентификатор задачи - ALTPHP-464 (для вашей справки), мы упомянем об этом в нашем блоге.


Помогло ли это обновление mod_lsapi исправить это? Или я просто жду следующего релиза Alt-PHP? Или оба нужно обновить?

Я ищу обновление, которое исправит эту проблему. https://wordpress.org/support/topic/big-phpxxxxxx-files-in-home-user-cagefs-tmp/page/4/ Они сказали, что им сказали: [цитата] Похоже, что проблема должна быть исправлена в следующем выпуске группы alt-php, где LiteSpeed ​​SAPI будет обновлен до версии 7.0 Идентификатор задачи ALTPHP-464 (для вашей справки), мы упомянем об этом в нашем блоге. [/ quote] Помогает ли это обновление mod_lsapi исправить Это? Или я просто жду выхода следующего Alt-PHP? Или оба должны быть обновлены?

Вы должны будете обновить как Alt-PHP, так и mod_lsapi, когда доступны фиксированные версии. ALTPHP-464 будет выпущен вместе с MODLS-497, MODLS-499 и MODLS-500, которые должны решить проблему.

Вы должны будете обновить как Alt-PHP, так и mod_lsapi, когда доступны фиксированные версии. ALTPHP-464 будет выпущен вместе с MODLS-497, MODLS-499 и MODLS-500, которые должны решить проблему.

Говорит:

Пакет (ы) liblsapi-devel доступен, но не установлен.
Нет пакетов, помеченных для обновления

Как я узнаю, что это уже сделано?

Говорит: пакет (ы) liblsapi-devel доступен, но не установлен. Пакеты не помечены для обновления. Как узнать, сделано ли это уже?
Уже зарегистрирован? ВОЙТИ
гость
Пятница, Февраль 21 2020

Защитный код изображение