Блог KernelCare - KernelCare поддерживает множество дистрибутивов, но работает ли он с вашим ядром?
Блог KernelCare

Для получения дополнительной информации о последней уязвимости (CVE-2018-12130, CVE-2018-12126, CVE-2018-12127 и CVE-2019-11091),
пожалуйста, обратитесь к нашему блоге

KernelCare поддерживает множество дистрибутивов. А что на счет вашего ядра?

KernelCare поддерживает множество дистрибутивов. А что на счет вашего ядра?

Мы часто задаемся вопросом, поддерживается ли конкретное ядро ​​KernelCare. Мы поддерживаем большое количество дистрибутивов и версий ядра, таких как CentOS / RHEL / CL 5,6 & 7, Debian, Ubuntu, Virtuozzo и Proxmox VE. Список всех поддерживаемых дистрибутивов, ядер, а также исправлений для них доступен по адресу http://patches.kernelcare.com.

Тем не менее, для упрощения процесса мы выпустили простой скрипт, который вы можете запустить на своем сервере, чтобы точно узнать.

https://github.com/iseletsk/kernelchecker/blob/master/py/kc-compat.py

Его можно выполнить, выполнив:

curl -s https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py|python

Или ...

wget -qq -O - https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py|python

Сценарий будет отвечать:

  • СОВМЕСТИМОЕ -> Ядро, поддерживаемое KernelCare
  • UNSUPPORTED -> KernelCare не распознает ядро
  • НЕ ПОДДЕРЖИВАЕТСЯ; INSIDE CONTAINER -> работает внутри контейнера, не может исправлять ядро

HardenedPHP - еще один день, другое исправление безопасности
Бета-версия: CageFS, LVE Manager и обновленные версии

Комментарии 24

Хороший сценарий Игорь .

Хороший сценарий Игорь :).

Здравствуйте,
Я не могу установить kernelcare для моего сервера работает Cloudlinx 7.2.
Пожалуйста, проверьте еще раз.
# wget -qq -O - https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py|python
(False, «UNSUPPORTED»)
uname -a
Linux xxxxxxxx.xxxxx.xxxxx 3.10.0-427.10.1.lve1.4.7.el7.x86_64 #1 SMP Sat Apr 2 12: 09: 46 EDT 2016 x86_64 x86_64 x86_64 GNU / Linux

Привет, я не могу установить kernelcare для моего сервера работает Cloudlinx 7.2. Пожалуйста, проверьте еще раз. # wget -qq -O - https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py|python (False, 'UNSUPPORTED') uname -a Linux xxxxxxxx.xxxxx.xxxxx 3.10.0- 427.10.1.lve1.4.7.el7.x86_64 #1 SMP Sat Apr 2 12: 09: 46 EDT 2016 x86_64 x86_64 x86_64 GNU / Linux
WisiKlo WisiKlo в субботу, 23, апрель, 2016, 17: 50.

Пожалуйста, попробуйте сейчас. Это было исправлено.

Пожалуйста, попробуйте сейчас. Это было исправлено.

[[Электронная почта защищена]: ~] curl -s https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py|python
НЕ ПОДДЕРЖИВАЕТСЯ
[[Электронная почта защищена]: ~] uname -a
Linux excession.server.gtaxl.net 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1 + deb8u6 (2015-11-09) x86_64 GNU / Linux
[[Электронная почта защищена]: ~] cat / etc / debian_version
8.4

ЧТО? Но я вижу это в списке здесь, http://patches.kernelcare.com/e89cc28de257ef3f903fcb12e94e4e8391763f81/9/kpatch.html

[[Электронная почта защищена]: ~] curl -s https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py|python UNSUPPORTED [[Электронная почта защищена]: ~] uname -a Linux excession.server.gtaxl.net 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1 + deb8u6 (2015-11-09) x86_64 GNU / Linux [[Электронная почта защищена]: ~] cat / etc / debian_version 8.4 WHAT? :( Но я вижу, что он указан здесь, http://patches.kernelcare.com/e89cc28de257ef3f903fcb12e94e4e8391763f81/9/kpatch.html

У вас есть версия 3.16.0.x
Самое раннее, что мы поддерживаем, - 3.16.7
Прости

У вас есть версия 3.16.0.x. Самое раннее, что мы поддерживаем, это 3.16.7 извините :(

На самом деле - вы правы, его нужно поддерживать, позвольте мне попробовать / дважды проверить.

На самом деле - вы правы, его нужно поддерживать, позвольте мне попробовать / дважды проверить.

Попробуйте сейчас, небольшая ошибка в скрипте вызывала его.

Попробуйте сейчас, небольшая ошибка в скрипте вызывала его.

Приятно, что поддерживается также Debian 8.
Но не так приятно, что отсутствовало ядро ​​4.9 Debian Jessie-backports

Возможно, это можно улучшить, поскольку ядра 4.x имеют гораздо лучшую SSD / файловую систему
поддержка / производительность, и вы уже предлагаете такие ядра для других поставщиков?

Приятно, что поддерживается также Debian 8. :) Но не так приятно, что отсутствовало ядро ​​4.9 Debian Jessie-backports :( Возможно, это можно улучшить, поскольку ядра 4.x имеют гораздо лучшую поддержку SSD / файловой системы / производительность, и вы уже предлагаете такие ядра для других поставщиков?

Здравствуй!
Поддержка таких ядер будет доступна через неделю.
Благодаря!

Здравствуй! Поддержка таких ядер будет доступна через неделю. Благодаря!

Здравствуйте,

довольно, что теперь также поддерживаются ядра Debian 9 / 4.9.x, но все же Debian 8 Backports 4.9 отсутствуют
И так как обработка сетевых / межсетевых экранов была полностью изменена, потребуется больше времени, чтобы перенести настройку с Debian Jessie на Debian Stretch, чтобы этот запрос все еще имел смысл ...

Thx

Привет, довольно, что теперь также поддерживаются ядра Debian 9 / 4.9.x, но все же отсутствуют Debian 8 Backports 4.9;) И так как обработка сетевых / межсетевых экранов была полностью изменена, потребуется больше времени, чтобы перенести установку с Debian Jessie на Debian Stretch поэтому этот запрос все еще имеет смысл ... Thx
Уже зарегистрирован? ВОЙТИ
гость
Среда, 22 мая 2019

Защитный код изображение