ModSecurity: Exec: Execution failed while reading output error
Forum
  1. Forums
  2. Imunify360
  3. Imunify360 and Imunify Sensor
  1. Glenn Taylor
  2. Monday, 20 April 2020
  3.  Subscribe via email
I have been running into this error over the past few days repeatedly on two sites with Cloudflare hosted DNS. One is Drupal and another is an older custom CMS both of which use ckfinder. I get the error uploading images via Drupal while disabling Cloudflare proxy fixed the problem on the older custom CMS.

I was able to fix the Drupal problem by restarting the website (apache) but this solution only works for awhile and requires another apache restart.

Here's the error and it was the same error for both websites:

2020-04-20 10:08:22 Error xx.xx.xx.xx [client xx.xx.xx.xx] ModSecurity: Exec: Execution failed while reading output: /opt/alt/python35/share/imunify360/scripts/modsec_scan.py (The timeout specified has expired) [hostname "http://www.abc.ca"] [uri "/media/add/image"] [unique_id "Xp3Ifa6sZEszyFFcVw6C8AAAARI"], referer: https://www.abc.ca/media/add/image Apache error

2020-04-20 10:08:22 Error xx.xx.xx.xx [client xx.xx.xx.xx] ModSecurity: Rule processing failed. [hostname "http://www.abc.ca"] [uri "/media/add/image"] [unique_id "Xp3Ifa6sZEszyFFcVw6C8AAAARI"], referer: https://www.abc.ca/media/add/image

I get the feeling this is related to cloudflare somehow but can't say why.

Anyone run into this problem before of have any ideas to fix the problem?

Thx
Rate this post:
  1. 20.04.2020 17:04:06
  2. # 1
Sergey Khristich Accepted Answer
Posts: 492
Joined: 20.05.2019
0
Votes
Undo
Hello Glenn,
Thank you for reaching out! Please try adding this to the ModSecurity configuration file:

SecRequestBodyLimitAction ProcessPartial
SecResponseBodyLimitAction ProcessPartial
SecRequestBodyLimit 234217728

If this does not solve the problem could you please create a ticket here https://cloudlinux.zendesk.com/hc/en-us/requests/new and technical experts will help you asap. Thank you for contacting us.
Marketing Manager
  1. 20.04.2020 17:04:13
  2. # 2
Glenn Taylor Accepted Answer
Posts: 38
Joined: 23.04.2015
0
Votes
Undo
Thanks Sergey for getting back to me so quickly.

I added it to apache directives like this:

<IfModule mod_fcgid.c>
FcgidMaxRequestLen 67108864
SecRequestBodyLimit 67108864
SecRequestBodyNoFilesLimit 67108864
SecRequestBodyLimitAction ProcessPartial
SecResponseBodyLimitAction ProcessPartial
SecRequestBodyLimit 234217728
</IfModule>

Is this correct? It didn't seem to work and I had to disable modsecurity on the site again. I use Plesk.
  1. 20.04.2020 18:04:34
  2. # 3
Sergey Khristich Accepted Answer
Posts: 492
Joined: 20.05.2019
0
Votes
Undo
Glenn,
Please add it and try again:

FcgidMaxRequestLen 67108864
SecRequestBodyLimit 234217728
SecRequestBodyNoFilesLimit 67108864
SecRequestBodyLimitAction ProcessPartial
SecResponseBodyLimitAction ProcessPartial

Hope to hear from you soon. Thank you.
Marketing Manager
  1. 20.04.2020 21:04:44
  2. # 4
Glenn Taylor Accepted Answer
Posts: 38
Joined: 23.04.2015
0
Votes
Undo
Hi Sergey,

I added the directives as shown above and it doesn't seem to work. It works for a little while but then the same problem returns.

When making changes to these directives, apache restarts and I think it's the apache restart which fixes the problem for a short time, not the directives.

This now happening with two old CMS sites and one fairly new drupal site though I am waiting to hear if the problem returns on the Drupal site.

Thanks
Glenn
  1. 21.04.2020 09:04:06
  2. # 5
Sergey Khristich Accepted Answer
Posts: 492
Joined: 20.05.2019
0
Votes
Undo
Hello Glenn,
Apparently, this problem cannot be solved without a ticket. Can you open a support ticket https://cloudlinux.zendesk.com/hc/en-us/requests/new so we can take a closer look at your system? You can post the ticket number here and we'll link this thread to it. Thank you.
Marketing Manager
  1. 21.04.2020 13:04:04
  2. # 6
Glenn Taylor Accepted Answer
Posts: 38
Joined: 23.04.2015
0
Votes
Undo
Hi Sergey,

I submitted a ticket last night and the problem is a bug in IM360: DEF-11510

How long before a solution is released?

Thanks
Glenn
  1. 21.04.2020 15:04:49
  2. # 7
Sergey Khristich Accepted Answer
Posts: 492
Joined: 20.05.2019
0
Votes
Undo
Hello Glenn,
We are working on this issue. Unfortunately, we can’t clarify the terms yet.
Get back to you later with a response.
Thanks!
Marketing Manager
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.

EU e-Privacy Directive

We use cookies to ensure you get the best experience using our website and services. Read more about it in our Privacy Policy. Please agree to the use of cookies to proceed. Alternatively, you may disable cookies in your browser at any time.

You have declined cookies. This decision can be reversed.

You have allowed cookies to be placed on your computer. This decision can be reversed.