Imunify 360 not install on Plesk Obsidian
Forum
  1. Forums
  2. Imunify360
  3. Imunify360 and Imunify Sensor
  1. Automata
  2. Sunday, 26 July 2020
  3.  Subscribe via email
Hi,

Operating System: Debian 10.4 - 64 bit

Control Panel: Plesk Obsidian v18.0.28_build1800200720.10

PROBLEM 1:

Imunify 360 not install on Plesk Obsidian.

# START Installation LOG:

Installation daemon created pid file /usr/local/psa/var/modules/imunify360/installation.pid
Installation daemon forked first time
Installation daemon forked second time
Installation daemon initialized
Starting i360deploy.sh
Detecting ostype... debian
Checking for an update to i360deploy.sh
Downloading i360deploy.sh.repo_version (please wait)
New version (2.19) of i360deploy.sh detected
OK, executing i360deploy.sh.repo_version
Download of i360deploy.sh 2.19 successful
Run /usr/local/psa/admin/sbin/modules/imunify360/i360deploy.sh -y --force
Detecting ostype... debian
Skipping check version
In a few moments the script will install latest imunify360-firewall package (w/dependencies)... (Ctrl-C to cancel)
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package gnupg-curl
Warning: apt-key output should not be parsed (stdout is not a terminal)
Executing: /tmp/apt-key-gpghome.M8eO5s4W0q/gpg.1.sh --fetch-keys https://repo.imunify360.cloudlinux.com/defense360/RPM-GPG-KEY-CloudLinux
gpg: requesting key from 'https://repo.imunify360.cloudlinux.com/defense360/RPM-GPG-KEY-CloudLinux'
gpg: key 8C55A6628608CB71: "CloudLinux Packager (CloudLinux Key) Ign:7 https://repo.imunify360.cloudlinux.com/imunify360/ubuntu/10 buster InRelease
Err:8 https://repo.imunify360.cloudlinux.com/imunify360/ubuntu/10 buster Release
404 Not Found [IP: 23.111.175.219 443]
Hit:9 https://repo.cloudlinux.com/kernelcare-debian/9 stable InRelease
Reading package lists...
E: The repository 'https://repo.imunify360.cloudlinux.com/imunify360/ubuntu/10 buster Release' does not have a Release file.
apt-get update error."

# END Installation LOG

In addition, Imunify 360 does not perform any compatibility checks before installing itself without completing the installation.

QUESTION 1-A:
Imunify 360 support Debian 10 and if it does not support it you have an ETA for its support or a beta version ?

QUESTION 1-B:
Imunify 360 support Ubuntu 20.4 and if it does not support it you have an ETA for its support or a beta version ?

PROBLEM 2:

Imunify QuickPatch from the official Plesk Extension page result, as you write and quote "The Imunify QuickPatch extension is compatible with all operating systems supported by Plesk for Linux except for CloudLinux."

This is the preinstallation error message:

The execution of pre-install.php has failed with the following message:
Pre-install check failed: Debian 10.0 is not a supported OS

QUESTION 2-A:
Imunify QuickPatch support Debian 10 and if it does not support it you have an ETA for its support or a beta version ?

QUESTION 2-B:
Imunify QuickPatch support Ubuntu 20.4 and if it does not support it you have an ETA for its support or a beta version ?

Thanks in advance for the support.

NOTE WELL:
Same topic opened in the official support Forum of Plesk Extensions for Imunify 360 and Imunify QuickPatch at this link: https://talk.plesk.com/threads/imunify-360-not-install-on-plesk-obsidian.357494/
Rate this post:
  1. 27.07.2020 09:07:35
  2. # 1
Sergey Khristich Accepted Answer
Posts: 504
Joined: 20.05.2019
0
Votes
Undo
Hello,
Thank you for reaching out! To help you with these questions we need a little bit more information, please create a ticket here https://cloudlinux.zendesk.com/hc/en-us/requests/new and technical experts will help you asap.
If you have any other questions, feel free to ask here. Thank you for contacting us.
Marketing Manager
  1. 27.07.2020 19:07:58
  2. # 2
Automata Accepted Answer
Posts: 1
Joined: 26.07.2020
0
Votes
Undo
Hi dear Sergey Khristich,

I have created a suppot ticket.

Thanks for the support and good day for you.
  1. 28.07.2020 08:07:04
  2. # 3
Sergey Khristich Accepted Answer
Posts: 504
Joined: 20.05.2019
0
Votes
Undo
Hello,
Thank you for continuing! Our specialists will answer you on the ticket as quickly as possible.
Thanks, Have a great day too!
Marketing Manager
  1. 17.09.2020 21:09:07
  2. # 4
Markus Accepted Answer
Posts: 0
Joined: 28.02.2021
0
Votes
Undo
Did you get this issue resolved? I am facing the same problem ...
  1. 18.09.2020 12:09:35
  2. # 5
Sergey Khristich Accepted Answer
Posts: 504
Joined: 20.05.2019
0
Votes
Undo
Did you get this issue resolved? I am facing the same problem ...

Hello Markus,
Thank you for contacting us. Support of Debian 10 will be available from 5.6 release. ETA is October/November this year.
Marketing Manager
  1. 18.02.2021 03:02:41
  2. # 6
Scott Todd Accepted Answer
Posts: 0
Joined: 28.02.2021
0
Votes
Undo
I am experiencing this same issue, I've tried the patch but am still hitting a dead end message : Pre-install check failed: Debian 10.0 is not a supported OS " . I do not wish to replace my OS, very pleased with Debain 10 with Plesk Obsidian, fast, smooth, no glitches.
You indicated that a solution was projected available 10 or 11 of 2020, however I can find no solution. I've looked to Linux Code Kernels for support but do not find a solution there either, at least not as of this writing. I really appreciate the Imunify360, but if I cannot get it to work, what other server safeguard alternative would you recommend?
  1. 18.02.2021 17:02:13
  2. # 7
Posts: 258
Joined: 31.01.2017
0
Votes
Undo
Hi,

Please follow the steps from the following article: https://blog.imunify360.com/release-notes-imunify360-v.5.5-beta to be able to install it on Debian 10. This will install ver. 5.5 from beta.
This version will be available from the stable feed by the end of Feb 2021.
Ubuntu 20.04 support will be added in Imunify350 ver 5.6 - by the end of Feb 2021
  1. 22.02.2021 07:02:37
  2. # 8
Olivier Accepted Answer
Posts: 0
Joined: 28.02.2021
0
Votes
Undo
Hello,
I have exactly the same problem.
I want to uninstall imunify360.
I followed the procedure: https://docs.imunify360.com/uninstall/
but this one does not work.
Since this morning I have this error:
Reason: 2021-02-22 06:25:19 INFO: pum is called with arguments: ['--list', '--repo-info', '--json']
2021-02-22 06:25:20 ERROR: E: The repository 'https://repo.imunify360.cloudlinux.com/imunify360/ubuntu/10 buster Release' does not have a Release file.
2021-02-22 06:25:20 ERROR: Exited with returncode 1.
Cordially.
  1. 22.02.2021 08:02:09
  2. # 9
James S Todd Accepted Answer
Posts: 0
Joined: 28.02.2021
0
Votes
Undo
i jumped ship before the Cloud Linux arrived to the rescue and reverted to centos 7. Now knowing that by contacting Cloud Linux for support that the long awaited work around for Debian 10 is now available for Imunify360, I will backup my server when I'm done configuring it and have all my websites transferred over and working, and then reinstall Debian 10 again and restore my server from the backup. I know it's the long way home. I wish I'd contacted Cloud Linux before pulling the pin on Debian 10 the first time around. Live and learn ;). If you want to keep Debian 10 and Imunify360 contact CloudLinux.com support, they are a great help and I'm confident will help you through the process. Good Luck.
  1. 25.02.2021 10:02:09
  2. # 10
Peter Kopf Accepted Answer
Hi there!

Same problem here after a FRESH Plesk 18.x installation on Debian 10. Please solve and notify me about the solution. Thanks.


With best regards from Switzerland,
Peter
  1. 25.02.2021 10:02:49
  2. # 11
  1. 25.02.2021 15:02:00
  2. # 12
Posts: 258
Joined: 31.01.2017
0
Votes
Undo
Hi everyone,

Now, as Imunify360 5.5 is in stable, you can use standard installation procedure for Debian 10.
  1. 26.02.2021 09:02:59
  2. # 13
Peter Kopf Accepted Answer
No... the URL in source.list gives me a 404 error:
https://bit.ly/3dNIfS1

If there are any questions, so please don't hesitate to ask me. Thanks.


With kind regards,
Peter
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Peter Kopf
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.

EU e-Privacy Directive

We use cookies to ensure you get the best experience using our website and services. Read more about it in our Privacy Policy. Please agree to the use of cookies to proceed. Alternatively, you may disable cookies in your browser at any time.

You have declined cookies. This decision can be reversed.

You have allowed cookies to be placed on your computer. This decision can be reversed.