i360: Error in global initialization 1 in Unknown on line 0
Forum
  1. Forums
  2. Imunify360
  3. Imunify360 and Imunify Sensor
  1. Darryl
  2. Tuesday, 17 July 2018
  3.  Subscribe via email
Hi,

We're getting an email bounce and it looks like it's related to imunify:

This message has a from address in edited.server.co.uk but has failed edited.server.co.uk's required tests for authentication. Learn more
This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

pipe to |/usr/local/bin/php -q /home/main/public_html/clients/pipe/pipe.php
generated by [email protected]
(ultimately generated from [email protected])

The following text was generated during the delivery attempt:

------ pipe to |/usr/local/bin/php -q /home/main/public_html/clients/pipe/pipe.php
generated by [email protected]
(ultimately generated from [email protected]) ------

PHP Warning: i360: Error in global initialization 1 in Unknown on line 0

Action: failed
Final-Recipient: rfc822;|/usr/local/bin/php -q /home/main/public_html/clients/pipe/pipe.php
Status: 5.0.0

-----------


Specifically it's the i360: Error in global initialization 1 in Unknown on line 0 part, is this a known error?

When googling for this error I found a stackoverflow page which was written today (not by me) at https://stackoverflow.com/questions/51369498/what-does-i360-error-in-global-initialization-mean-in-php/51375076 so wonder if this is a recent error which has cropped up and if there is a fix?

Regards
Rate this post:
  1. 17.07.2018 22:07:46
  2. # 1
Thomas Accepted Answer
Posts: 0
Joined: 24.08.2019
0
Votes
Undo
I'm seeing the exact same message in my php error log. Started earlier today.
  1. 18.07.2018 11:07:12
  2. # 2
Darryl Accepted Answer
Posts: 7
Joined: 25.04.2018
0
Votes
Undo
Additional info:

PHP error shown in /usr/local/apache/logs/error_log - it's happening a lot around 15k times a day on one server.

PHP Warning: i360: Error in global initialization 1 in Unknown on line 0

I am seeing this error started right after this yum update:

Jul 17 03:50:21 yum[3878714]: Installed: imunify360-php-i360-0.1-10.7.el7.x86_64

It has affected 60% of our servers running imunify but oddly not all, I have checked and they are all running and received this yum update, however I noticed a difference between them though they show the same versions via rpm -qa as some updated almost a month ago and others just yesterday:

The servers that received this yum update on 21/22nd June do not have this issue:

Jun 22 03:19:51 yum[2808147]: Installed: imunify360-php-i360-0.1-10.7.el7.x86_64
Jun 21 17:56:39 yum[1964423]: Installed: imunify360-php-i360-0.1-10.7.el6.x86_64

However the recent ones updated July 17th do exhibit this problem:
Jul 17 00:17:58 yum[2910120]: Installed: imunify360-php-i360-0.1-10.7.el6.x86_64
Jul 17 03:46:35 yum[4032876]: Installed: imunify360-php-i360-0.1-10.7.el7.x86_64
43918 Jul 17 03:50:21 yum[3878714]: Installed: imunify360-php-i360-0.1-10.7.el7.x86_64

Perhaps changes were made to the package without revising version number during this time and it's caused this issue?

Regards
  1. 18.07.2018 11:07:50
  2. # 3
Darryl Accepted Answer
Posts: 7
Joined: 25.04.2018
0
Votes
Undo
Copying the solution posted in the StackOverflow thread here which appears to work, whilst awaiting official confirmation:

-------------------

This issue is caused by Imunify360 because of a recent update to include a feature called "Proactive Defense":

https://www.imunify360.com/blog/meet-imunify360-with-proactive-defense-the-sophisticated-protection-against-any-kind-of-malware-all-in-one-nice-package

To fix this you need to have your host disable the extension over all PHP versions:

edit: even with code selected it's breaking the sed command, please visit https://stackoverflow.com/a/51395106 for the correct sed code, could do with looking at a fix for that too CL ;)

That should fix the problem for the time being.

-------------------

As an addendum I checked the configs and it appears the servers that updated to this i360 PHP version in June didn't implement this PHP module in the CL PHP configurations, whereas the ones updated yesterday did so that's where the difference comes from.
  1. 18.07.2018 20:07:25
  2. # 4
Lewis Accepted Answer
I am also having this issue on CloudLinux running CageFS and Immunify360. The Stack Overflow solution doesn't work for me due to CageFS. Any suggestions welcome.
  1. 18.07.2018 21:07:14
  2. # 5
Darryl Accepted Answer
Posts: 7
Joined: 25.04.2018
0
Votes
Undo
I'm also on CL running CageFS and it works here, I assume you restarted httpd after making the sed modification?

edit: also running lsapi not sure if that is a factor.
  1. 18.07.2018 21:07:47
  2. # 6
Lewis Accepted Answer
Posts: 0
Joined: 24.08.2019
0
Votes
Undo
@Darryl Yes - I've changed the start of the cron job from

php -q
to

/usr/local/bin/ea-php71 -q
and this seems to stop the flood of emails but I'm won't be sure whether the issue has been resolved until tomorrow. I have also just updated the system and an update for Imunify has been installed so this might be a fix.
  1. 19.07.2018 11:07:09
  2. # 7
Timur Irmatov Accepted Answer
Posts: 3
Joined: 24.11.2017
0
Votes
Undo
This is a known problem and it should be fixed by updating Imunify360 to newer stable version, 3.4.2.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.