Disable rule in ssh - request timeout
Forum
  1. Forums
  2. Imunify360
  3. Imunify360 and Imunify Sensor
  1. Morten
  2. Monday, 16 April 2018
  3.  Subscribe via email
Getting this on disabling a rule on some servers:
imunify360-agent rules disable --id 77137928 --plugin modsec --name 'xss injection attempt'
ERROR: request timeout

But some servers respond OK?
Rate this post:
  1. 24.04.2018 07:04:31
  2. # 1
Posts: 187
Joined: 31.01.2017
0
Votes
Undo
This issue will be addressed in one of the following product releases: the task tracking id is DEF-3780 (CLI command timeout will be set to infinity after that)
  1. 23.04.2018 11:04:47
  2. # 2
Morten Accepted Answer
Posts: 5
Joined: 16.04.2018
0
Votes
Undo
Is it possible to increase timeout limit in next verison?

Reason why I get this is:
Error is in Imunify360 script which is disabled rule and then it is waiting until Apache graceful restart is not completed (it requires for applying made changes). Restart, by itself, may take 20-30 seconds or even more from the beginning of initialization. This script is also has timeout limit, which sometimes is exceeded.
  1. 17.04.2018 12:04:29
  2. # 3
Posts: 187
Joined: 31.01.2017
0
Votes
Undo
Morten,

Please submit a ticket with our support so they can help you with solving the problem.
  1. 16.04.2018 14:04:06
  2. # 4
Morten Accepted Answer
Posts: 5
Joined: 16.04.2018
0
Votes
Undo
I had to login to WHM and turn it off there, but in order to have it working httpd should be restarted?
But when using ssh command httpd is not restarted. Why?
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.