PHP selector cPanel API
Forum
  1. Forums
  2. General
  3. Programming for CloudLinux
  1. alexis
  2. Friday, 12 April 2019
  3.  Subscribe via email
Hello,

I wondering if the PHP Selector API is documented somewhere, I can't find anything on the cPanel doc or here on the Cloudlinux website.

I'm not talking about the WHM access or the CLI, I wan't something that is accessible by the end user (the CLI doesn't seems to work if executed inside cagefs).

The only "official" documentation I found is this page : https://documentation.cpanel.net/display/DD/cPanel+API+2+Functions+-+LVEInfo%3A%3AgetUsage

I know for a fact it's not the only fonction available because other fonctions are used in the cPanel php selector module, we can see this on the extension-selector.html.tt file.

I found out the following functions are available :

  • LVEInfo processPHPVersionSelect lveversion={version}
  • LVEInfo hideIfNative
  • LVEInfo showPHPOptTable
  • LVEInfo showPHPExtTable


I can see some other stuff by launching this command but it's not very clear either :

cpapi2 | grep -i lveinfo


I can't find anything on the extension of a PHP extension, it seems to use the cloudlinux.cgi instead.

Anyway, do you have any documentation on this ? How do I change, with the cPanel API, the PHP version and the extension loaded for instance ?

Thank you,
Alexis
Rate this post:
  1. 16.04.2019 17:04:01
  2. # 1
Michael Accepted Answer
Posts: 4
Joined: 29.08.2018
0
Votes
Undo
Hello Alexis,

I believe you're looking for the information found under the End-User section on the following document:

https://docs.cloudlinux.com/selectorctl.html

Can you confirm if this page helps?

Thank you.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.