Forum
  1. Forums
  2. General
  3. General Discussion
  1. Tamas DAJKA
  2. Wednesday, April 29, 2015
  3.  Subscribe via email
Hi All,

some of our users complain about random \"Internal Server errors\" on ther Joomla 1.5/2.5/3.4 or Wordpress pages.

In the /usr/local/apache/logs/error_log I see the following errors:
<code>
[Wed Apr 29 10:04:25.120285 2015] [core:error] [pid 240710] [client x.x.x.x:49174] End of script output before headers: index.php, referer: http://otherdomain.com/wp-login.php
[Tue Apr 28 12:59:29.325574 2015] [core:error] [pid 649284] [client y.y.y.y:57294] Premature end of script headers: index.php, referer: http://domain.com/index.php?page=shop.cart&;option=com_virtuemart&Itemid=1
</code>

Some use PHP 5.3, some php 5.4 (both via cagefs). System is a CentOS 6.5 with cPanel and CloudLinux.

Any suggestions I should check? (I\'ve already checked the statistics and I don\'t see any problems there.
Rate this post:
  1. 29.04.2015 11:04:34
  2. # 1
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Hello,

We have no ready answer for you, this needs to be investigated on the server, better to create a ticket and our support will help you.

Are there any other errors in /usr/local/apache/logs/*log ? Also, what php mode is used? Show us the output of \"/usr/local/cpanel/bin/rebuild_phpconf --current\"
  1. 22.11.2016 08:11:40
  2. # 2
Tamas DAJKA Accepted Answer
Posts: 6
Joined: 01.12.2012
0
Votes
Undo
Hi,

we're still facing this issue, more of our customers reports it on multiple servers, all running CentOS 6.x with cPanel (latest stable).

The occurance of the Internal Server Error is random and not reproducable. The customer acts in the Joomla backend, clicks on a menu item, gets a HTTP 500 ISE, refreshes and voilá, the page loads without error.

There are no other errors in apache/suphp/suexex log :(

I'm a qualified system administrator, so I can debug a few things if someone points me to the right direction. What is the best way to debug this? Can I somehow attach to the corresponding apache process?

Thanks,

     Tom
  1. 22.11.2016 09:11:34
  2. # 3
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Do you use any RLimits in apache configs? Any results with:
grep -i RLimit /usr/local/apache/conf* -Rs

Still would like to see your setup with:
/usr/local/cpanel/bin/rebuild_phpconf --current
  1. 22.11.2016 09:11:42
  2. # 4
Tamas DAJKA Accepted Answer
Posts: 6
Joined: 01.12.2012
0
Votes
Undo
Yes, there are some - cPanel default - RLimits in the config:

 [email protected] [~]# grep -i RLimit /usr/local/apache/conf* -Rs
/usr/local/apache/conf/httpd.conf:RLimitMEM 1153433600
/usr/local/apache/conf/httpd.conf:RLimitCPU 240
/usr/local/apache/conf/httpd.conf:ServerLimit 256
/usr/local/apache/conf/httpd.conf,v:RLimitMEM 1153433600
/usr/local/apache/conf/httpd.conf,v:RLimitCPU 240
/usr/local/apache/conf/httpd.conf,v:ServerLimit 256
/usr/local/apache/conf/httpd.conf,v:RLimitMEM 1153433600
/usr/local/apache/conf/httpd.conf,v:RLimitCPU 240
[email protected] [~]# free
total used free shared buffers cached
Mem: 12169516 11929912 239604 46708 561572 2246976
-/+ buffers/cache: 9121364 3048152
Swap: 2097148 5276 2091872
[email protected] [~]#


My setup is:


 [email protected] [~]# /usr/local/cpanel/bin/rebuild_phpconf --current
Available handlers: suphp dso cgi none
DEFAULT PHP: 5
PHP4 SAPI: none
PHP5 SAPI: suphp
SUEXEC: enabled
RUID2: not installed
[email protected] [~]#


CageFS is also installed.
  1. 23.11.2016 02:11:44
  2. # 5
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Please remove RLimitMEM and RLimitCPU from /usr/local/apache/conf/httpd.conf and restart apache. As far as I know cPanel will not add them back with apache config file rebuild so it is Ok to edit it directly. I bet they are the core of the issue.
  1. 23.11.2016 04:11:51
  2. # 6
Tamas DAJKA Accepted Answer
Posts: 6
Joined: 01.12.2012
0
Votes
Undo
Thank you Bogdan. I've disabled RLimit via  WHM (WHM >> Main >> Service Configuration >> Apache Configuration >> Memory Usage Restrictions), I'll report back the results.

If you have some spare time, can you please explain a bit how is that RLimit can be a core issue?
  1. 29.11.2016 15:11:45
  2. # 7
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
I remember I have seen such errors with RLimits enabled. And, searching with google almost all articles says the same. Another point is that issue is happening not regularly, but sometimes.

Let me know how it goes without RLimits.
  1. 30.11.2016 04:11:32
  2. # 8
Tamas DAJKA Accepted Answer
Posts: 6
Joined: 01.12.2012
0
Votes
Undo
I\'m still waiting for our customers\' feedback. As soon as I\'ve enough feedback I\'ll get back to the forum.
  1. 08.02.2017 10:02:22
  2. # 9
Tamas DAJKA Accepted Answer
Posts: 0
Joined: 22.06.2018
0
Votes
Undo
Unfortunatelly the issue still exists :( Just bumped into it myself with a joomla backend.
  1. 08.02.2017 11:02:45
  2. # 10
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
I am still sure issue has something to do with rlimits.. But, please open a support ticket with us and we will check it in place.
  1. 13.04.2017 08:04:34
  2. # 11
Tamas DAJKA Accepted Answer
Posts: 6
Joined: 01.12.2012
0
Votes
Undo
Issue solved with the help of the support, it was due to and old setting in CSF/LFD, which killed the user's app if they reached a certain memory level (not needed with cloudlinux). Thanks for your support Bogdan.
  1. 13.04.2017 09:04:56
  2. # 12
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Good to hear that, and thanks for the update!
  1. 15.04.2017 08:04:02
  2. # 13
Walid Aweiwi Accepted Answer
Posts: 0
Joined: 22.06.2018
0
Votes
Undo
Hi Tamas DAJKA,

What you did exactly, I have the same issue?

Cpanel support couldn't help me.

BR
  1. 18.04.2017 09:04:11
  2. # 14
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
I suppose it was resolved with whitelisting php in /etc/csf/csf.pignore file.

But also following two options from /etc/csf/csf.conf file should be checked: PT_USERRSS , PT_USERMEM .
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Remove Upload Files (Maximum File Size: 2 MB)
You may insert polls into your post. The poll would then appear in the post.
Vote Options
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.