Error on MySQL Governor install
Forum
For more information on the latest vulnerability (CVE-2018-12130, CVE-2018-12126, CVE-2018-12127, and CVE-2019-11091),
please refer to our blog post
  1. Forums
  2. General
  3. General Discussion
  1. Boeki
  2. Tuesday, 09 November 2010
  3.  Subscribe via email
Hi,

I tried to install the MySQL Governor via the following:

# yum --enablerepo=cloudlinux-updates-testing --disablerepo=cloudlinux-base --disablerepo=cloudlinux-updates install mysql-server mysql

It generated an error:

Loaded plugins: fastestmirror, rhnplugin
Loading mirror speeds from cached hostfile
Excluding Packages in global exclude list
Finished
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package MySQL-server.x86_64 0:5.1.48-1.el5.cloudlinux set to be updated
--> Processing Dependency: perl(DBI) for package: MySQL-server
--> Finished Dependency Resolution
MySQL-server-5.1.48-1.el5.cloudlinux.x86_64 from cloudlinux-updates-testing has depsolving problems
--> Missing Dependency: perl(DBI) is needed by package MySQL-server-5.1.48-1.el5.cloudlinux.x86_64 (cloudlinux-updates-testing)
Error: Missing Dependency: perl(DBI) is needed by package MySQL-server-5.1.48-1.el5.cloudlinux.x86_64 (cloudlinux-updates-testing)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

How do I resolve this?

And incidentally, the CPanel is set to use MySQL 5.0x. Can the yum install use MySQL 5.0x instead? Would there be any problems (from my CPanel users standpoint) if the yum install installs MySQL 5.1x?

Thanks.
Rate this post:
  1. 10.11.2010 08:11:40
  2. # 1
Igor Seletskiy Accepted Answer
Posts: 1196
Joined: 09.02.2010
0
Votes
Undo
If you are using cPanel, try using this script for the install:
# wget http://repo.cloudlinux.com/cloudlinux/sources/install-db-governor
# sh install-db-governor

More info here: http://www.cloudlinux.com/docs/mysqlgovernor.php
  1. 10.11.2010 10:11:38
  2. # 2
Boeki Accepted Answer
Posts: 15
Joined: 09.11.2010
0
Votes
Undo
Does the CPanel script also install MySQL 5.1x? My CPanel servers run MySQL 5.0x. Does the script upgrade the databases, too?
  1. 10.11.2010 11:11:17
  2. # 3
Igor Seletskiy Accepted Answer
Posts: 1196
Joined: 09.02.2010
0
Votes
Undo
It automatically detects the version of MySQL you are running, and installs the right one.
  1. 10.11.2010 11:11:55
  2. # 4
Boeki Accepted Answer
Posts: 15
Joined: 09.11.2010
0
Votes
Undo
great! thanks!

giving it a go later.
  1. 19.11.2010 10:11:26
  2. # 5
Boeki Accepted Answer
Posts: 15
Joined: 09.11.2010
0
Votes
Undo
the install script has these lines:

function checkMySQL(){
res=$(rpm -qa cpanel-MySQL-server | grep cpanel-MySQL-server-$1-1.el5_5)
echo \"$res\"
}

but the repo has -2.el5_5.

this should be fixed. i had to scratch my head several times wondering why dbgovernor won\'t install. it doesn\'t because the mysql check fails.
  1. 19.11.2010 11:11:05
  2. # 6
Igor Seletskiy Accepted Answer
Posts: 1196
Joined: 09.02.2010
0
Votes
Undo
sorry about that... fixing it now.
  1. 19.11.2010 11:11:40
  2. # 7
Igor Seletskiy Accepted Answer
Posts: 1196
Joined: 09.02.2010
0
Votes
Undo
Fixed:
rm -f install-db-governor
wget http://repo.cloudlinux.com/cloudlinux/sources/install-db-governor
sh install-db-governor
  1. 02.12.2010 01:12:44
  2. # 8
Boeki Accepted Answer
Posts: 15
Joined: 09.11.2010
0
Votes
Undo
is it okay to install v3 on cpanel (via yum) on top of v2 installed via script?
  1. 02.12.2010 08:12:22
  2. # 9
Boeki Accepted Answer
Posts: 15
Joined: 09.11.2010
0
Votes
Undo
i proceeded to install anyway as you haven\'t replied.

the yum process completed well but when i run the perl command, i get this:

...skipping 206.217.198.61......server closed connection......connecting to [email protected].Error 404 while fetching URL http://repo.cloudlinux.com//cloudlinux/sources/cpanel/CURRENT/cPpkgversion
...skipping 206.217.198.61......server closed connection......Done
Can\'t call method \"haspkg\" on an undefined value at /usr/share/lve/db_governor/utils/install-db-governor line 59.


how do i fix this?
  1. 02.12.2010 09:12:23
  2. # 10
Boeki Accepted Answer
Posts: 15
Joined: 09.11.2010
0
Votes
Undo
the folder CURRENT does not exist in the repo. only RELEASE is available.

that\'s why the script is getting a 404 error.

how do i fix this?
  1. 02.12.2010 09:12:19
  2. # 11
Alexey Berezhok Accepted Answer
Posts: 35
Joined: 20.04.2010
0
Votes
Undo
Thank you! I have created CURRENT folder, and it should be working now. Could you check?
  1. 02.12.2010 09:12:08
  2. # 12
Boeki Accepted Answer
Posts: 15
Joined: 09.11.2010
0
Votes
Undo
it went on without a hitch this time!

thank you for your usual fast action!
  1. 03.12.2010 11:12:11
  2. # 13
kernow Accepted Answer
Posts: 72
Joined: 06.08.2010
0
Votes
Undo
Is anyone running this on a production server yet? If so is it working OK?
  1. 06.12.2010 14:12:42
  2. # 14
Igor Seletskiy Accepted Answer
Posts: 1196
Joined: 09.02.2010
0
Votes
Undo
We have at least 10 people running it in production right now. Probably more. I think we will go in RC in ~2 weeks, and then release it a month later.
All the bugs for the past few versions were related to the data display/collection, and didn\'t cause any MySQL service interruption.
  1. 24.03.2019 09:03:21
  2. # 15
Robert Smith Accepted Answer
Posts: 0
Joined: 20.06.2019
0
Votes
Undo
It failed for me with a bunch of 404. In my case, I just had to retrieve my MySQL version, which ended up being MariaDB 10.3. In ANY case, you should issue the following commands and not use the Wizard currently, in SSH:


/usr/share/lve/dbgovernor/mysqlgovernor.py --mysql-version=mysqlXXX|mariadbXXX


Use either MySQL or MariaDB depending on what you have, and its version number.
Documentation for accepted script arguments: https://docs.cloudlinux.com/mysql_governor_installation.html

You should get a message that said the version was set correctly.

Now, here's the tricky part. If you have MySQL or MariaDB <= 10.3, issue:


/usr/share/lve/dbgovernor/mysqlgovernor.py --install


If you have the new version of MariaDB 10.3, its currently in beta, and you'll have to issue:



usr/share/lve/dbgovernor/mysqlgovernor.py --install-beta


The script in the wizard seems to fail to detect the currently running MySQL version. Hopefully that gets patched, until it does here's the solution I found to get it to install correctly (WHM, CPanel, CloudLinux7 on CentOS 7)
  1. 01.04.2019 08:04:30
  2. # 16
Inessa Atmachian Accepted Answer
Posts: 1
Joined: 29.08.2017
0
Votes
Undo
For now, the Wizard cannot install packages from beta and it so happened that MariaDB 10.3 is currently in beta so you are having these problems.

We are planning to release MariaDB 10.3 to the stable this week. This will solve this problem.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.