Compatiblity Issue - ESXi 5.5, Cloud Linux 6.5 & VMware Tools
Forum
  1. Forums
  2. General
  3. General Discussion
  1. Wesley Render
  2. Monday, 03 March 2014
  3.  Subscribe via email
After upgrading to ESXi 5.5 I am having issues re-installing the vmware tools in Cloud Linux.  I get the following errors when trying to install VMware Tools from the command line on the guest os.  Any help would be appreciated.  The vmware tools I am trying to install is:  VMwareTools-9.4.0-1399439.tar.gz  (Comes with ESXi, 5.5.0, 1474528  - Latest ESXi Essentials version).

Creating a new initrd boot image for the kernel.
initctl: Job failed to start
Unable to start services for VMware Tools
Also, I notice that the vmci &  vsock kernel modules are for some reason not compiled when I run this version of VMware Tools vmware-config-tools.pl .  With the previous version of the vmware tools installer it would make these modules during install and load them correctly.   I am wondering if the Cloud Linux rpms are not compatible with this version of VMware Tools.  I get the following errors when trying to re-install some of the Cloud Linux rpms:

Running Transaction
Installing : kmod-iolimits-2.6.32-458.23.2.lve1.2.52.el6.x86_64-0.1-101.el6.x86_64 1/2
WARNING: /lib/modules/2.6.32-458.23.2.lve1.2.52.el6.x86_64/misc/vsock.ko needs unknown symbol security_sock_graft
Installing : kmod-lve-2.6.32-458.23.2.lve1.2.52.el6.x86_64-1.2-56.el6.x86_64 2/2
WARNING: /lib/modules/2.6.32-458.23.2.lve1.2.52.el6.x86_64/misc/vsock.ko needs unknown symbol security_sock_graft
Verifying : kmod-lve-2.6.32-458.23.2.lve1.2.52.el6.x86_64-1.2-56.el6.x86_64 1/2
Verifying : kmod-iolimits-2.6.32-458.23.2.lve1.2.52.el6.x86_64-0.1-101.el6.x86_64 2/2
The previous version of ESXi and the VMware Tools that would install correctly with Cloud Linux was:  VMwareTools-9.0.0-782409.tar.gz
Rate this post:
  1. 03.03.2014 22:03:11
  2. # 1
Wesley Render Accepted Answer
Posts: 49
Joined: 16.05.2011
0
Votes
Undo
Here are the kernel packages currently installed on my system.  For further testing I completely uninstalled cloud linux, cagefs and alt php from the server.  I then was able to properly install the vmware tools.  So this seems to indicate a problem with Cloud Linux rpms conflicting with ESXi 5.5 vmware tools.

kernel-2.6.32-458.23.2.lve1.2.48.el6.x86_64
kernel-2.6.32-458.23.2.lve1.2.52.el6.x86_64
dracut-kernel-004-336.el6_5.2.noarch
kernel-firmware-2.6.32-458.23.2.lve1.2.52.el6.noarch
kernel-headers-2.6.32-458.23.2.lve1.2.52.el6.x86_64
kernel-devel-2.6.32-458.23.2.lve1.2.52.el6.x86_64
  1. 05.03.2014 11:03:46
  2. # 2
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Unfortunately we are out of ideas what could be the reason of the issue. Could you please create a trouble ticket to have support team check the server from inside?
  1. 05.03.2014 12:03:37
  2. # 3
Wesley Render Accepted Answer
Posts: 49
Joined: 16.05.2011
0
Votes
Undo
Cloud Linux support was able to help me resolve this issue.  In case anyone else is having this issue with the newer VMware here is how to resolve it:

1. When installing Vmware Tools, At this option select no:
 
Before running VMware Tools for the first time, you need to configure it by invoking the following command: /usr/bin/vmware-config-tools.pl. Do you want this program to invoke the command for you now? [yes] No

2.  Then run "vmware-config-tools.pl --compile"   (Note the --compile option).
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.