Executing mercurial "hg update" will give "abort: out of memory"
Forum
  1. Forums
  2. General
  3. General Discussion
  1. Marco Silva
  2. Wednesday, 02 May 2012
  3.  Subscribe via email
hg process when executed by user will show "abort: out of memory"
Rate this post:
  1. 02.05.2012 05:05:29
  2. # 1
Marco Silva Accepted Answer
Posts: 3
Joined: 02.05.2012
0
Votes
Undo
Since the mercurial version on the official repos is a bit old, I tried installing fr om rpmforge and fr om source, but neither of them work when executing hg with a normal user. If I execute with root, there will be no problem, hg executes as expected.

When I execute \"hg upd ate\" with a normal user I will get a \"abort: out of memory\". I even se tup the LVE for 16GB of ram and 50% CPU, and this won\'t work. So It looks like there is a extra feature thats lim iting mercurial?

Any ideias?

System details:

# uname -a
2.6.32-320.4.1.lve1.1.4.el6.x86_64 #1 SMP Wed Mar 7 06:32:27 EST 2012 x86_64 x86_64 x86_64 GNU/Linux

# python --version
Python 2.6.6

# hg --ver sion (fr om source)
Mercurial Distributed SCM (version 2.2)

# hg update
abort: /usr/lib64/python2.6/lib-dynload/operator.so: failed to map segment fr om shared object: Cannot allocate memory!

# ulimit -a (from a normal user)
core file size (blocks, -c) 200000
data seg size (kbytes, -d) 200000
scheduling priority (-e) 0
file size (blocks, -f) unlim ited
pending signals (-i) 385129
max locked memory (kbytes, -l) 64
max memory size (kbytes, -m) 200000
open files (-n) 100
pipe size (512 bytes, -p) 8
POSIX message queues (bytes, -q) 819200
real-time priority (-r) 0
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlim ited
max user processes (-u) 35
virtual memory (kbytes, -v) 200000
file locks (-x) unlim ited
  1. 02.05.2012 09:05:51
  2. # 2
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
If you are running it as root -- I am pretty sure it is not due to LVE
most likely it is either data seg size (-d) or max memory size (-m) or virtual memory (-v)
I would reset those to unlimited, and try again.
  1. 02.05.2012 09:05:09
  2. # 3
Marco Silva Accepted Answer
Posts: 3
Joined: 02.05.2012
0
Votes
Undo
hmmm ok, so in what does the LVE Memory Limit that I can set in CPANEL affect, since that is set to 8GB now.

and how do I change those limite you mentions (data seg size (-d) or max memory size (-m) or virtual memory (-v) ) ?

Thanks for the help
  1. 02.05.2012 09:05:11
  2. # 4
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
man ulimit will show how to adjust those limits.

LVE memory limits limits cron/shell/php/cgi scripts run by end users. It doesn\'t limit root at all.
  1. 02.05.2012 11:05:32
  2. # 5
Marco Silva Accepted Answer
Posts: 3
Joined: 02.05.2012
0
Votes
Undo
Thanks!

Had to change /etc/bashrc and /etc/profile to set new limits, since it looks like its Cpanel that was setting this limits for SSH connections.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.