yum update error
Forum
  1. Forums
  2. General
  3. General Discussion
  1. Sylvester Nielsen
  2. Tuesday, 20 September 2011
  3.  Subscribe via email
I installed a new cloudlinux 5.6 server and registered using rhnreg_ks.
I see the server in CLN, but get this error trying to run yum.


[[email protected] ~]# yum update
Loaded plugins: fastestmirror, rhnplugin
Loading mirror speeds from cached hostfile
* cloudlinux-base: repo.cloudlinux.com
* cloudlinux-updates: repo.cloudlinux.com
* cloudlinux-x86_64-server-5: de-proxy.cl-mirror.net
Traceback (most recent call last):
File \"/usr/bin/yum\", line 29, in ?
yummain.user_main(sys.argv[1:], exit_code=True)
File \"/usr/share/yum-cli/yummain.py\", line 309, in user_main
errcode = main(args)
File \"/usr/share/yum-cli/yummain.py\", line 178, in main
result, resultmsgs = base.doCommands()
File \"/usr/share/yum-cli/cli.py\", line 345, in doCommands
self._getTs(needTsRemove)
File \"/usr/lib/python2.4/site-packages/yum/depsolve.py\", line 101, in _getTs
self._getTsInfo(remove_only)
File \"/usr/lib/python2.4/site-packages/yum/depsolve.py\", line 112, in _getTsInfo
pkgSack = self.pkgSack
File \"/usr/lib/python2.4/site-packages/yum/__init__.py\", line 662, in <lambda>
pkgSack = property(fget=lambda self: self._getSacks(),
File \"/usr/lib/python2.4/site-packages/yum/__init__.py\", line 502, in _getSacks
self.repos.populateSack(which=repos)
File \"/usr/lib/python2.4/site-packages/yum/repos.py\", line 260, in populateSack
sack.populate(repo, mdtype, callback, cacheonly)
File \"/usr/lib/python2.4/site-packages/yum/yumRepo.py\", line 168, in populate
if self._check_db_ver sion(repo, mydbtype):
File \"/usr/lib/python2.4/site-packages/yum/yumRepo.py\", line 226, in _check_db_version
return repo._check_db_ver sion(mdtype)
File \"/usr/lib/python2.4/site-packages/yum/yumRepo.py\", line 1233, in _check_db_version
repoXML = self.repoXML
File \"/usr/lib/python2.4/site-packages/yum/yumRepo.py\", line 1406, in <lambda>
repoXML = property(fget=lambda self: self._getRepoXML(),
File \"/usr/share/yum-plugins/rhnplugin.py\", line 514, in _getRepoXML
return YumRepository._getRepoXML(self)
File \"/usr/lib/python2.4/site-packages/yum/yumRepo.py\", line 1398, in _getRepoXML
self._loadRepoXML(text=self)
File \"/usr/lib/python2.4/site-packages/yum/yumRepo.py\", line 1388, in _loadRepoXML
return self._groupLoadRepoXML(text, [\"primary\"])
File \"/usr/lib/python2.4/site-packages/yum/yumRepo.py\", line 1372, in _groupLoadRepoXML
if self._commonLoadRepoXML(text):
File \"/usr/lib/python2.4/site-packages/yum/yumRepo.py\", line 1208, in _commonLoadRepoXML
result = self._getFileRepoXML(local, text)
File \"/usr/lib/python2.4/site-packages/yum/yumRepo.py\", line 989, in _getFileRepoXML
cache=self.http_caching == \'all\')
File \"/usr/share/yum-plugins/rhnplugin.py\", line 336, in _getFile
start, end, copy_local, checkfunc, text, reget, cache, size)
File \"/usr/share/yum-plugins/rhnplugin.py\", line 412, in _noExceptionWrappingGet
size = size
File \"/usr/lib/python2.4/site-packages/urlgrabber/grabber.py\", line 936, in urlgrab
return self._retry(opts, retryfunc, url, filename)
File \"/usr/lib/python2.4/site-packages/urlgrabber/grabber.py\", line 854, in _retry
r = apply(func, (opts,) + args, {})
File \"/usr/lib/python2.4/site-packages/urlgrabber/grabber.py\", line 922, in retryfunc
fo = URLGrabberFileObject(url, filename, opts)
File \"/usr/lib/python2.4/site-packages/urlgrabber/grabber.py\", line 1010, in __init__
self._do_open()
File \"/usr/lib/python2.4/site-packages/urlgrabber/grabber.py\", line 1093, in _do_open
fo, hdr = self._make_request(req, opener)
File \"/usr/lib/python2.4/site-packages/urlgrabber/grabber.py\", line 1202, in _make_request
fo = opener.open(req)
File \"/usr/lib64/python2.4/urllib2.py\", line 358, in open
response = self._open(req, data)
File \"/usr/lib64/python2.4/urllib2.py\", line 376, in _open
\'_open\', req)
File \"/usr/lib64/python2.4/urllib2.py\", line 337, in _call_chain
result = func(*args)
File \"/usr/lib64/python2.4/site-packages/M2Crypto/m2urllib2.py\", line 82, in https_open
h.request(req.get_method(), req.get_selector(), req.data, headers)
File \"/usr/lib64/python2.4/httplib.py\", line 813, in request
if v[0] != 32 or not self.auto_open:
IndexError: tuple index out of range
Rate this post:
  1. 20.09.2011 17:09:41
  2. # 1
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
please, try doing:
yum clean all
and see if that helps.

If it doesn\'t help -- could you contact our support, preferably with access to the server.
  1. 21.09.2011 01:09:42
  2. # 2
Sylvester Nielsen Accepted Answer
Posts: 6
Joined: 02.09.2011
0
Votes
Undo
Today it works without any interactions.

I ran yum clean all yesterday and got a little further but ended out with the same error.
Today i ran the same commands and it just works.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.