CentOS upgrade fails
Forum
  1. Forums
  2. General
  3. General Discussion
  1. Sylvester Nielsen
  2. Friday, 02 September 2011
  3.  Subscribe via email
Hi,

I keep getting errors when upgrading my centos servers. Why does this happen?
I use CentOS 6 x86_64 as a xen pv template. cpanel is installed and i use the upgrade script.

The errors are like this:

Error Downloading Packages:
lve-0.9-0.2.el6.x86_64: failed to retrieve getPackage/lve-0.9-0.2.el6.x86_64.rpm from cloudlinux-x86_64-server-6
error was [Errno 14] PYCURL ERROR 51 - \"SSL: certificate subject name \'xmlrpc.cln.cloudlinux.com\' does not match target host name \'ams-proxy.cl-mirror.net\'\"
Rate this post:
  1. 02.09.2011 08:09:23
  2. # 1
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
We are fixing it right now. One of the mirrors has wrong certificate (it was ok for 5.x, but 6.x doens\'t accept it).
  1. 02.09.2011 08:09:05
  2. # 2
Sylvester Nielsen Accepted Answer
Posts: 6
Joined: 02.09.2011
0
Votes
Undo
Ok.. It seems that the upgrade script select wrong kernels too.
It should use kernel-xen but it dosen\'t.

Is there a fix for this also?
  1. 02.09.2011 08:09:52
  2. # 3
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
1. Edit /etc/sysconfig/kernel
Change DEFAULTKERNEL from kernel to kernel-xen
If you don\'t have that file, create it, and populate it with this:

# UPDATEDEFAULT=yes
# new kernels the default
UPDATEDEFAULT=yes

# DEFAULTKERNEL specifies the default kernel package type
DEFAULTKERNEL=kernel-xen

2. Do:
yum install kernel-xen

3. Don\'t skip this step:
rpm -qa|grep kernel
Take all non-xen kernels, and for each of them:
rpm -e kernel-.....
(full version of a kernel)

If you leave any non kernel-xen packages, future yum updates will update those packages as well.
  1. 02.09.2011 08:09:56
  2. # 4
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
That particular mirror should be back to normal, you should be able to update from it now.
  1. 02.09.2011 08:09:45
  2. # 5
Sylvester Nielsen Accepted Answer
Posts: 6
Joined: 02.09.2011
0
Votes
Undo
How do i see if it\'s a xen kernel? I see no kernel with xen in the name.
  1. 02.09.2011 08:09:14
  2. # 6
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
xen kernel come in a package named:
kernel-xen

and when you do uname -r it will show up as:
2.6.32-231.6.1.lve0.9.8.x86_64xen

or something similar
  1. 02.09.2011 08:09:45
  2. # 7
Sylvester Nielsen Accepted Answer
Posts: 6
Joined: 02.09.2011
0
Votes
Undo
Well.. It doesn\'t really seem to work with the xen kernel.


# yum install kernel-xen
Loaded plugins: fastestmirror, rhnplugin
Loading mirror speeds from cached hostfile
* cloudlinux-x86_64-server-6: ams-proxy.cl-mirror.net
Setting up Install Process
Package kernel-2.6.32-231.6.1.lve0.9.8.x86_64 already installed and latest version
Nothing to do


# rpm -qa|grep kernel
kernel-2.6.32-71.29.1.el6.x86_64
kernel-firmware-2.6.32-231.6.1.lve0.9.8.noarch
kernel-devel-2.6.32-231.6.1.lve0.9.8.x86_64
dracut-kernel-004-33.2.el6_0.noarch
kernel-headers-2.6.32-231.6.1.lve0.9.8.x86_64
kernel-2.6.32-231.6.1.lve0.9.8.x86_64
  1. 02.09.2011 10:09:15
  2. # 8
Leonid Kanter Accepted Answer
Posts: 34
Joined: 18.04.2010
0
Votes
Undo
In CL6 regular kernel (without -xen) should be able to act as xen domU kernel, no other kernel is needed.
  1. 02.09.2011 14:09:15
  2. # 9
Sylvester Nielsen Accepted Answer
Posts: 6
Joined: 02.09.2011
0
Votes
Undo
When i boot this kernel it fails. Are you able to see why from this trace?

]# xm console vm107
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 2.6.32-231.6.1.lve0.9.8.x86_64 ([email protected]) (gcc version 4.4.5 20110214 (Red Hat 4.4.5-6) (GCC) ) #1 SMP Tue Aug 23 19:52:10 EEST 2011
[ 0.000000] Command line: console=hvc0 xencons=tty0 root=/dev/xvda1 ro
[ 0.000000] KERNEL supported cpus:
[ 0.000000] Intel GenuineIntel
[ 0.000000] AMD AuthenticAMD
[ 0.000000] Centaur CentaurHauls
[ 0.000000] ACPI in unprivileged domain disabled
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] Xen: 0000000000000000 - 00000000000a0000 (usable)
[ 0.000000] Xen: 00000000000a0000 - 0000000000100000 (reserved)
[ 0.000000] Xen: 0000000000100000 - 0000000080000000 (usable)
[ 0.000000] DMI not present or invalid.
[ 0.000000] last_pfn = 0x80000 max_arch_pfn = 0x400000000
[ 0.000000] init_memory_mapping: 0000000000000000-0000000080000000
[ 0.000000] RAMDISK: 0236e000 - 0447c000
[ 0.000000] No NUMA configuration found
[ 0.000000] Faking a node at 0000000000000000-0000000080000000
[ 0.000000] Bootmem setup node 0 0000000000000000-0000000080000000
[ 0.000000] NODE_DATA [0000000000008000 - 000000000003bfff]
[ 0.000000] bootmap [000000000003c000 - 000000000004bfff] pages 10
[ 0.000000] (7 early reservations) ==> bootmem [0000000000 - 0080000000]
[ 0.000000] #0 [0000000000 - 0000001000] BIOS data page ==> [0000000000 - 0000001000]
[ 0.000000] #1 [000487f000 - 00048a8000] XEN PAGETABLES ==> [000487f000 - 00048a8000]
[ 0.000000] #2 [0000006000 - 0000008000] TRAMPOLINE ==> [0000006000 - 0000008000]
[ 0.000000] #3 [0001000000 - 000234db84] TEXT DATA BSS ==> [0001000000 - 000234db84]
[ 0.000000] #4 [000236e000 - 000447c000] RAMDISK ==> [000236e000 - 000447c000]
[ 0.000000] #5 [000447c000 - 000487f000] XEN START INFO ==> [000447c000 - 000487f000]
[ 0.000000] #6 [0000100000 - 00004d7000] PGTABLE ==> [0000100000 - 00004d7000]
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0x00000001 -> 0x00001000
[ 0.000000] DMA32 0x00001000 -> 0x00100000
[ 0.000000] Normal 0x00100000 -> 0x00100000
[ 0.000000] Movable zone start PFN for each node
[ 0.000000] early_node_map[2] active PFN ranges
[ 0.000000] 0: 0x00000001 -> 0x000000a0
[ 0.000000] 0: 0x00000100 -> 0x00080000
[ 0.000000] SFI: Simple Firmware Interface v0.7 http://simplefirmware.org
[ 0.000000] SMP: Allowing 4 CPUs, 0 hotplug CPUs
[ 0.000000] No local APIC present
[ 0.000000] APIC: disable apic facility
[ 0.000000] PM: Registered nosave memory: 00000000000a0000 - 0000000000100000
[ 0.000000] Allocating PCI resources starting at 80000000 (gap: 80000000:80000000)
[ 0.000000] Booting paravirtualized kernel on Xen
[ 0.000000] Xen version: 3.1.2-238.19.1.el5 (preserve-AD)
[ 0.000000] NR_CPUS:4096 nr_cpumask_bits:4 nr_cpu_ids:4 nr_node_ids:1
[ 0.000000] PERCPU: Embedded 38 pages/cpu @ffff8800048de000 s126680 r8192 d20776 u155648
[ 0.000000] pcpu-alloc: s126680 r8192 d20776 u155648 alloc=38*4096
[ 0.000000] pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3
[ 0.000000] Xen: using vcpu_info placement
[ 0.000000] Built 1 zonelists in Node order, mobility grouping on. Total pages: 515013
[ 0.000000] Policy zone: DMA32
[ 0.000000] Kernel command line: console=hvc0 xencons=tty0 root=/dev/xvda1 ro
[ 0.000000] PID hash table entries: 4096 (order: 3, 32768 bytes)
[ 0.000000] Checking aperture...
[ 0.000000] No AGP bridge found
[ 0.000000] AMD-Vi disabled by default: pass amd_iommu=on to enable
[ 0.000000] Memory: 2001004k/2097152k available (4917k kernel code, 388k absent, 95760k reserved, 6986k data, 1272k init)
[ 0.000000] Hierarchical RCU implementation.
[ 0.000000] NR_IRQS:33024 nr_irqs:304
[ 0.000000] Console: colour dummy device 80x25
[ 0.000000] console [tty0] enabled
[ 0.000000] console [hvc0] enabled
[ 0.000000] installing Xen timer for CPU 0
[ 0.000000] Detected 3200.106 MHz processor.
[ 0.000999] Calibrating delay loop (skipped), value calculated using timer frequency.. 6400.21 BogoMIPS (lpj=3200106)
[ 0.002008] pid_max: default: 1048576 minimum: 301
[ 0.003029] Dentry cache hash table entries: 262144 (order: 9, 2097152 bytes)
[ 0.004145] Inode-cache hash table entries: 131072 (order: 8, 1048576 bytes)
[ 0.004857] Mount-cache hash table entries: 256
[ 0.005175] Initializing cgroup subsys cpuacct
[ 0.005191] Initializing cgroup subsys devices
[ 0.005202] Initializing cgroup subsys freezer
[ 0.005212] Initializing cgroup subsys net_cls
[ 0.005222] Initializing cgroup subsys blkio
[ 0.005343] CPU: Physical Processor ID: 3
[ 0.005353] CPU: Processor Core ID: 0
[ 0.005364] alternatives: switching to unfair spinlock
[ 0.005999] SMP alternatives: switching to UP code
[ 0.007695] ftrace: converting mcount calls to 0f 1f 44 00 00
[ 0.007732] ftrace: allocating 20111 entries in 79 pages
[ 0.009291] Performance Events: unsupported Netburst CPU model 4 no PMU driver, software events only.
[ 0.012936] NMI watchdog disabled (cpu0): hardware events not enabled
[ 0.013547] installing Xen timer for CPU 1
[ 0.013631] SMP alternatives: switching to SMP code
[ 0.015446] installing Xen timer for CPU 2
[ 0.016081] installing Xen timer for CPU 3
[ 0.016418] Brought up 4 CPUs
[ 0.021124] Grant table initialized
[ 0.021141] regulator: core version 0.5
[ 0.021323] NET: Registered protocol family 16
[ 0.025070] PCI: Fatal: No config space access function found
[ 0.028515] bio: create slab <bio-0> at 0
[ 0.029193] ACPI: Interpreter disabled.
[ 0.030053] xen_balloon: Initialising balloon driver.
[ 0.031110] vgaarb: loaded
[ 0.031606] SCSI subsystem initialized
[ 0.032134] usbcore: registered new interface driver usbfs
[ 0.032147] usbcore: registered new interface driver hub
[ 0.033045] usbcore: registered new device driver usb
[ 0.034095] PCI: System does not support PCI
[ 0.034106] PCI: System does not support PCI
[ 0.058183] Switching to clocksource xen
[ 0.089975] pnp: PnP ACPI: disabled
[ 0.090729] NET: Registered protocol family 2
[ 0.091168] IP route cache hash table entries: 65536 (order: 7, 524288 bytes)
[ 0.093719] TCP established hash table entries: 262144 (order: 10, 4194304 bytes)
[ 0.096449] TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
[ 0.097236] TCP: Hash tables configured (established 262144 bind 65536)
[ 0.097260] TCP reno registered
[ 0.097607] NET: Registered protocol family 1
[ 0.097785] Trying to unpack rootfs image as initramfs...
[ 0.187654] Freeing initrd memory: 33848k freed
[ 0.218929] platform rtc_cmos: registered platform RTC device (no PNP device found)
[ 0.220096] audit: initializing netlink socket (disabled)
[ 0.220131] type=2000 audit(1314987544.375:1): initialized
[ 0.235706] HugeTLB registered 2 MB page size, pre-allocated 0 pages
[ 0.237983] VFS: Disk quotas dquot_6.5.2
[ 0.238070] Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
[ 0.238296] msgmni has been set to 3974
[ 0.242863] alg: No test for stdrng (krng)
[ 0.242911] ksign: Installing public key data
[ 0.242929] Loading keyring
[ 0.242962] - Added public key 2A116672B87B7FDE
[ 0.242974] - User ID: Red Hat, Inc. (Kernel Module GPG key)
[ 0.243021] - Added public key D4A26C9CCD09BEDA
[ 0.243033] - User ID: Red Hat Enterprise Linux Driver Update Program <[email protected]>
[ 0.243066] - Added public key ADC9753FB3BC36E3
[ 0.243076] - User ID: Parallels, Inc. (Kernel Module GPG key)
[ 0.243173] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[ 0.243643] io scheduler noop registered
[ 0.243674] io scheduler anticipatory registered
[ 0.243686] io scheduler deadline registered
[ 0.243822] io scheduler cfq registered (default)
[ 0.244118] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[ 0.244192] pciehp: PCI Express Hot Plug Controller Driver version: 0.4
[ 0.244209] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
[ 0.244253] pci-stub: invalid id string \"\"
[ 0.248793] Non-volatile memory driver v1.3
[ 0.248805] Linux agpgart interface v0.103
[ 0.248905] crash memory driver: version 1.1
[ 0.248919] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[ 0.251793] brd: module loaded
[ 0.252871] loop: module loaded
[ 0.252951] input: Macintosh mouse button emulation as /devices/virtual/input/input0
[ 0.253059] Fixed MDIO Bus: probed
[ 0.253151] ehci_hcd: USB 2.0 \'Enhanced\' Host Controller (EHCI) Driver
[ 0.253196] ohci_hcd: USB 1.1 \'Open\' Host Controller (OHCI) Driver
[ 0.253229] uhci_hcd: USB Universal Host Controller Interface driver
[ 0.253411] PNP: No PS/2 controller found. Probing ports directly.
[ 0.254336] mice: PS/2 mouse device common for all mice
[ 0.254682] rtc_cmos: probe of rtc_cmos failed with error -16
[ 0.254746] cpuidle: using governor ladder
[ 0.254759] cpuidle: using governor menu
[ 0.255596] usbcore: registered new interface driver hiddev
[ 0.255645] usbcore: registered new interface driver usbhid
[ 0.255660] usbhid: v2.6:USB HID core driver
[ 0.255806] TCP cubic registered
[ 0.255815] Initializing XFRM netlink socket
[ 0.255836] NET: Registered protocol family 17
[ 0.264592] registered taskstats version 1
[ 0.272529] XENBUS: Device with no driver: device/vbd/2049
[ 0.272546] XENBUS: Device with no driver: device/vbd/2050
[ 0.272565] XENBUS: Device with no driver: device/vif/0
[ 0.272606] drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
[ 0.272665] Initalizing network drop monitor service
[ 0.272886] Freeing unused kernel memory: 1272k freed
[ 0.273898] Write protecting the kernel read-only dat a: 10240k
[ 0.279007] Freeing unused kernel memory: 1208k freed
[ 0.281356] Freeing unused kernel memory: 1828k freed
[ 0.345525] dracut: dracut-004-33.2.el6_0
[ 0.391603] device-mapper: uevent: version 1.0.3
[ 0.392047] device-mapper: ioctl: 4.20.6-ioctl (2011-02-02) initialised: [email protected]
[ 0.399493] udev: starting version 147
[ 0.505102] dracut: Starting plymouth daemon
could not read byte from child: Success
[ 0.613836] xlblk_init: register_blkdev major: 202
[ 0.646844] blkfront: xvde1: barriers disabled
[ 0.649448] blkfront: xvde2: barriers disabled


No root device found

Boot has failed, sleeping forever.
  1. 02.09.2011 14:09:07
  2. # 10
Sylvester Nielsen Accepted Answer
Posts: 6
Joined: 02.09.2011
0
Votes
Undo
And this is the trace when booting the original kernel.

# xm console vm107
Initializing cgroup subsys cpuset
Initializing cgroup subsys cpu
Linux version 2.6.32-71.29.1.el6.x86_64 ([email protected]) (gcc version 4.4.4 20100726 (Red Hat 4.4.4-13) (GCC) ) #1 SMP Mon Jun 27 19:49:27 BST 2011
Command line: console=hvc0 xencons=tty0 root=/dev/xvda1 ro
KERNEL supported cpus:
Intel GenuineIntel
AMD AuthenticAMD
Centaur CentaurHauls
ACPI in unprivileged domain disabled
BIOS-provided physical RAM map:
Xen: 0000000000000000 - 00000000000a0000 (usable)
Xen: 00000000000a0000 - 0000000000100000 (reserved)
Xen: 0000000000100000 - 0000000080000000 (usable)
DMI not present or invalid.
last_pfn = 0x80000 max_arch_pfn = 0x400000000
init_memory_mapping: 0000000000000000-0000000080000000
RAMDISK: 01cc1000 - 03ad3000
No NUMA configuration found
Faking a node at 0000000000000000-0000000080000000
Bootmem setup node 0 0000000000000000-0000000080000000
NODE_DATA [0000000000008000 - 000000000003bfff]
bootmap [000000000003c000 - 000000000004bfff] pages 10
(7 early reservations) ==> bootmem [0000000000 - 0080000000]
#0 [0000000000 - 0000001000] BIOS data page ==> [0000000000 - 0000001000]
#1 [0003ed6000 - 0003ef9000] XEN PAGETABLES ==> [0003ed6000 - 0003ef9000]
#2 [0000006000 - 0000008000] TRAMPOLINE ==> [0000006000 - 0000008000]
#3 [0001000000 - 0001ca0ff8] TEXT DATA BSS ==> [0001000000 - 0001ca0ff8]
#4 [0001cc1000 - 0003ad3000] RAMDISK ==> [0001cc1000 - 0003ad3000]
#5 [0003ad3000 - 0003ed6000] XEN START INFO ==> [0003ad3000 - 0003ed6000]
#6 [0000100000 - 00004dd000] PGTABLE ==> [0000100000 - 00004dd000]
Zone PFN ranges:
DMA 0x00000001 -> 0x00001000
DMA32 0x00001000 -> 0x00100000
Normal 0x00100000 -> 0x00100000
Movable zone start PFN for each node
early_node_map[2] active PFN ranges
0: 0x00000001 -> 0x000000a0
0: 0x00000100 -> 0x00080000
SFI: Simple Firmware Interface v0.7 http://simplefirmware.org
SMP: Allowing 4 CPUs, 0 hotplug CPUs
No local APIC present
APIC: disable apic facility
PM: Registered nosave memory: 00000000000a0000 - 0000000000100000
Allocating PCI resources starting at 80000000 (gap: 80000000:80000000)
Booting paravirtualized kernel on Xen
Xen version: 3.1.2-238.19.1.el5 (preserve-AD)
NR_CPUS:4096 nr_cpumask_bits:4 nr_cpu_ids:4 nr_node_ids:1
PERCPU: Embedded 31 pages/cpu @ffff880003f2f000 s95064 r8192 d23720 u126976
pcpu-alloc: s95064 r8192 d23720 u126976 alloc=31*4096
pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3
Xen: using vcpu_info placement
Built 1 zonelists in Node order, mobility grouping on. Total pages: 516031
Policy zone: DMA32
Kernel command line: console=hvc0 xencons=tty0 root=/dev/xvda1 ro
PID hash table entries: 4096 (order: 3, 32768 bytes)
Checking aperture...
No AGP bridge found
AMD-Vi disabled by default: pass amd_iommu=on to enable
Memory: 2015112k/2097152k available (4939k kernel code, 388k absent, 81652k reserved, 3931k data, 1220k init)
Hierarchical RCU implementation.
NR_IRQS:33024 nr_irqs:304
Console: colour dummy device 80x25
console [tty0] enabled
console [hvc0] enabled
allocated 20971520 bytes of page_cgroup
please try \'cgroup_disable=memory\' option if you don\'t want memory cgroups
installing Xen timer for CPU 0
Detected 3200.108 MHz processor.
Calibrating delay loop (skipped), value calculated using timer frequency.. 6400.21 BogoMIPS (lpj=3200108)
pid_max: default: 32768 minimum: 301
Security Framework initialized
SELinux: Initializing.
Dentry cache hash table entries: 262144 (order: 9, 2097152 bytes)
Inode-cache hash table entries: 131072 (order: 8, 1048576 bytes)
Mount-cache hash table entries: 256
Initializing cgroup subsys ns
Initializing cgroup subsys cpuacct
Initializing cgroup subsys memory
Initializing cgroup subsys devices
Initializing cgroup subsys freezer
Initializing cgroup subsys net_cls
Initializing cgroup subsys blkio
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 0
Performance Events: no PMU driver, software events only.
alternatives: switching to unfair spinlock
SMP alternatives: switching to UP code
ftrace: converting mcount calls to 0f 1f 44 00 00
ftrace: allocating 20293 entries in 80 pages
installing Xen timer for CPU 1
SMP alternatives: switching to SMP code
installing Xen timer for CPU 2
installing Xen timer for CPU 3
Brought up 4 CPUs
devtmpfs: initialized
Grant table initialized
regulator: core version 0.5
NET: Registered protocol family 16
PCI: Fatal: No config space access function found
bio: create slab <bio-0> at 0
ACPI: Interpreter disabled.
xen_balloon: Initialising balloon driver.
vgaarb: loaded
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
PCI: System does not support PCI
PCI: System does not support PCI
NetLabel: Initializing
NetLabel: domain hash size = 128
NetLabel: protocols = UNLABELED CIPSOv4
NetLabel: unlabeled traffic allowed by default
Switching to clocksource xen
pnp: PnP ACPI: disabled
NET: Registered protocol family 2
IP route cache hash table entries: 65536 (order: 7, 524288 bytes)
TCP established hash table entries: 262144 (order: 10, 4194304 bytes)
TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
TCP: Hash tables configured (established 262144 bind 65536)
TCP reno registered
NET: Registered protocol family 1
Trying to unpack rootfs image as initramfs...
Freeing initrd memory: 30792k freed
platform rtc_cmos: registered platform RTC device (no PNP device found)
audit: initializing netlink socket (disabled)
type=2000 audit(1314987786.233:1): initialized
HugeTLB registered 2 MB page size, pre-allocated 0 pages
VFS: Disk quotas dquot_6.5.2
Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
msgmni has been set to 3995
alg: No test for stdrng (krng)
ksign: Installing public key data
Loading keyring
- Added public key 965331713A640F69
- User ID: CentOS (Kernel Module GPG key)
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.4
acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
pci-stub: invalid id string \"\"
Non-volatile memory driver v1.3
Linux agpgart interface v0.103
crash memory driver: version 1.0
Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
brd: module loaded
loop: module loaded
input: Macintosh mouse button emulation as /devices/virtual/input/input0
Fixed MDIO Bus: probed
ehci_hcd: USB 2.0 \'Enhanced\' Host Controller (EHCI) Driver
ohci_hcd: USB 1.1 \'Open\' Host Controller (OHCI) Driver
uhci_hcd: USB Universal Host Controller Interface driver
PNP: No PS/2 controller found. Probing ports directly.
mice: PS/2 mouse device common for all mice
rtc_cmos: probe of rtc_cmos failed with error -16
cpuidle: using governor ladder
cpuidle: using governor menu
usbcore: registered new interface driver hiddev
usbcore: registered new interface driver usbhid
usbhid: v2.6:USB HID core driver
TCP cubic registered
Initializing XFRM netlink socket
NET: Registered protocol family 17
registered taskstats version 1
XENBUS: Device with no driver: device/vbd/2049
XENBUS: Device with no driver: device/vbd/2050
XENBUS: Device with no driver: device/vif/0
drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
Initalizing network drop monitor service
Freeing unused kernel memory: 1220k freed
Write protecting the kernel read-only dat a: 7184k
dracut: dracut-004-33.2.el6_0
device-mapper: uevent: version 1.0.3
device-mapper: ioctl: 4.17.0-ioctl (2010-03-05) initialised: [email protected]
udev: starting version 147
dracut: Starting plymouth daemon
could not read byte from child: Success
xlblk_init: register_blkdev major: 202
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
dracut: Remounting /dev/xvda1 with -o errors=remount-ro,ro
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
dracut: Mounted root filesystem /dev/xvda1
dracut: Switching root
Welcome to CloudLinux Server
Starting udev: udevd[269]: NAME=\"%k\" is superfluous and breaks kernel supplied names, please remove it from /etc/udev/rules.d/60-lve.rules:1

udev: starting version 147
Initialising Xen virtual ethernet driver.
[ OK ]
Setting hostname web01.dk01.hotserv.dk: [ OK ]
Checking filesystems
Checking all file systems.
[ OK ]
Remounting root filesystem in read-write mode: EXT3 FS on xvda1, internal journal
[ OK ]
Mounting local filesystems: [ OK ]
Enabling /etc/fstab swaps: Adding 2097144k swap on /dev/xvda2. Priority:-1 extents:1 across:2097144k SS
[ OK ]
Entering non-interactive startup
loading LVE module
FATAL: Module lve not found.
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
Bringing up loopback interface: [ OK ]
Bringing up interface eth0: JBD: barrier-based sync failed on xvda1 - disabling barriers
[ OK ]
Starting lvectl: error: \"ubc.dentry_check\" is an unknown key
error: lve interface is not available
[FAILED]
Starting system logger: [ OK ]
Retrigger failed udev events[ OK ]
Starting sshd: [ OK ]
Starting Red Hat Network Daemon: [ OK ]

CloudLinux Server release 6.1 (Beta)
Kernel 2.6.32-71.29.1.el6.x86_64 on an x86_64
  1. 02.09.2011 17:09:14
  2. # 11
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
could you post /boot/grub/menu.lst
  1. 06.09.2011 09:09:51
  2. # 12
Leonid Kanter Accepted Answer
Posts: 34
Joined: 18.04.2010
0
Votes
Undo
Please replace \"xvda\" to \"xvde\" in both /boot/grub/grub.conf and /etc/fstab and try to boot our kernel - it should boot.
  1. 06.09.2011 10:09:22
  2. # 13
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
&#1040;s a side note -- this is a temporary solution -- we will fix it in the future.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.