lve-stats Dependencies
Forum
  1. Forums
  2. General
  3. General Discussion
  1. Ellery Harrington
  2. Friday, 29 July 2011
  3.  Subscribe via email
I did an install of CloudLinux on CentOS 5.5-64 on SoftLayer\'s Cloud Servers (XEN PV).

Installation went well, but required using the cloudlinux-updates-testing repository.

However, when I try to install lve-stats, I get the results below.
The CentOS repositories seem to be lacking a lot of packages - are there any good repositories that would contain those required packages?


yum install lve-stats --enablerepo=*
Loaded plugins: fastestmirror, rhnplugin
Profilename: s1.fm7.net
Not licensed
This system is not registered with CLN.
CLN support will be disabled.
Loading mirror speeds from cached hostfile
* cloudlinux-base: repo.cloudlinux.com
* cloudlinux-updates: repo.cloudlinux.com
cloudlinux-updates-testing X | 1.1 kB 00:00
cloudlinux-updates-testing/primary X | 51 kB 00:00
cloudlinux-updates-testing X 203/203
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package lve-stats.noarch 0:0.6-1.el5.cloudlinux set to be updated
--> Processing Dependency: python-matplotlib for package: lve-stats
--> Processing Dependency: mx for package: lve-stats
--> Processing Dependency: numpy for package: lve-stats
--> Running transaction check
---> Package python-matplotlib.x86_64 0:0.91.2-1.el5.rf set to be updated
--> Processing Dependency: pycairo >= 1.2.0 for package: python-matplotlib
--> Processing Dependency: python-tz for package: python-matplotlib
--> Processing Dependency: python-dateutil for package: python-matplotlib
---> Package python-mx-base.i386 0:2.0.4-0.2.el4.rf set to be updated
---> Package python-numpy.x86_64 0:1.3.0-9.2 set to be updated
--> Processing Dependency: libgfortran.so.1()(64bit) for package: python-numpy
--> Processing Dependency: liblapack.so.3()(64bit) for package: python-numpy
--> Processing Dependency: libblas.so.3()(64bit) for package: python-numpy
--> Running transaction check
---> Package libblas3.x86_64 0:3.3.1-6.1 set to be updated
--> Processing Dependency: libgfortran.so.1()(64bit) for package: libblas3
---> Package liblapack3.x86_64 0:3.3.1-6.1 set to be updated
--> Processing Dependency: libgfortran.so.1()(64bit) for package: liblapack3
---> Package python-dateutil.noarch 0:1.2-1.el5.rf set to be updated
---> Package python-matplotlib.x86_64 0:0.91.2-1.el5.rf set to be updated
--> Processing Dependency: pycairo >= 1.2.0 for package: python-matplotlib
---> Package python-numpy.x86_64 0:1.3.0-9.2 set to be updated
--> Processing Dependency: libgfortran.so.1()(64bit) for package: python-numpy
---> Package python-tz.noarch 0:2006p-1.el5.rf set to be updated
--> Finished Dependency Resolution
liblapack3-3.3.1-6.1.x86_64 from scilinux has depsolving problems
--> Missing Dependency: libgfortran.so.1()(64bit) is needed by package liblapack3-3.3.1-6.1.x86_64 (scilinux)
libblas3-3.3.1-6.1.x86_64 from scilinux has depsolving problems
--> Missing Dependency: libgfortran.so.1()(64bit) is needed by package libblas3-3.3.1-6.1.x86_64 (scilinux)
python-matplotlib-0.91.2-1.el5.rf.x86_64 from dag has depsolving problems
--> Missing Dependency: pycairo >= 1.2.0 is needed by package python-matplotlib-0.91.2-1.el5.rf.x86_64 (dag)
python-numpy-1.3.0-9.2.x86_64 from scilinux has depsolving problems
--> Missing Dependency: libgfortran.so.1()(64bit) is needed by package python-numpy-1.3.0-9.2.x86_64 (scilinux)
Error: Missing Dependency: pycairo >= 1.2.0 is needed by package python-matplotlib-0.91.2-1.el5.rf.x86_64 (dag)
Error: Missing Dependency: libgfortran.so.1()(64bit) is needed by package liblapack3-3.3.1-6.1.x86_64 (scilinux)
Error: Missing Dependency: libgfortran.so.1()(64bit) is needed by package python-numpy-1.3.0-9.2.x86_64 (scilinux)
Error: Missing Dependency: libgfortran.so.1()(64bit) is needed by package libblas3-3.3.1-6.1.x86_64 (scilinux)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.


Thanks for your help.
Rate this post:
  1. 29.07.2011 18:07:05
  2. # 1
Igor Seletskiy Accepted Answer
Posts: 1194
Joined: 09.02.2010
0
Votes
Undo
You can see here:

Profilename: s1.fm7.net
Not licensed
This system is not registered with CLN.
CLN support will be disabled.


that your server is not registered, and this is why you cannot get packages.
cloudlinux-updates-testing repository has only beta packages, many of which are unstable.

You should correctly install CloudLinux and register your system. Please, contact helpdesk.cloudlinux.com if you need help with that.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.