Error in Apache Log - LVE enter -1
Forum
  1. Forums
  2. General
  3. General Discussion
  1. Adam Heavens
  2. Monday, 26 April 2010
  3.  Subscribe via email
Hi,

We have the following error on any access to PHP pages on our test server.

The error in apache error log is mod_hostinglimits:Error on LVE enter -1

Static pages and images load fine.

Permissions on device /dev/lve is 777

Can anybody shed any light on this?

Thanks
Rate this post:
  1. 26.04.2010 08:04:57
  2. # 1
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
Could you check if there are any messages in /var/log/messages or dmesg?

Also, which version of kernel are you running?
Does it happen for single domain, all domains?
what is the result of lveps -d
  1. 26.04.2010 09:04:41
  2. # 2
Adam Heavens Accepted Answer
Posts: 14
Joined: 19.04.2010
0
Votes
Undo
This is the error in /var/log/messages : Apr 26 19:45:38 kernel: enter limit exced for lve 503 (2/4294967295)

But the entry for 503 has been removed fr om ve.cfg and the server rebooted.

Kernel: 2.6.18-264.11.1.el5.17.cloudlinux #1 SMP Tue Apr 13 06:46:36 EDT 2010 i686 i686 i386 GNU/Linux

ve.cfg config below

<lveconfig>
<defaults>
<cpu limit=\"100\"/>
<io lim it=\"100\"/>
<other maxEntryProcs=\"2000\"/>
</defaults>
</lveconfig>
  1. 26.04.2010 09:04:29
  2. # 3
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
results lveps -d
  1. 26.04.2010 09:04:14
  2. # 4
Adam Heavens Accepted Answer
Posts: 14
Joined: 19.04.2010
0
Votes
Undo
[email protected] [~]# lveps -d
LVE REF PNO TNO UID GID CPU MEM I/O
[email protected]9 [~]#
  1. 26.04.2010 09:04:09
  2. # 5
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
Do you still get this error? Or did it clear up after reboot?
  1. 26.04.2010 09:04:49
  2. # 6
Adam Heavens Accepted Answer
Posts: 14
Joined: 19.04.2010
0
Votes
Undo
Nope still get the error even after a reboot.

Get this in the browser when calling a PHP page

Service Temporarily Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.15 (Unix) mod_ssl/2.2.15 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at xxx.xxx.xxx.xxx port 80
  1. 26.04.2010 09:04:54
  2. # 7
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
Very strange.
What about output of cat /proc/lve/list

Does dmesg still prints out: enter limit exced for lve 503 (2/4294967295)
for each request.
  1. 26.04.2010 09:04:40
  2. # 8
Adam Heavens Accepted Answer
Posts: 14
Joined: 19.04.2010
0
Votes
Undo
[email protected] [~]# cat /proc/lve/list
veid refs cpu io cpu_usage
503 2 100 100 3729163
[email protected] [~]#

Yes dmesg still shows the same error.
  1. 26.04.2010 09:04:45
  2. # 9
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
For some reason LVE thinks that you are over the limit with number of entry procs.
This message tells us that kernel: enter limit exced for lve 503 (2/4294967295)
First number is number of procs, the second is the limit. So, it looks like the limit is too big, and maybe there is some error due to that.
Actually 4294967295 == (uint32_t)-1 -- so it thinks the limit is -1.
Usually it should have something like (21/20)

Could you try to:
change maxEntryProcs to 30, change cpu limit to 25%
We found this numbers most useful
And try rebooting. That should clear up the issue.
  1. 26.04.2010 09:04:09
  2. # 10
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
My developers told me that this issue can be due to setting CPU limits without setting maxprocentry limits via lvectl tool.
  1. 26.04.2010 09:04:56
  2. # 11
Adam Heavens Accepted Answer
Posts: 14
Joined: 19.04.2010
0
Votes
Undo
Thanks, Changing ve.cfg to the following maxEntryProcs to 30, change cpu limit to 25% didn\'t work until it was set using the lvectl tool.

Thanks for your help!

Am I missing something here? Can we not just edit the ve.cfg file directly? Do all changes have to be completed using lvectl? I assume therefore it is best just to have a default and not set individual LVE limits?
  1. 26.04.2010 10:04:24
  2. # 12
Igor Seletskiy Accepted Answer
Posts: 1200
Joined: 09.02.2010
0
Votes
Undo
You can edit ve.cfg -- but then you need to reboot server (until we fix /etc/init.d/lvectl restart -- it is disabled for now)
Otherwise lvectl is your best choice. The problem with lvectl -- you cannot change value for LVEs that already have been created, unless you do it individually.
So, if the site had a hit, it would have an lve (you can see it in /proc/lve/list)
And you cannot change all of those at the same time with lvectl
  1. 26.04.2010 10:04:15
  2. # 13
Adam Heavens Accepted Answer
Posts: 14
Joined: 19.04.2010
0
Votes
Undo
Igor Seletskiy wrote:
You can edit ve.cfg -- but then you need to reboot server (until we fix /etc/init.d/lvectl restart -- it is disabled for now)
Otherwise lvectl is your best choice. The problem with lvectl -- you cannot change value for LVEs that already have been created, unless you do it individually.
So, if the site had a hit, it would have an lve (you can see it in /proc/lve/list)
And you cannot change all of those at the same time with lvectl


Ah I see, Thanks for clearing that up!
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.