Max MTU size 3616
Forum
  1. Forums
  2. General
  3. General Discussion
  1. Drug-it
  2. Monday, 27 May 2019
  3.  Subscribe via email
We are moving some of our blades from FC to ISCSI, with centos 7.6.1810 3.10.0-957.12.2.el7.x86_64 all went smooth, but with CloudLinux release 7.6 3.10.0-962.3.2.lve1.5.25.8.el7.x86_64 some odd things:

at boot: ip=192.168.1.2:::255.255.255.0::enp2s0f2:none:9000:
ifcfg-enp2s0f2 generated by dracut have MTU="9000"

runtime: ifconfig enp2s0f2 mtu 9000

but result is: enp2s0f2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 3616

Hardware for centos7 and CL blades are identical.
bnx2x: QLogic 5771x/578xx 10/20-Gigabit Ethernet Driver bnx2x 1.712.30-0 (2014/02/10)

Switch and network too.

Any one have any ideas how to change MTU to 9000? :)
Rate this post:
  1. 28.05.2019 08:05:48
  2. # 1
Artem Varlyga Accepted Answer
Posts: 2
Joined: 27.05.2019
0
Votes
Undo
Hello,
most of all the issue related to the different versions of the driver that exists in CentOS and CL kernels
Please, try to find out details using "modinfo"
for example:


~]#ls -la /sys/class/net/eth0/device/driver
\lrwxrwxrwx 1 root root 0 May 28 03:52 /sys/class/net/eth0/device/driver -> ../../../bus/pci/drivers/8139cp

[[email protected] ~]# lsmod | grep 8139cp
8139cp 32012 0
mii 13934 2 8139cp,8139too

~]# modinfo 8139cp
filename: /lib/modules/3.10.0-962.3.2.lve1.5.24.10.el7.x86_64/kernel/drivers/net/ethernet/realtek/8139cp.ko
license: GPL
version: 1.3
description: RealTek RTL-8139C+ series 10/100 PCI Ethernet driver
author: Jeff Garzik <[email protected]>
retpoline: Y
rhelversion: 7.5
srcversion: 9C539E342A707080DB77233
alias: pci:v00000357d0000000Asv*sd*bc*sc*i*
alias: pci:v000010ECd00008139sv*sd*bc*sc*i*
depends: mii
intree: Y
vermagic: 3.10.0-962.3.2.lve1.5.24.10.el7.x86_64 SMP mod_unload modversions
signer: Virtuozzo kernel signing key
sig_key: 3B:0B:64:0A:B5:6B:D0:80:3D:75:BE:F1:9E:51:A6:F5:42:69:5A:34
sig_hashalgo: sha256
parm: debug:8139cp: bitmapped message enable number (int)
parm: multicast_filter_limit:8139cp: maximum number of filtered multicast addresses (int)
  1. 29.05.2019 16:05:22
  2. # 2
Drug-it Accepted Answer
Posts: 2
Joined: 27.05.2019
0
Votes
Undo
Answer from developers:
Our kernel does not support mtu values greater than 4000.

Strange decision in my oppinion, using iSCSI you need 2 frames to read/write 4k, or 3 frames for 8k. Hope they rise this limitation.
  1. 30.05.2019 08:05:24
  2. # 3
Sergey Khristich Accepted Answer
Posts: 140
Joined: 20.05.2019
0
Votes
Undo
Hello,
To help you with this question we need a little bit more information, please create a ticket here https://cloudlinux.zendesk.com/hc/en-us/requests/new
and technical experts will help you asap.
If you have any other questions, feel free to ask here.
Thank you for contacting us.
Marketing Manager
  1. 30.05.2019 14:05:04
  2. # 4
Drug-it Accepted Answer
Posts: 2
Joined: 27.05.2019
0
Votes
Undo
Hm, i got this answer from there:
Our kernel does not support mtu values greater than 4000.
  1. 31.05.2019 10:05:50
  2. # 5
Sergey Khristich Accepted Answer
Posts: 140
Joined: 20.05.2019
0
Votes
Undo
Hello,
Right now there's no way to raise this limit above 4000. We've made a task to the developer's team (internal ID is CLKRN-471); we'll see if we can improve that in the future. Thanks!
Marketing Manager
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.