lsapi - installation
Forum
  1. Forums
  2. General
  3. General Discussion
  1. Wojciech
  2. Wednesday, 15 March 2017
  3.  Subscribe via email
I'm using Cludlinux 7 with cpanel and EasyApache 4

I installed lsapi based on page: http://docs.cloudlinux.com/index.html?apache_mod_lsapi.html

but I can't see lsapi_mod in MultiPHP (there are only standard handlers: suphp, cgi and none)
Should it be visible there ?

How to enable it ?

Wojtek
Rate this post:
  1. 16.03.2017 09:03:33
  2. # 1
Wojciech Accepted Answer
Posts: 2
Joined: 15.03.2017
0
Votes
Undo
I see now. It's strange, that I can't see module lsapi in MultiPHP Handlers, but lsapi overwrites the suphp or cgi.

All works now, bo not in all versions of php. 5.3 and 7.1 don't work

I logs I have: "End of script output before headers: ea-php71"

other php versions have the same modules and settings.

Wojciech
  1. 16.03.2017 20:03:36
  2. # 2
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Hi,

As discussed in https://www.cloudlinux.com/forum/forum11/mod-lsapi - there is no methods to hook into cPanel scripts to show if lsapi is used. So, yes it is normal that cPanel shows suphp/cgi/fcgi whie mod_lsapi is actually in use.

About "End of script output before headers: ea-php71" - not sure what is going on, we would like to check the issue in place. Please create support ticket with https://helpdesk.cloudlinux.com
  1. 17.03.2017 08:03:15
  2. # 3
Marcin Accepted Answer
Posts: 2
Joined: 17.03.2017
0
Votes
Undo
Problem solved - we needed to edit /etc/container/php.handler and insert additional PHP handlers.
  1. 17.03.2017 08:03:23
  2. # 4
Marcin Accepted Answer
Posts: 2
Joined: 17.03.2017
0
Votes
Undo
Hello,
how to get multiphp ini editor to action? The phpinfo() i have information about searching the directory /opt/ etc.. but nothing that is associated with the domain directory client.
  1. 17.03.2017 19:03:56
  2. # 5
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Having two selectors is a bit complicated, better to disable one of it with cPanel's Feature Manager.

Please also review documentation how they works together: http://docs.cloudlinux.com/index.html?php_selector_cpanel.html . As well brief description: http://kb.cloudlinux.com/2017/01/cloudlinux-php-selector-and-cpanel-multiple-php-manager-from-ea4-explained/
  1. 18.03.2017 07:03:40
  2. # 6
Wojciech Accepted Answer
Posts: 0
Joined: 23.08.2019
0
Votes
Undo
We don't want to have two selectors (multiphp and phpselector). Phpselector is disabled in LVE in WHM.

We want to have only multiphp. But when it runs lsapi, changing any options in Php.Ini (in users cpanel) nothing changes. In phpinfo in users folder (where we have another Php version) we see that Php reads his settings only from mail Php setting, but not from local Php.ini.

All we want is using multiphp (lsapi) with possibility to set another Php settings per domain. Is it possible?

W.
  1. 20.03.2017 14:03:54
  2. # 7
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
I have just performed a bunch of tests (cpanel 62.0(build 16), ea-apache24-mod_lsapi-1.1-4.el7 ) and it works as expected. I can select PHP version from cPanel's MultiPHP Manager , and I can change values from cPanel's MultiPHP INI Editor. They are reflected properly on phpinfo page.

I believe I understand the core of your issue. Have you tried same with lsapi disabled?

As far as I know there is a bug in older cPanel versions (v60 has it):
1. When you as a cpanel user modify some settings with MultiPHP INI Editor they are saved into /home/username/public_html/php.ini file.

2. When you as an admin edit some PHP settings from WHM > Software > MultiPHP INI Editor they are saved to /opt/cpanel/ea-php56/root/etc/php.d/local.ini file

However these local.ini is being processed after user's php.ini file so simply overwrites values.


Starting from version 62.0.1 cPanel writes customers values into their php.ini files and also into .user.ini in same directory. If so - lsapi will use .user.ini and will work properly (in my case).

Let me know if this helps.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.