cagefs Installation Problem
Forum
  1. Forums
  2. General
  3. General Discussion
  1. Baby Penguin
  2. Monday, 06 March 2017
  3.  Subscribe via email
Hello,

I am trying to install cagefs but I can not success. I am wondering your comments. Here is my configuration:

CloudLinux 7.3 running on hyper-v with 6cpu and 400GB Generation1 IDE storage.

I run these commands firstly;
yum update -y --enablerepo=cloudlinux-base && yum update -y --enablerepo=cloudlinux-updates and than here we go:


[[email protected] ~]# yum install cagefs --enablerepo=cloudlinux-updates-testing
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package cagefs.x86_64 0:6.0-31.el7.cloudlinux will be installed
--> Processing Dependency: cagefs-lve = 1.17 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: cagefs-safebin = 6.0-31.el7.cloudlinux for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: cagefs-safebin = 6.0-31.el7.cloudlinux for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: cloudlinux-linksafe >= 1-1.12 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-cllib >= 1.2-35 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-simplejson >= 2.2.0 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: lve-utils >= 1.5-36 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: lve-wrappers >= 0.6-11 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: bsock >= 0.09-8 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: cloudlinux-linksafe >= 1-1.12 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-cllib >= 1.2-35 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-simplejson >= 2.2.0 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: lve-utils >= 1.5-36 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: lve-wrappers >= 0.6-11 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: bsock >= 0.09-8 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: pam_lve >= 0.3-10 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-PyYAML for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: tmpwatch for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-PyYAML for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: tmpwatch for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Running transaction check
---> Package alt-python27.x86_64 0:2.7.13-1.el7 will be installed
--> Processing Dependency: alt-python27-libs(x86-64) = 2.7.13-1.el7 for package: alt-python27-2.7.13-1.el7.x86_64
---> Package alt-python27-cllib.x86_64 0:1.2-38.el7.cloudlinux will be installed
--> Processing Dependency: alt-python27-simplejson >= 2.2.0 for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-simplejson >= 2.2.0 for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-jinja2 for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-PyYAML for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-MySQL-python for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-jinja2 for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-PyYAML for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-MySQL-python for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
---> Package cagefs.x86_64 0:6.0-31.el7.cloudlinux will be installed
--> Processing Dependency: cagefs-lve = 1.17 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-simplejson >= 2.2.0 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: lve-wrappers >= 0.6-11 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: bsock >= 0.09-8 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-simplejson >= 2.2.0 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: lve-wrappers >= 0.6-11 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: bsock >= 0.09-8 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: pam_lve >= 0.3-10 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-PyYAML for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: tmpwatch for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-PyYAML for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: tmpwatch for package: cagefs-6.0-31.el7.cloudlinux.x86_64
---> Package cagefs-safebin.x86_64 0:6.0-31.el7.cloudlinux will be installed
---> Package cloudlinux-linksafe.noarch 0:1-1.19.el7 will be installed
---> Package lve-utils.x86_64 0:1.5-41.el7.cloudlinux will be installed
--> Processing Dependency: alt-pylve for package: lve-utils-1.5-41.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-MySQL-python for package: lve-utils-1.5-41.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-docopt for package: lve-utils-1.5-41.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-schema for package: lve-utils-1.5-41.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-lxml for package: lve-utils-1.5-41.el7.cloudlinux.x86_64
--> Processing Dependency: alt-pylve for package: lve-utils-1.5-41.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-MySQL-python for package: lve-utils-1.5-41.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-docopt for package: lve-utils-1.5-41.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-schema for package: lve-utils-1.5-41.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-lxml for package: lve-utils-1.5-41.el7.cloudlinux.x86_64
--> Running transaction check
---> Package alt-pylve.x86_64 0:1.4-1.11.el7.cloudlinux will be installed
--> Processing Dependency: liblve = 1.4-1.11.el7.cloudlinux for package: alt-pylve-1.4-1.11.el7.cloudlinux.x86_64
---> Package alt-python27-cllib.x86_64 0:1.2-38.el7.cloudlinux will be installed
--> Processing Dependency: alt-python27-simplejson >= 2.2.0 for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-simplejson >= 2.2.0 for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-jinja2 for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-PyYAML for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-MySQL-python for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-jinja2 for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-PyYAML for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-MySQL-python for package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64
---> Package alt-python27-docopt.noarch 0:0.6.2-1.el7 will be installed
---> Package alt-python27-libs.x86_64 0:2.7.13-1.el7 will be installed
--> Processing Dependency: alt-sqlite for package: alt-python27-libs-2.7.13-1.el7.x86_64
---> Package alt-python27-lxml.x86_64 0:3.2.4-1.el7 will be installed
---> Package alt-python27-schema.noarch 0:0.3.1-1.el7 will be installed
---> Package cagefs.x86_64 0:6.0-31.el7.cloudlinux will be installed
--> Processing Dependency: cagefs-lve = 1.17 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-simplejson >= 2.2.0 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: lve-wrappers >= 0.6-11 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: bsock >= 0.09-8 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-simplejson >= 2.2.0 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: lve-wrappers >= 0.6-11 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: bsock >= 0.09-8 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: pam_lve >= 0.3-10 for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-PyYAML for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: tmpwatch for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-PyYAML for package: cagefs-6.0-31.el7.cloudlinux.x86_64
--> Processing Dependency: tmpwatch for package: cagefs-6.0-31.el7.cloudlinux.x86_64
---> Package lve-utils.x86_64 0:1.5-41.el7.cloudlinux will be installed
--> Processing Dependency: alt-python27-MySQL-python for package: lve-utils-1.5-41.el7.cloudlinux.x86_64
--> Processing Dependency: alt-python27-MySQL-python for package: lve-utils-1.5-41.el7.cloudlinux.x86_64
--> Finished Dependency Resolution
Error: Package: alt-pylve-1.4-1.11.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
Requires: liblve = 1.4-1.11.el7.cloudlinux
Installed: liblve-1.4-1.13.el7.cloudlinux.x86_64 (@cloudlinux-base)
liblve = 1.4-1.13.el7.cloudlinux
Available: liblve-1.4-1.5.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
liblve = 1.4-1.5.el7.cloudlinux
Available: liblve-1.4-1.7.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
liblve = 1.4-1.7.el7.cloudlinux
Available: liblve-1.4-1.11.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
liblve = 1.4-1.11.el7.cloudlinux
Error: Package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
Requires: alt-python27-MySQL-python
Error: Package: lve-utils-1.5-41.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
Requires: alt-python27-MySQL-python
Error: Package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
Requires: alt-python27-PyYAML
Error: Package: cagefs-6.0-31.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
Requires: alt-python27-simplejson >= 2.2.0
Error: Package: cagefs-6.0-31.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
Requires: alt-python27-PyYAML
Error: Package: cagefs-6.0-31.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
Requires: bsock >= 0.09-8
Error: Package: cagefs-6.0-31.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
Requires: tmpwatch
Error: Package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
Requires: alt-python27-jinja2
Error: Package: cagefs-6.0-31.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
Requires: pam_lve >= 0.3-10
Error: Package: alt-python27-libs-2.7.13-1.el7.x86_64 (cloudlinux-updates-testing)
Requires: alt-sqlite
Error: Package: cagefs-6.0-31.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
Requires: lve-wrappers >= 0.6-11
Error: Package: alt-python27-cllib-1.2-38.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
Requires: alt-python27-simplejson >= 2.2.0
Error: Package: cagefs-6.0-31.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
Requires: cagefs-lve = 1.17
Installed: liblve-1.4-1.13.el7.cloudlinux.x86_64 (@cloudlinux-base)
cagefs-lve = 1.16
Available: liblve-1.4-1.5.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
cagefs-lve = 1.12
Available: liblve-1.4-1.7.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
cagefs-lve = 1.13
Available: liblve-1.4-1.11.el7.cloudlinux.x86_64 (cloudlinux-updates-testing)
cagefs-lve = 1.16
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


If I success about cagefs installation, I will install cPanel. Or should I install cPanel first?

Thank you.
Rate this post:
  1. 06.03.2017 19:03:24
  2. # 1
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Hello,

I believe you have a mix of packages from stable repo and beta. Could you please create a support ticket with us so we can check it precisely?


Overall it's better to install cPanel first, so cagefs can create all needed hooks. However, nothing critical, just reinstall cagefs and it should correct things.
  1. 07.03.2017 05:03:00
  2. # 2
Baby Penguin Accepted Answer
Posts: 1
Joined: 06.03.2017
0
Votes
Undo
Hello Bogdan Thank you so much. Now, I am going to create a ticket.
  1. 26.05.2019 17:05:43
  2. # 3
ios man Accepted Answer
Posts: 8
Joined: 26.05.2019
0
Votes
Undo
it just kills the php process dead in it's tracks without allowing it to run any registered shutdown functions , Optimally I'd like there to be two timeouts . so cagefs can create all needed hooks. However , nothing critical.
  1. 28.05.2019 16:05:25
  2. # 4
Sergey Khristich Accepted Answer
Posts: 141
Joined: 20.05.2019
0
Votes
Undo
Hello,
Please let us know if you have any questions.
Thanks in advance!
Marketing Manager
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.