LveManager Panelless fails to start with "No module named 'aiohttp_jinja2'" error
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and Other Control Panels
  1. Darren Poulton
  2. Thursday, 07 January 2021
  3.  Subscribe via email
Hi folks, I've got a head-scratcher here ...

I've done a fresh install at DigitalOcean from an image of CloudLinux7.9 (yes, I've booted the right kernel and verified using uname). On top of that, I've installed a little open source CP called CyberPanel (which is really quite cool - you should check it out). I'm trying to start the lvemanager service, but keep getting the following error:

ModuleNotFoundError: No module named 'aiohttp_jinja2'

Yes, I've installed aiohttp-jinja2 using pip ... no it doesn't matter whether I use --user or not (error happens both ways)

One thing that concerns me - whenever I run cldetect --check-license, it tells me "No valid license found" - even though checking using the tool at https://cln.cloudlinux.com/ returns a valid license just fine (license was activated when I booted the image and is not an IP-based license ... it IS a trial license though).

I'm out of ideas, and thought you fine folks might be able to come up with a few. Any help greatly appreciated and will receive a hearty thumbs-up emoji (if I can find one here) :p
Rate this post:
  1. 08.01.2021 11:01:10
  2. # 1
Posts: 257
Joined: 31.01.2017
0
Votes
Undo
Hi Darren,

First, make sure the system is registered by running:

yum install rhn-setup --enablerepo=cloudlinux-base
/usr/sbin/rhnreg_ks --activationkey=<activation key>
cldetect --check-license


If the previous returns no errors, run:

yum install alt-python37-devel
yum reinstall lvemanager
  1. 08.01.2021 13:01:58
  2. # 2
Darren Poulton Accepted Answer
Posts: 0
Joined: 26.02.2021
0
Votes
Undo
Hi Alexandre,

Thanks for getting back to me.

As stated, rhn-setup is installed, my activation key has been registered using `rhnreg_ks` and the server is displayed under my control panel at cloudlinux.com. When I use the license check at cloudlinux.com, it returns a valid license message - but when I use the `cldetect --check-license` command-line function, it returns the error "No valid license found". I've re-run the registration I several times, and `cldetect` still returns an invalid license error.

After `reinstall lvemanager`, I'm still getting the ModuleNotFoundError: No module named 'aiohttp_jinja2' error.
  1. 08.01.2021 15:01:32
  2. # 3
Posts: 257
Joined: 31.01.2017
0
Votes
Undo
Darren,

We've removed the server from your trial key just to exclude licensing issues, so please register the system once again. If the issue persists, do not hesitate to submit a ticket on https://cloudlinux.zendesk.com
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Darren Poulton
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.

EU e-Privacy Directive

We use cookies to ensure you get the best experience using our website and services. Read more about it in our Privacy Policy. Please agree to the use of cookies to proceed. Alternatively, you may disable cookies in your browser at any time.

You have declined cookies. This decision can be reversed.

You have allowed cookies to be placed on your computer. This decision can be reversed.