Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and DirectAdmin
  1. Daniel Jansen
  2. Sunday, November 03, 2013
  3.  Subscribe via email
Hi,

I have a server with cloudlinux and directadmin. Now i want to install nagios client on the machine. 



While the install start i get the following error's:

--> Finished Dependency Resolution
Error: Package: nagios-plugins-pgsql-1.4.16-5.el6.x86_64 (epel)
           Requires: libpq.so.5()(64bit)
Error: Package: nagios-3.5.1-1.el6.x86_64 (epel)
           Requires: php
Error: Package: nagios-3.5.1-1.el6.x86_64 (epel)
           Requires: httpd
Error: Package: nagios-plugins-mysql-1.4.16-5.el6.x86_64 (epel)
           Requires: libmysqlclient.so.16(libmysqlclient_16)(64bit)
Error: Package: nagios-plugins-sensors-1.4.16-5.el6.x86_64 (epel)
           Requires: /usr/bin/sensors
Error: Package: nagios-plugins-disk_smb-1.4.16-5.el6.x86_64 (epel)
           Requires: /usr/bin/smbclient
Error: Package: nagios-plugins-rpc-1.4.16-5.el6.x86_64 (epel)
           Requires: /usr/sbin/rpcinfo
Error: Package: nagios-plugins-mysql-1.4.16-5.el6.x86_64 (epel)
           Requires: libmysqlclient.so.16()(64bit)
Error: Package: nagios-plugins-ntp-perl-1.4.16-5.el6.x86_64 (epel)
           Requires: /usr/sbin/ntpdate
Error: Package: nagios-plugins-snmp-1.4.16-5.el6.x86_64 (epel)
           Requires: /usr/bin/snmpgetnext
Error: Package: nagios-plugins-ntp-perl-1.4.16-5.el6.x86_64 (epel)
           Requires: /usr/sbin/ntpq
Error: Package: nagios-plugins-snmp-1.4.16-5.el6.x86_64 (epel)
           Requires: /usr/bin/snmpget
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


I installed nagios by:

rpm -Uvh http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
yum -y install nagios nagios-plugins-all nrpe

Hope you van help me out!
Rate this post:
  1. 03.07.2017 04:07:54
  2. # 1
uiaciel Accepted Answer
Posts: 0
Joined: 23.09.2018
0
Votes
Undo
Install nagios with command

yum --enablerepo=epel -y install nrpe nagios-plugins
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Remove Upload Files (Maximum File Size: 2 MB)
You may insert polls into your post. The poll would then appear in the post.
Vote Options
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.