Yum update problem with Cloudlinux installed
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and Plesk
  1. Glenn Taylor
  2. Tuesday, 03 March 2020
  3.  Subscribe via email

I noticed a problem with YUM not running updates that are managed by Plesk when Cloudlinux is installed.

When I run Check for Updates in Plesk, it tells me YUM is locked and it also won't install updates. For example, there's been 9 Imunify360 updates available for weeks which appear in Plesk but they never update.

This error has appeared twice in Plesk: Warning: Information on some packages might not be actual: inconsistencies were detected in the system's package manager database. Please resolve this issue manually.

I then try and run 'yum update' from CLI and get different errors.

1. [[email protected] tmp]# yum update
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from CLN.
Existing lock /var/run/yum.pid: another copy is running as pid 1593649.
Another app is currently holding the yum lock; waiting for it to exit...

I had to use rm -f /var/run/yum.pid a few times before i could run yum update.

It then showed 104 updates which then finally appeared in plesk.

2. On another server, Yum generated Disk i/o error. I ran yum update again and it worked.

Something is not quite right with Yum when Cloudlinux is installed as it seems to take over yum updates and locks Plesk out or creates conflicts with Plesk over control of Yum which prevents regular system updates which Plesk should be managing.

This is fyi.
Rate this post:
  1. 04.03.2020 09:03:46
  2. # 1
Sergey Khristich Accepted Answer
Posts: 504
Joined: 20.05.2019
Hello Glenn,
Thank you very much for the detailed comment and the information!
If the updates hang for a long time - this can be a problem, can you open a support ticket https://cloudlinux.zendesk.com/hc/en-us/requests/new so we can take a closer look at your system?
You can post the ticket number here and we'll link this thread to it.
Thank you.
Marketing Manager
  • Page :
  • 1

There are no replies made for this post yet.
Be one of the first to reply to this post!
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.

EU e-Privacy Directive

We use cookies to ensure you get the best experience using our website and services. Read more about it in our Privacy Policy. Please agree to the use of cookies to proceed. Alternatively, you may disable cookies in your browser at any time.

You have declined cookies. This decision can be reversed.

You have allowed cookies to be placed on your computer. This decision can be reversed.