1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and Plesk
  1. Stéphan Schamp
  2. Monday, 04 August 2014
  3.  Subscribe via email
This is _NOT_ for production and will cripple fastcgi (aka native php).

THIS IS PURELY FOR TESTING DO NOT USE THIS ON A PRODUCTION SERVER



cat <<"EOF" > /var/www/vhosts//httpdocs/.htaccess
DirectoryIndex index.php index.html
AddType application/x-httpd-lsphp .php5 .php4 .php .php3 .php2 .phtml .php
EOF
chown :psacln /var/www/vhosts//httpdocs/.htaccess



cat <<"EOF" > /var/www/vhosts//httpdocs/phpinfo.php
EOF
chown :psacln /var/www/vhosts//httpdocs/phpinfo.php





yum -y install liblsapi liblsapi-devel --enablerepo=cloudlinux-updates-testing
yum -y install mod_lsapi --enablerepo=cloudlinux-updates-testing
/usr/bin/switch_mod_lsapi --setup

/usr/bin/cl-selector --select=php --version=5.6 --user=

mv /etc/httpd/conf.d/php.conf{,.bak}
mv /etc/httpd/conf.d/fcgid.conf{,.bak}
ln -s /usr/sbin/sulsphp /usr/local/bin/lsphp
/usr/sbin/cagefsctl --force-update
service httpd restart


Now go to http:///phpinfo.php
It should read: 
Server APILiteSpeed V6.6
Rate this post:
  1. 22.10.2014 18:10:23
  2. # 1
Thomas Gross Accepted Answer
Posts: 1
Joined: 22.10.2014
0
Votes
Undo
Hi Stéphan,

Good to read you're going the same way as us - and we're seeing good results using Plesk/CL/php-selector/lsapi

Just a reminder where I got hit with this:

>> mv /etc/httpd/conf.d/php.conf{,.bak}

May I suggest to add a

touch /etc/httpd/conf.d/php.conf

as otherwise your next update of php will ship it's own file (as there is no one currently in /etc/httpd/conf.d/) and suddenly your lsapi starts to break. I've been hit and creating the file fixed that ...

Cheers,
Thomas
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.