EasyApache 4
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Karl Fleming
  2. Tuesday, 13 January 2015
  3.  Subscribe via email
Upcomming EasyApache 4 Announcement
Rate this post:
  1. 13.12.2016 13:12:34
  2. # 101
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
It depends from server to server, however, usually conversion process takes ~20 minutes. Yes, apache is down just few moments during the conversion. Suppose not more then for 1 minute.
  1. 13.12.2016 21:12:37
  2. # 102
Scott Mutter Accepted Answer
Posts: 56
Joined: 23.04.2014
0
Votes
Undo
I wouldn't give you a dime for this EA4 conversion

Tried twice, and it's mucked up both times.  This time everything changed back to native (?) PHP, PHP version 5.4.  PHP 5.4 isn't even installed.

I'm just going to give up on this whole piece of crap.  MAJOR PITA.
  1. 16.12.2016 02:12:44
  2. # 103
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Strange to hear that, we already had a bunch number of successfull convertions to EA4. I would like to check the issue, do you have any ticket created with us already?
  1. 22.12.2016 21:12:29
  2. # 104
Saeed M Accepted Answer
Posts: 1
Joined: 22.12.2016
0
Votes
Undo
Hi Bogdan,

I am in middle of a server migration and the new servers are setup as fresh installs of cpanel/cloudlinux. One thing seems not to be working for me. We need PHP selector but when I have EA4 in place and go to cpanel->php selector I do not see any old versions installed. I believe with EA4, I should not yum group install alt-php packages used to be for php selector. What am I missing?

We are also aiming to have LiteSpeed installed on our servers but not yet installed, so is EA4 compatible with LiteSpeed? Do I need to install alt-php packages for LiteSpeed ?

Regards.
  1. 26.12.2016 03:12:09
  2. # 105
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Hi,

You still need alt-php packages installed to be available from our PHP-Selector page. It\'s a bit confusing, however, you will get two PHP-selectors, one from cPanel, called \'Multiple PHP manager\' which works only with ea-php* packages, and one from us \'Select PHP version\' which works with alt-php* packages. Recommend you disabling one from WHM > Feature Manager.

Litespeed is supported with EA4 and our selector, but yes it still needs alt-php packages.
  1. 26.12.2016 11:12:51
  2. # 106
Scott Mutter Accepted Answer
Posts: 56
Joined: 23.04.2014
0
Votes
Undo
Just to close out about the issues I was experiencing.  I was able to fix mine by running EasyApache3 prior to attempting the conversion script.  Apparently I'm missing something from EA3 and recompiling everything from EA3 puts all of that in place.  I do have to rerun the enable enable mod_lsapi stuff after running EA3 and make sure everything is still using mod_lsapi before running the EA4 conversion script.  And I do have to rerun the mod_lsapi enable stuff after the EA4 conversion.  But it's all fairly seamless.
  1. 26.12.2016 13:12:27
  2. # 107
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
Good to hear that! Thanks for the follow up.
  1. 30.01.2017 08:01:10
  2. # 108
Hary Accepted Answer
Posts: 0
Joined: 25.08.2019
0
Votes
Undo
What i must choose? multiphp or php selector?
  1. 30.01.2017 15:01:18
  2. # 109
Bogdan Accepted Answer
Posts: 709
Joined: 26.06.2013
0
Votes
Undo
What i must choose? multiphp or php selector?


As you are asking this on CloudLinux forum - better to use our PHP-Selector ! :)


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.