cURL support
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Kevin Morrison
  2. Saturday, 29 November 2014
  3.  Subscribe via email
Looking at the selectors it appears that cURL is installed and enabled by default. However I have an extension in a Joomla site that requires it and it is throwing a warning even though looking at the php info shows cURL is running. Here is a typical warning message that I am getting.


Warning: curl_exec() has been disabled for security reasons in /home/***/public_html/administrator/components/com_jfbconnect/views/jfbconnect/view.html.php on line 71

When I set the site to run the default PHP version which also has cURL running the warning goes away. However no matter what PHP selector I choose in cPanel the warning returns. What am I missing and why are extensions that require cURL telling me it is not enabled?
Rate this post:
  1. 29.11.2014 18:11:05
  2. # 1
Laurens Dragicevic Accepted Answer
Posts: 4
Joined: 27.11.2014
0
Votes
Undo
Not sure, not a expert in this area but you will have to remove it from php.ini 

You will have to remove curl_exec from disabled_functions= 

I'm not sure about the directory, but the locator got a own directory with a php version.

- It does not mean it is not loaded, it probably is. But it is disabled because someone thinks it might cause security issues.

The directory is probably /opt/alt/php5x/
  1. 29.11.2014 18:11:31
  2. # 2
Kevin Morrison Accepted Answer
Posts: 11
Joined: 25.09.2013
0
Votes
Undo
That was the problem, thanks Laurens...
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.