PHP Manager Question
Forum
  1. Forums
  2. CloudLinux and Control Panels
  3. CloudLinux and cPanel
  1. Hostking
  2. Monday, 10 June 2013
  3.  Subscribe via email
PHP Manager Question
Rate this post:
  1. 10.06.2013 04:06:33
  2. # 1
Hostking Accepted Answer
Posts: 38
Joined: 07.11.2012
0
Votes
Undo
Hi Guys,

Quick question around PHP Manager. I have customers that can:

1. Add their own php.ini in their www folder and when loading phpinfo file I can see that it actually looks at this file. Any way to disable this?
2. Clients can disable within PHP Manager suhosin. Any way to not allow them to disable this aswell by unchecking it in PHP Manager?

Thanks
  1. 24.06.2013 16:06:25
  2. # 2
Hostking Accepted Answer
Posts: 38
Joined: 07.11.2012
0
Votes
Undo
Any ideas?
  1. 24.06.2013 16:06:02
  2. # 3
Igor Seletskiy Accepted Answer
Posts: 1195
Joined: 09.02.2010
0
Votes
Undo
1. It depends what you are using (control panel/suPHP or mod_fcgid)
Basically -- you need to disable all of those parameters:
 SuPHP_ConfigPath, PHPRC, PHP_INI_SCAN_DIR

2. For now you cannot force any module to be used. Also, suhoshin does not work correctly on php5.4 and up.
  1. 26.06.2013 15:06:50
  2. # 4
Hostking Accepted Answer
Posts: 38
Joined: 07.11.2012
0
Votes
Undo
Hi,

I\'m trying to restrict clients fr om not using their own php.ini files but able to use php 5.3, php 5.4 or php5.5
I\'m using suPHP

When I do the leave suphp as default they can use their own php.ini and make changes.

When I do the following:



[handlers]
;Handler for php-scripts
application/x-httpd-php5=\"php:/usr/bin/php\"
application/x-httpd-php54=\"php:/usr/bin/php\"
application/x-httpd-php55=\"php:/usr/bin/php\"

;Handler for CGI-scripts
;x-suphp-cgi=\"execute:!self\"

[phprc_paths]
;Uncommenting these will force all requests to that handler to use the php.ini
;in the specified directory regardless of suPHP_ConfigPath settings.
application/x-httpd-php5=/opt/alt/php53/etc/php.ini
application/x-httpd-php54=/opt/alt/php54/etc/php.ini
application/x-httpd-php55=/opt/alt/php55/etc/php.ini



It seems to work better and php versions change via PHP selector only the php.ini always points to:

/opt/alt/php53/etc/php.ini


Any way to make it change php versions but also sel ect the correct php.ini linked to the /opt directory under suphp and restricting them to non other than those 3 global php.ini files.
That\'s what puzzles me a bit.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf
• Insert • Remove Upload Files (Maximum File Size: 2 MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.